Windows 8 issue, please read

If I recall correctly then the WinUSB driver doesn’t work with the bootloader… :frowning:

Well thats true, you can not install the WinUSB driver (GHI_NETMF_WinUsb) for Bootloader, because it simply does not match.
But when the matching BootLoader driver (GHI_Bootloader_Interface) is installed, the device is shown with an exclamation mark in Device Manager and the Message ‘USB device can not be started’.

By this we can not update the Firmware using this Win 8 Laptop.

i have Windows 8 x64 pro and i cannot reach to use the Fez Spider.
When i connect the device to my PC i hear the classic sound (“bing bong”) but when i try to use the firmware updater it says that cannot connect to device.
what am i wrong ???

telling us noises is great, at least something’s enumerating on the USB bus, but please show us screen shots of your Device Manager list in both the “normal” switch mode and the “bootloader” switch mode.

I have same problems with win8, the driver installation failed and is not possible to install driver from device manager.
I have latest firmware in my cerberus mb:
ClrInfo.clrVendorInfo: Copyright GHI Electronics, LLC
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: Apr 25 2013
SoftwareVersion.CompilerVersion: 410713

Any ideas?

Device Manager shows what exactly? Does the event log report anything about the failure? If the driver fails to install, can you capture screen shots along the way? I don’t have a Cerbuino, but I have been using Win8 on many of my other Fez-line products with no issues like drivers failing to install.

But if you are seeing that info then the driver is installed! This should help

I see this info from a Win7 PC :slight_smile: but when I try to plug my device on Win8 PC the driver installation failed.

I found a workaround.
I think the problem is in Setup.exe launcher program on Win8 because I restore my Win8 and then manual install driver directly from \GHI NETMF v4.2 and .NET Gadgeteer Package (04-30-2013)\Installation Files\GHI NETMF USB Drivers x64 directory. The setup correctly install driver. Later I installed other software but not the driver. Now all works fine.
I think Setup.exe launcher doesn’t match correctly x64 Win8 version and launch x86 driver setup.

I use widows 8 64 bit

I am unable to install bootloader drivers on my Win 8 64 system for Spider I.

@ mhectorgato - i had to turn off digital signature check, then all go…

Yes, EMX boot loader does not on some machines, G120 does! What is mind boggling is that they are almost identical.

So how do you suggest that i use my Spider?

Didn’t see an option.

With SDK becoming at or near its final stability stages, there will be no need to update TinyBooter anymore. You will see this in the new coming updater. Unfortunately, should there is a need to update tinyBooter, then a different machine need to be used.

We will see if we can make this easier somehow, EMX was made years before windows 8 was out so it would have been impossible to test :wink:

@ mhectorgato - I’m talking about turning off widows driver check wotzit and forcing the driver to install, twoz the only way i could update on win8 a couple of sdks ago…

Ok I’ll give that a swing … last time I ran into these hurdles was Oct, the time Win8 came out and I got my laptop.

Hey there,

I am having similar issues trying to get the drivers installed on Windows 8 but for the Fez Game-O device. The device switches one but absolutely nothing appears when plugging the device into a USB port. I tried from a hub, USB 2.0 and 3.0 direct with no success.

Trying to update the drivers manually also fails. No drivers are found online and manually pointing to C:\Program Files\GHI Electronics\GHI NETMF USB Drivers\USB Drivers\ has no effect claiming no valid drivers are found.

Reading this article ( mentions a WinUSB driver I wanted to try which is not included in the normal download and I can’t find a separate download for it anywhere obvious.

Just to confirm I also get no devices in Visual Studio 2012 when selecting USB as the transport under .NET Micro Framework project settings.

I’m completely out of ideas on how to get this device to be detected in Windows 8 and 8.1. Any help here would be greatly appreciated since I cannot use my new Game-O for any development.


Welcome Werner to the forum ! Sorry to hear you have a challenge getting this working which has bought you here :frowning:

Anyway, can you do a test for me. Can you show us another Device Manager picture when you DON’T have the Game-O connected? I want to be sure the unknown device disappears. The error message displayed there (Device Descriptor request failed) is intriguing and might help GHI and others to figure out what that might be, but basically I think it’s related to unstable USB data communications, that could actually point to a potential hardware issue on your device, or your cable, but I don’t think we’ll be sure until you can confirm that this device disappears when you disconnect the Game-O.

Until the device descriptors can be read, Windows won’t be able to figure out what driver might work - so there’s no point re-testing the driver update portion until we get a different device appearing here.

I’m positive we have great folks here to help troubleshoot, and we’ll get you working