Windows 8 issue, please read

On my Win7 64 system at the office - uninstalled previous GHI; installed absolute latest, plugged in the Spider (into a port that has the SS which iirc means USB3).

The toast said it was installing the drivers and few seconds later it showed that it installed a “GHI .NET Micro Framework USB Debugging Interface”.

At lunch time today I’ll update the offending Win8 system.

@ mhectorgato - A release will be out in few hours, please use that one.

Will do – to confirm, is this release an update to the Insider’s version from last night?

We did couple minor changes on top of the insider release so wait for new one please.

Ok thanks! Appreciate the help/effort.

I am having trouble getting my drivers installed on my desktop. I have Windows 8 64bit with a bunch of usb 2.0 ports. I installed and re-installed the GHI electronics package [].

However, I cannot install the drivers. I use the location [C:\Program Files\GHI Electronics\GHI NETMF USB Drivers\USB Drivers\GHI_NETMF_Interface]
Windows says it could not find driver software for your device.

I am out of ideas to troubleshoot. I have a FEZ Spider I am trying to connect. EMX Version 4.2.5.

Please help…

install the latest GHI SDK, which is 4.2.7.

@ Weston Bridgewater - What if you try the WinUSB drivers folder? What happens when you put the device in boot loader? (be pushing the 3 switches)

I installed the latest one already on my computer.

@ Gus - I tried the driver folder and that had the same result. When I do the switches, my screen turns white.

Do not worry about the screen. What do you see in device manager.

@ Gus - See attached Image

Well I re-flashed the FEZ Spider with a Windows 7 laptop I have. I plugged it into my desktop and it stated installing drivers for device EMX. I was hoping I could get it working with Windows 8 but it is good to have a backup solution.

The attached image shows success. I don’t know why it would not work before though…corrupt firmware?

What is your firmware version loaded on spider?

that is not the latest firmware

Yeah, but I had to install the latest SDK [4.2.7] on my desktop then had trouble getting the drivers to install.

Do you have to update the firmware to the latest before the drivers will install properly?

This thread is to help us understand and resolve issues with the new win8 and we can only do this if info provided here are using the latest firmware. No guarantee the new firmware will fix it but that will be the start.

Ok, thanks for the suggestions. I learned something today :slight_smile:

In case it helps anybody, I had to update couple of FEZ Cerberus boards on Win 8 x64 recently. The serial part was without problems, and the MFDeploy was successfully pinging to TinyBooter. However, as soon as I tried to deploy the TinyCLR, MFDeploy said it cannot connect to the TinyBooter. Out of deploying, it still could ping to it.
Connected directly to a desktop machine, tried both 2.0 and 3.0 ports.

What helped to me was to use the WinUSB drivers instead, everything started to work immediately.

1 Like

We have a brand new Win 8 x64 laptop.
We installed VS and SDK with FW 4.2.8.
The Debug interface works fine using the WinUSB driver.
But the Bootloader interface does not work.
It’s installing the driver, but then it says the USB Device ‘can not be started’.
Any ideas?
Edit: This labtop has only USB 3.0 ports, so we can not try it with an USB 2.0 port.