Main Site Documentation

USB Mountaineer: DfuSe Demo has stopped working


#1

I just got my first USB Mountaineer! It is so cute! So like a good newbe I started with the “Mountaineer Firmware and USB Driver Installation Guide for NETMF 4.2 QFE2”.

“Compared to QFE1, the QFE2 release allows you to use USB drivers that run in user mode and therefore cannot cause the infamous Blue Screens of Death. It also adds support for analog outputs, which was contributed by Oberon microsystems to the NETMF community.”

I decided that Blue Screens of Death are worth avoiding so QFE2 is an upgrade I need.

Following each step carefully gets me to step (4) Start the DfuSe Demonstration program. After I press the “UPGRADE” button the following happens:

[ol]Target 00: Upgrading - Erase Phase 100%
Target 00: Upgrading - Download Phase 100%
Target 00: Uploading 0% Error DfuSe Demo has stopped working: A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available (see attached image).
[/ol]

Please HELP!


#2

Weird. Try to run DfuSe as administrator.


#3

Thanks for the reply. As administrator I experienced the same result.


#4

Try reinstalling DfuSe. Check Windows Events may be there is a clue why it crashed.


#5

Thank you for the continued assist.

I tried on a second computer, fresh install following the “Mountaineer Firmware and USB Driver Installation Guide for NETMF 4.2 QFE2” exactly.

On first attempt I received a different error (see attached image). Second, third and fourth attempts result in the “DfuSe Demo has stopped working…” fault. The following is what I am getting in the Application Event Logs:

Faulting application name: DfuSeDemo.exe, version: 3.0.3.0, time stamp: 0x4ecd2975
Faulting module name: STDFUPRT.dll, version: 3.0.1.0, time stamp: 0x4ecd296e
Exception code: 0xc0000005
Fault offset: 0x0001075a
Faulting process id: 0x2460
Faulting application start time: 0x01ce1c10aad45f5d
Faulting application path: C:\Program Files (x86)\STMicroelectronics\Software\DfuSe\BIN\DfuSeDemo.exe
Faulting module path: C:\Program Files (x86)\STMicroelectronics\Software\DfuSe\BIN\STDFUPRT.dll
Report Id: fcb807f9-8803-11e2-be72-0002721ec5e6
Faulting package full name:
Faulting package-relative application ID:

I have noticed a slight version difference in the documentation. The “Mountaineer Firmware and USB Driver Installation Guide for NETMF 4.2 QFE2” PDF in step (2) tells me to obtain v.3.0.2 but the link took me to a download of v3.0.3.


#6

I may have figured this out following the Firmware Uploading instructions for the Cerberus that uses DFU Tester instead of DfuSe Demo.
http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Cerberus

I accomplished the steps without any errors anyway.


#7

Just when I thought I was unstuck… I’m stuck again.

STEPS

  1. PASS: Sucessfully upgraded the firmware using Mountaineer_USB_PK42_QFE2.dfu.
  2. PASS: Sucessfully installed Mountaineer_WinUSB_Driver.
  3. PASS: In device manager I see the MountaineerUSB connected.
  4. PASS: When I hit reset on the MountaineerUSB board; in device manager I see it disconnect and reconnect.
  5. FAIL: MFDeploy does not detect the presence of the MountaineerUSB board. (see attached image)

Thanks for the assist in advance!


#8

@ wbaldwin -

2 questions :

How do you power your mountaineer board ?
However you do not see it in MFDeploy, do you see it in Configuration panel and/or in VStudio ?


#9

LouisCpro,

[ol]
POWER: I am powering my MountaineerUSB using the connected USB port and supplied USB Cable. While MFDeploy does not detect the board, the DFU Tester that I used to upgrade the Firmware does detect it; so I do not believe that I am fighting a power issue.
Visual Studio 2010 does not appear to detect the board.
Windows Device Manager does appear to detect the board (http://www.tinyclr.com/uploads/forum/img/6958_problem_large.png). Is that what you mean by Configuration Panel?[/ol]


#10

Yes. English.


#11

@ wbaldwin -

I’ve plugged my Mounaineer Ethernet, and this is what I have (see image). Can you check the VIP and PID that you have ?


#12

And as it is seen in VS2010…


#13

LouisCpro,

Attached are the screen shots of the VIP, PID, and VS project NETMF configuration page.

Note: VS appears to detect the board while MFDeploy does not.

Thanks for the Assist!


#14

@ wbaldwin -

I dont know how you did, but your USB driver is nor WinUSB nor Signed which explains why you do not see in MFDeploy.

Check this page : http://www.mountaineer.org/resources/netmf-4-2-qfe2/

Uninstall properly the drvier you installed, and again from scrash, install the board using the WinUSB driver provided by Microsoft !


#15

LouisCpro,

The “Mountaineer_WinUSB_Driver” provided in the “Mountaineer Firmware and USB Driver 4.2 QFE2 (USB Mainboard)” is not signed. It was a actually pain to get it installed.

PREVIOUS STEPS:

(1) Following the directions for the “Mountaineer Firmware and USB Driver Installation Guide for NETMF 4.2 QFE2” on the web page: http://www.mountaineer.org/resources/netmf-4-2-qfe2/

(2) Downloaded the “Mountaineer Firmware and USB Driver 4.2 QFE2 (USB Mainboard)”

(3) Updated the Firmware to QFE2

(4) Updated the USB Driver 4.2 QFE2
—> Mountaineer_WinUSB_Driver (THIS DRIVER IS NOT SIGNED)
—> MontaineerUSB.inf
—> WdfCoInstaller01009.dll
—> winusbcoinstaller2.dll

I’ll try removing the provided driver and find a Microsoft Driver as per your suggestion. I’ll post the result here.


#16

Ok. So where can I find the signed “Mountaineer_WinUSB_Driver”. I can’t find it.


#17

Should be in the GHI program file folder something like :

C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb


#18

@ wbaldwin -

WINUSB is directly provided by the Windows OS (Vista and newer). If you installed the 4.2 QFE2 Firmware on the board, it should be recognized as is.


#19

@ LouisCpro -

Have a look on chapter 6 and 7 of the guide : http://www.mountaineer.org/app/download/6122023375/Mountaineer+Firmware+and+USB+Driver+Installation+Guide+for+NETMF+4.2+QFE2+V20120921.pdf?t=1348243282

It explains 2 important things :

Windows is a silly monkey that tell you it installed the Mountaineer USB Driver, but sometimes does not !
You must re-install the NETMF SDK 4.2 QFE2 after the Firmware and Driver installation in order to make MFDeploy goes right !


#20

@ wbaldwin

After a RESET, the mainboard enters a boot loader (TinyBooter), from there starts the common-language-runtime, which in turn interprets the application.

You can make the board stop in the boot loader and check whether MFDeploy then recognizes the board (visible at the USB list box, and then by its response to a Ping - click on the “Ping” button in MFDeploy). To stop in the boot loader, please hold down the SW button while pressing the RESET button on the mainboard. Now the blue LED should be blinking, and MFDeploy should be able to “see” the board. Otherwise something may be wrong with the boot loader or the hardware.

If MFDeploy now sees the board, erase the application (“Erase” button, “Deployment” check box). There may be a defective application in the Flash that crashes the system right after it starts.

Best regards

Cuno