Updating Spider firmware failed!

I cant update firmware without error. Se picture.

After updating the display showing:

TinyBooter v4.2.0.0
EMX Build Date:
Oct 24 2012 13:43:11
Signature PASS

Signature PASS

Signature PASS

Signature FAIL

I am running W7 x64
VS 2010 Express.
Microframework v4.2 (QFE2)
GHI NETMF v4.2 and .NET Gadgeteer Package (10-24-2012)

The first 4 days after I received Spider Kit, I could not update firmware without errors.
Sometimes the display showing ****** ASSERT ******.

Suddenly The Spider Kit works 10 days without any single error and update firmware needed.

But 5 days ago these errors came again.

Things I have tried with any luck:

  • Manually firmware updating.
  • External power to USBclient DP module.
  • Tried different USB Ports.

Do you use a powered hub? or power pack?

Welcome to the community.

Thanks for the welcome Gus.

I have used a Power adaptor 15VDC – 1A and laboratory Power Supply stable as a rock.

I do not own a USB powered hub.

If you try it with power pack, it should work. What do you see under device manager?

The 2 drivers under device manager.

I am lost now :slight_smile: You have both loader and firmware loaded. Maybe the updater somehow showed failed but it actually finished. Try updating again please.

The 2 picture is not done at the same time. It is the last picture after firmware update.

In the last hour, I have tried again to update, 1 out of 5 times it was with successfully,
but when deploying a simple program from scratch it hang and
the display showing ******** ASSERT *****

Ok that assert is a different problem. So you are set with new firmware. Now, how do you get the assert? You load a blank application? What modules?

New Gadgeteer Application v4.2
Modules Spiderboard, usbClientDP and display_T35 with no added code.

But when deploying, the display showing ****** ASSERT ***** .

When resetting the Spiderboard, I got a white screen and I cant update again without errors

TinyBooter v4.2.0.0
EMX Build Date:
Oct 24 2012 13:43:11
Signature PASS

Signature PASS

Signature PASS

Signature FAIL

To verify firmware is up to scratch, connect via MFDeploy and check Device Capabilities and verify the version of firmware matches your SDK.

Se picture for Device Capabilities and Show Device Info.

I am using GHI Premium NETMF v4.2 SDK from this file GHI NETMF v4.2 and .NET Gadgeteer Package (10-24-2012).ZIP

One interesting point, when the updater finish. It changes the usb name to gadgeteer. Did you use the updater app of fix the update manually?

When trying to change USB name it refuse to do it, se picture.

I used FEZSpider Firmware Updater

I think you have a mismatch between tinybooter and firmware. This should never happen if you use the updater though!

It seems that you did everything correct! Maybe other can help tomorrow. It better use the non bets SDK that will bd released tomorrow.

If there is a mismatch, why could I used the Spiderboard in 10 days without any errors? Se first post.

Sometimes when the Spiderboard has been without power turn off for 1 hours and more, I can do an update, but after a couple of minute the Spiderboard hangs.

2 possibilities

Power is not stable or cables are intermittent.

Configuration is corrupted but an update should have taken care of it.

+3.3V and +5V measure on a extenderboard is:

With USB Power
3.3V is 3.2V
5V is 4.54V

With External Power
3.3V is 3.17V
5V is 4.88V

The meassurement is taken under update

The other way I notice you can get TinyBooter version info is if you go into the network configuration from within MFDeploy. That resets into bootloader mode and shows on the LCD (at least on my Cobra) the tinybooter version.

One thing I would do is step through the firmware update manual process http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX You will want TeraTerm so get that ready, and that should at least get you to a stable state, if that’s actually the issue.

Can I ask what kind of app you are working on? Is it something exotic? Have you just let a simple app run for a long time (time update on screen and LED flash for instance)? Perhaps there’s something else there that we can find that might help.

A reset of Spiderboard in TinyBooter mode the display showing:
TinyBooter v4.2.0.0

But the SDK saying TinyBooter v4.2.5.0

SDK Version 0.0.6
October 24, 2012

Version Info

Important Note: Requires .NET Micro Framework 4.2 QFE2 and Visual Studio 2010

• EMX v4.2.5.0, TinyBooter v4.2.5.0
• G120 v4.2.5.0, TinyBooter v4.2.5.0
• GHI Premium NETMF Library v4.2.5.0

Yes, I have tried manual update with Tera Term 4.53, and thereafter MFDeploy, But with same result.

What I am doing with Spider Kit.
It has been working for 10 days without any firmware error.
In that time I have been working on library to software control an audio DAC with SPI interface.
It is possible to control more option in software mode, than hardware mode.
It working and are almost done.
Later on it should also controlling ASRC and a Transceiver.
The whole things control by a Touch screen.

TinyBooter version number confusion.

Se picture