Main Site Documentation

Updates are killing my boards


#1

I’ve attempted to do firmware updates from 4.2 to 4.3 using FEZ Config on both my Spider and Cobra II. Now they neither board is capable of being detected by my USB.
I’ve tried everything documented and nothing is working. So I know I’m missing something, but I have NO IDEA what it is. I welcome any advice.


#2

What PC operating system, Win7, Win8 or Win8.1?


#3

Running Windows 8 OS


#4

Is the USB driver installed properly?


#5

My USB seems fine. In fact to double check i just plugged in a FEZ Raptor and it’s being recognized no with no issues. If I were to do an update using FEZ Config on it, I suspect I would get the same problem as I did with both my Spider and Cobra II.


#6

Try updating the boot loader from the top menu bar.


#7

Yes I tried that again and same issue I see the switches in the Load mode, but again “Could not connect to device”.


#8

At least with the Cobra II, the USB recognizing a device is present, just can not determine what it is and does not install any drivers.
The Spider however isn’t recognized at all.
I’m using an external power supply on all boards when connecting them.


#9

I even tried to manually update both boards. When I ran TeraTermPro, the Serial port options was grey/unavailable. I attempted to manually install USB descriptors, didn’t work.
I’m wondering if the 4.3 update somehow crashed both my boards, since the updates failed halfway on both boards and since then I haven’t been able to connect them. Yet other boards that i did attempt to update are working fine.


#10

Can you try an different computer?


#11

Its iron you mention that. I have a new Surface Pro 3 being delivered today.
I will do this and get back to you. In the meantime I did uninstall/re-install all the NETMF and Gadgeteer bits on this PC to no avail.
I’ll provide an update here shortly.


#12

Brand New computer and new install of NETMF and Gadgeteer Pachage 2014 R2,
Same Problem!
Boards are fried, this is terrible… I’ve got a keynote presentation where I wanted to have at least 3 demos and I only have 1 of 3 boards working.

Upon installing NETMF/Gadgeteer, I saw a “Known Issue” with Windows 8. It says “The loader cannot be updated on Windows 8”.
I also saw a notice from Amtel regarding their USB driver. It doesn’t look like it’s compatible with Windows 8 neither.


#13

reflash tinybooter on your spider, don’t forget to adjust the dip switch


#14

Not sure I know how to do that, but I’ve followed about every instruction published and so far nothing as worked. I’ve flipped switches every which way on the Spider and for the Cobra II, it doesn’t have switches, so I’ve held the two buttons while pressing the reset button. Nothing works. In case I’m missing something, can you be more specific?


#15

the switch information is documented in https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families

If TeraTerm doesn’t show a serial port for you to connect to, then your device hasn’t shown a serial port. Make sure you know what device has become visible in Device Manager… and you nust also exit teraterm and re-open it since it only populates the serial port dropdown list when it starts.


#16

It is very rare to brick a module during an update. It normally turns out to be something silly.


#17

I’ve done all the switch setting to ensure both boards are in Load mode.
USB shows up as “not a recognized device”, then drops it all together.
Tera Term opens, but Serial selection is greyed out. FEZ Config sees no device connected.
Both boards were working fine on 4.2, this all just happened after a failed attempt to update them to 4.3 using FEZ Config.


#18

where are you based, you might need someone with a working PC and known working device to prove what state your boards are in.


#19

I’m in Grand Blanc, Michigan… not far from GHI.
My new PC works well with my FEZ Raptor board (4.2). I’ve been developing on the Raptor with no issues so far. As long as I don’t try to update it to 4.3. The other boards that I attempted to update to 4.3 (Spider and Cobra II) still do not work even with my new PC. Probably because I’m an idiot, but I’m a bit green on all this still.


#20

Enough is enough. Brand new computer and new installs of everything. As long as I DO NOT UPDATE to 4.3 my other board is fine. However for all that I “attempted” to update, They are trash. I’m forced to return these boards back to GHI. In the meantime I have an Intel Galileo that I have yet to unbox, so I hope the experience goes smoother.