TinyCLR Config Problem

When I update the board SC20260 to the latest firmware, I get an error message from TinyClr Config.
that " There was an error during the upload "
what is this ? can someone help me ??

can you post a screen shot of tinyclr config?

TinyCLR config version must be match to latest firmware also.

this is the screenshot from TinyConfig

Have you tried connecting the device in loader mode?

Or use the erase all option in tinyclr config and try again that way?

I have set the device in bootloader mode and I have also deleted more times but comes the same error message

Is your version of TinyCLR Config version v2.1.0-rc1?

no my version is v2.0.0


You are going to need to download and install the latest version of TinyCLR Config, I am assuming you are trying to update to rc1.

You are using a 2.1.4000 firmware with a 2.1.0000 tinyclr config. You should download tinyclr firmware 2.1.5000 and tinyclr config 2.1.5000 from the downloads section in the docs.


He’s absolutely correct.


Thank you for your answer. I used all the latest versions of TinyCLR v2.1.0.rc1 and firmware V2.1.0.5000 (RC1) but does not work

Welcome to the community.

It is harder to help when you have 2 posts about the same problem. I will continue to help you in the other post

Tinyclr config could perhaps display its version number in the title?

1 Like

click on “Select a device”, a new comport should shown up, go ahead update with that port… If not, something wrong with the PC.

You also have to reinstall TinyCLR config to match the firmware version you are trying to install.

I was thinking about this…

Or your board in loader mode and show us if it shows in TinyCLR config under there list of available devices. It will be “COMx GH Electronics”

I was having an issue yesterday and I noticed that I had plugged the USB cable into a USB 3 port. When I changed to a USB 2 port it worked.

I always use USB 3. Is it the loader or the firmware causing issue @taylorza

I mean hold LDR low and update, any issues?

It has been working for me as well, but last night it would just not recognize the board when I went into LDR no matter what I did.

As a last ditch attempt I moved to a USB 2 port and it worked. I did try initially moving to another USB 3 port and it did not work either. Since it is working now, I have not moved back to the USB 3 port, that might work again, but last night it was not giving me any joy.

hello guys can someone say at the manuel firmware update with Tera Term where binds this option

  1. IMPORTANT: Make sure you check the 1K option.