Main Site Documentation

TinyCLR and windows 7


#1

Hello GHI team,
Is there a Window 7 driver for Panda III with G80 Firmware.0.3.0.ghi inside ? Personnaly i work with windows 10 and it’s ok but all school’s PC are under Windows 7 and Panda III isn’t knowned. Thank you for your reply.


G80 driver for windows 7
#2

@ MNO - You may be able to use the drivers found in our NETMF SDK.


#3

@ John - Thanks for your reply John.

But my problem is not resolved. :frowning:
My Panda III with NetMF 4.3 on Windows 7 or 10 and VS2015: it works. My panda with G80 Firmware 0.3.0 under W10 and VS2017 also but under W7 I can not get to recognize it to work with VS2017.


#4

@ MNO - On Windows 7 with VS2017, what shows up for the G30 in the Device Manager? As noted in the release notes, Windows may still use the old NETMF USB IDs preventing the device from being seen by TinyCLR. I’d uninstall all NETMF and TinyCLR devices you can see in the device manager. Make sure enable showing disconnected devices as https://technet.microsoft.com/en-us/library/ff184583.aspx explains. Then try to connect just the G30 (make sure it has the TinyCLR firmware on it before performing the above steps).


#5

I’ve tested it at school today, and I obtain same result as MNO.
Device not recognized.

I’ve tried to reboot pc, same result…


#6

@ John - Hello John, thanks to help me.
I follow your advice. Some results from yesterday. I managed to install a driver and Panda III is recognized by Windows 7 :slight_smile: , but Visual Studio 2017 does not see it and therefore does not program it ! :frowning:
See details.


#7

@ MNO - I think the issue may be because we changed one of the USB IDs to be different than what was in NETMF. To test, uninstall the old drivers completely and remove the device from the device manager, making sure to check the box to remove the files. Make sure to keep a copy of GHI_NETMF_Interface.inf though (but not the cat file). Open that file and towards the bottom, change D32D1D64-963D-463E-874A-8EC8C8082CBF to C13BCFE9-5E84-4187-9BAA-45597FFCBB6F. Then try to install the device using this new file manually. You may need to disable driver signature enforcement. If this works, we’ll look into getting proper updated and signed drivers for a future release.


#8

Thanks John,
Thanks John, it’s 11:30 pm in France. I’ll test it tomorrow. :slight_smile:


#9

It seems to be working. Thanks a lot. Now, waiting for future release ! :wink:


#10

@ John - Hello John,
It’s fine for me too. It was the solution. Thanks a lot for your help. :smiley:


#11

It’s working for Brainpad too ! :clap:


#12

@ MNO and Bauland - Glad to hear it’s working. We’ll look into this more for a future release.


#13

@ John_ghielectroncs - Hello John,
Thanks for the work done since TinyCLR v0.3.0. I installed TinyCLRv0.5.0 on Windows 7. G80 is now recognized by VS2017 but the debug mode does not work. The program is transferred but does not work step by step.


#14

@ MNO - Step by step?


#15

@ John_ghielectroncs - This seems to be a poor translation of (pas à pas) in this context . I wanted to say: In debug mode. :slight_smile:


#16

@ MNO - So you can deploy an app like blink LED and if you just power the board it works, but when you try to start the VS debugger with the same program, it doesn’t?


#17

@ John_ghielectroncs - Yes, when I try to start the VS debugger with the same program, it doesn’t work.


#18

@ MNO - What behavior specifically are you seeing that’s failing? Are there any errors shown anywhere?


#19

@ John_ghielectroncs -

I see this during the compilation :

Looking for a device on transport ‘USB’.
Found device port ‘USB’ with ID ‘72400619-1d04-4ba9-8325-ddafbd648169’ for transport ‘Usb’.
Starting device deployment.
Attempting to connect to device ‘USB:G80’: iteration 0.
Opening port ‘\?\usb#vid_1b9f&pid_0110#5&3971263f&0&1#{c13bcfe9-5e84-4187-9baa-45597ffcbb6f}’.
Attaching debugger engine.
Debugger engine attached.
Querying device assemblies.
Found assemblies:
- TinyCLRBlink v1.0.0.0.
- mscorlib v0.5.0.0.
- GHIElectronics.TinyCLR.Devices v0.5.0.0.
Generating device specific assemblies.
Deploying assemblies:
- TinyCLRBlink v1.0.0.0 with size 644 bytes at ‘C:\Users\Administrateur\documents\visual studio 2017\Projects\TinyCLRBlink\TinyCLRBlink\bin\Debug\pe\TinyCLRBlink.pe’.
- mscorlib v0.5.0.0 with size 76 636 bytes at ‘C:\Users\Administrateur\documents\visual studio 2017\Projects\TinyCLRBlink\TinyCLRBlink\bin\Debug\pe\mscorlib.pe’.
- GHIElectronics.TinyCLR.Devices v0.5.0.0 with size 40 968 bytes at ‘C:\Users\Administrateur\documents\visual studio 2017\Projects\TinyCLRBlink\TinyCLRBlink\bin\Debug\pe\GHIElectronics.TinyCLR.Devices.pe’.
Total deployment size is 118 248 bytes.
Incrementally deploying assemblies to the device:
- Erasing sector 1 (131 072 bytes).
- Writing sector 1 (644 bytes).
- Erasing sector 2 (131 072 bytes).
- Writing sector 2 (117 604 bytes).
Assemblies deployed. There are 143 896 bytes left in the deployment area.
Restarting interpreter.
Attaching to device.
Waiting for device to initialize.
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error ‘Could not reconnect to the debugging target after rebooting it.’.


#20

@ MNO - Can you try to reflash the firmware, create a new project to test, and reinstall the VSIX?