Main Site Documentation

The project type is not supported by this installation


#1

Note: I am a .NET programmer, I’ve use Visual Studio every day (since I was 9 months old ;>)

I purchased the “Getting started with .NET Gadgeteer” book and I have installed all the prerequisite components (SDK, Drivers…) as directed by the book.

Visual Studio 2010 Proferssional lists the Gadeteer 4.1 and 4.2 projects in the list project templates but gives me this error when I try and create a new project:

The project file ‘C:…\Hello.csproj’ cannot be opened. The project type is not supported by this installation.

Any ideas what’s missing / wrong?

Thanks
Robert


#2

Welcome to the forum!

Please, check this thread:

http://www.tinyclr.com/forum/topic?id=1665

and few more from the search:

http://www.tinyclr.com/forum/search?q="The+project+type+is+not+supported+by+this+installation"


#3

Thanks for replying!

Please note… I never installed VS Express.

Here are a few directories the the GHI stuff was installed to:

C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK
C:\Program Files (x86)\Microsoft .NET Gadgeteer
C:\Program Files\GHI Electronics\GHI NETMF USB Drivers\

I have uninstalled everything (.NET MF and GHI stuff) and reinstalled everytihng. Still, the same error…

Welcome to the world of embeddded… Right? ;>


#4

Did you install optional step 4 from the support page?


#5

4.(Optional) GHI NETMF v4.1 SDK Sep. 14, 2012
Needed for 4.1 devices (ChipworkX, USBizi).

http://www.ghielectronics.com/support/.net-micro-framework

I did not install this - Robert


#6

Please do.


#7

I downloaded the Step 4 ZIP and extracted it.

I ran the installer which placed the files in C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\

I created a new Visual Studio Project based on the 4.2 template and got the same error.

I then created a new Visual Studio Project based on the 4.1 template and got the same error.


#8

Try rebooting the system.


#9

Sounds like something is missing from the install. I would un install everything and re install. What gadgeteer mainboard are you using?


#10

@ andre.m >>> VS 2012 Version 4.5.50709 SP1Rel

@ HugeB >>> I already ripped everything out and reinstalled

@ Forum Host >>> Why do I have to keep re-authnticating to make a post? The time out is quick on this forum:>


#11

VS 2012 is not officially supported yet. Try VS 2010.


#12

Sorry… I meant VS 2012


#13

dang… again… I’m so used to writing “2012”… I meant "2010?


#14

Jesus holy… To be clear (sorry) I am using VS 2010 for this project. All of my previous correspondence has pertained to VS 2010


#15

Running out of suggestions here. There were issues before on non English os, changing locale usually helped.


#16

@ andre.m >>> Thank you for replying. Curious, has that helped anyone else?


#17

@ robbyv - are you creating a 4.2 microframework console app, or gadgeteer app and not the full framework?


#18

@ Justin >>>

In VS2010 I select “New Project” / Visual C# / Gadgeteer / .NET Gadgeteer Application (NETMF 4.1 <or 4.2>)

The Location in VS is specified as “C:\Users\Administrator\Documents\Visual Studio 2010\Projects…”


#19

So the error is when you open an existing project or on creating a new one?


#20

When I create New Projects