Main Site Documentation

Spider - Undef Instr


#1

I read a couple of threads mentioning similar problems, but they weren’t very clear on how to solve the issue or maybe I wasn’t able to indentify the circumstances that could also apply to my situation at hand.

I got this gadget which is based on the Spider 1.0 and the J11D ethernet modules (among others) and its main purpose is to make HTTP posts to an endpoint on the web. Everything seems to be working OK, but every once in a while the unit apparently crashes displaying the following messages on the LCD screen:

Undef Instr
Build Date:
Aug 15 2013
11:41:08

cps = 0x00000010
pc = 0x4248dbf2
lr = 0x0002b2db
sp = 0x4000f76c

At first glance, the crashes aren’t associated with any user-initiated events at all… they always happen by themselves, when the unit is in an idle state.

Not sure what’s going on… hope somebody here can shed some light.


#2

Much improvements were done on the 4.3 networking. Have you tried it maybe?


#3

Strangely enough I had exactly the same problem last night but I’m only parsing NMEA messages from a GPS unit.


#4

This project was built under VS 2010, using NETMF 4.2 with GHI’s SDK Package 2013 R2. Just to get it right, you’re suggesting that I upgrade/use VS 2012 with the newer NETMF SDK 4.3 (RTM) and also the Gadgeteer Package 2014 R1 instead, is that it?

The Spider board that I’m using is currently fitted with firmware 4.2.11.0. I guess I’ll have to upgrade the firmware also, right? Will FEZ Config handle this by itself or will I need to go through that rather convoluted process via Teraterm?

Regardless, I’ll still have to target Micro Framework 4.2 inside VS 2012, right?


#5

Sooner or later, you need to use 4.3. the update is simple, just like any other firmware update. Another SDK ships this week so maybe wait couple days.


#6

Sure, I’ll give it a try to see if this problem gets fixed. But what about the firmware upgrade? In previous SDK versions I remember having to use Teraterm and having to follow a rather convoluted process. Did this process get any easier now? Could you point me to some documentation?


#7

loader update: take a look at : https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families , section on automated update.


#8

When I try to put in “bootloader mode” (fliping the dip switches and pressing the reset) FEZ Config loses connection to the device and therefore I can’t continue with the upgrade process. Any ideas?


#9

What do you see on the device manager? Maybe the loader driver didn’t load automatically.


#10

There’s a “GHI Boot Loader Interface (COM3)” under the “Ports (COM & LPT)” group.

This looks right, doesn’t it?

Could it have something to do with the fact that I’m running this inside a Win7 VM?


#11

I’ve been chopping bits out of my code trying to isolate the problem and at the moment it seems to be related to an interrupt I have on socket 4, (1 sec pulse from GPS). If I disable this I don’t get the problem.


#12

I use this VM as a testbed, so I can keep my oficial dev box as clean as possible. In it I have everything working and updated up to version 4.2. I also have both VS 2010 and VS 2012. What would be the correct steps to upgrade everything to 4.3? Should I uninstall NETMF’s and GHI’s 4.2 SDKs before installing the newer ones?


#13

I ended prepping up a new Win 8.1 Pro machine from the ground up. Installed VS2012 and all the SDK packages, but something is wrong. When I plug in my device, it shows in Windows’ Device Manager as “GHI Boot Loader Interface (COM3)” under the “Ports (COM & LPT)” group. But the thing is that it is showing with a yellow exclamation mark.

Any ideas?


#14

On my previous post, Windows wasn’t fully updated yet. Besides, some mainboard drivers were still missing. I went ahead and updated everything. Now everything seems OK and I can see a clean “GHI Boot Loader Interface (COM3)” item in the Device Manager. But FEZConfig is still not picking up my device. Not sure why.

Any ideas?


#15

Maybe use a terminal software to open the serial port? Then do the update manually? This should be explained under Spider documents or EMX.


#16

I decided to take another route and ended up updating my main dev box – the one that has both VS2010 and VS2012.

As advised, first I uninstalled all packages from previous SDKs (MS NETMF SDK 4.2 QFE2 and GHI NETMF and Gadgeteer Package 2013 R2), making sure to delete folders and all that once they had been uninstalled. Rebooted and then installed the newer packages (MS NETMF SDK 4.3 RTM and GHI NETMF and Gadgeteer Package 2014 R1). Once all packages were finished installing, I rebooted once again and then I fired up VS2012 so to try to create a new Gadgeteer project. But the application wizard is now showing that in order to use any of the GHI boards available I need to install .Net Gadgeteer Core version 2.42.500 or newer.

I don’t get it. Can anyone please clarify?

PS: The driver seems to load OK since the GHI Boot Loader Interface (COM4) device is showing on the Device Manager window, but no sign of the device inside FEZConfig.

Just a sidenote: this is a Win7 Pro x64 box and everything was working OK before the upgrade.


#17

This behavious is either when you have the spider switches set in bootloader mode or you don’t have a netmf firmware loaded.

Step to https://www.ghielectronics.com/docs/170/fez-spider and https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families to make sure that’s done (and like Gus, I suggest you manually do this with TeraTerm) Then you should be back in normal switch setting mode (as in the process you turn them back) and then let FezConfig apply the netmf firmware.


#18

Thanks, Brett. I’ll try that later on. And what about VS2012 not being able to create a new gadgeteer project? Apparently, it is complaining about the Gadgeteer Core libs.


#19

I’m really at a lost here, guys.

  • when I tried to follow FEZConfig’s onscreen instructions (flipping the dip switches, pressing reset, etc), I always ended up with an unrecognized device

  • now that I tried to follow the documentation that was pointed out here, I ended up with a device now completely erased to a clean state

Image #1 shows Loader and Firmware versions that WERE present on my device before I just completely wiped out everything.

Image #2 shows the Firmware Updater process, which ran apparently with no problems, except at the very end, when a message popped up saying that it couldn’t “run the firmware”

Now I’m staring at a completely empty screen – no boot messages, no nothing.

This is all too confusing. I really need some good and solid help here.


#20

Things are starting to look better now (I guess). Apparently I was able to manually update the loader via TeraTerm. Once that was done, I was then able to update the firmware via FEZConfig. Please see the image attached which shows the result of pressing the “Check device for update” on the FEZConfig.

Now the next challenge (I guess) is to solve the issue inside VS2012, since it’s complaining of some Gadgeteer Core libs, as I have mentioned in a previous post.

I’d really appreciate extra help on this. Why on heavens is VS2012 giving this error if all SDKs installed without any problems??