SC13048Q-A Not in TinyCLR List


I’ve integrated an SC13048Q-A into a development board of my own. When I connect via USB, device manager originally showed STM32 Bootloader (with driver not found error).

I then installed the STM32 driver from STMicroelectronics directly, and reconnected via USB. Now device manager shows STM32 Bootloader under USB device list, but when I open TinyCLR I am still unable to see any devices listed in the dropdown menu.

I tried resetting and holding down LDR prior to opening TinyCLR with the same result.

Is there something else I should be doing to find the device for initial setup?

Also, here is my schematic in case it helps.



Some older chips required a pull down resistor on ph3 on first lower up and only first power up. This is no longer the case. You will see this in all of our schematics.

This may sound silly but reset the board a few times while touching the chip where ph3 is (ground your body) and your board will boot fine. Once it boots fine once it will always be fine afterwards. You can also just run a wire from ground to ph3. Again, this is only needed once.

If you are not comfortable with above then we are more than happy to fix the boards for you if you ship to us

Sorry about this inconvenience.

Appreciate the info. I got 4/5 dev boards up and running. Anything else I can try to get the 5th board to boot?

I was able to connect with STM32CubeProgrammer so should be able to program from there as well.

Are you using our dev board or your custom board?

This is a custom board which uses the schematic shown in initial post.

Did you select “Read Unprotect (MCU)” when connect by STM32cubpro on 5th board?

With or without Read Unprotect (MCU) checked it will connect in STM32Cube.

just to be clear here - you have 5 boards, 4 work fine but one does not.

That to me says your design is fine and operating as expected, and the 5th board is an anomaly. Personally I’d be looking at a solder / connection issue on the 5th board, a cap or resistor that might have tombstoned or didn’t flow right.

@Brett Yes 4 of them were able to boot, one registers as STM32 in device manager, but haven’t been able to get it to talk to TinyCLR config. As far as I can tell, the components and voltages around the PCA look good, and it acts exactly the same as the other 4 did prior to shorting PH3 to ground during reset. In any event, not a huge deal but was just trying to get it fired up. Appreciate the help from everyone on this!

High tech solution suggests the method below may also work?