Releasing the NETMF and Gadgeteer Package 2014 R2 Beta-2 SDK!

Same issue here

Solved:

  • Uninstalled everything related to ghi, netmf and gadgeteer.
  • Manualy deleted all folders related to ghi, netmf, gadgeteer !!
  • Installed latest sdk etc

Thanks RobvanSchelven, that did it. Works fine now…

It seems that the Micro Framework installers do not properly handle upgrades. One of the issues is that when moving from 4.2 to 4.3, the existing 4.2 assemblies are not overwritten like they should be, only the 4.3 assemblies are added. So when the 4.2 assemblies are QFE1, you stick with those. So the next beta will uninstall old Micro Frameworks first then install the new 4.3 QFE1. As for why a fresh install gave 4.2 QFE1, I was not able to reproduce that. I even took apart the installers and verified that the embedded assemblies were 4.2 QFE2, and they were. Did you perhaps manually install 4.2 QFE1 before running our installer? Uninstalling everything GHI and Micro Framework related and verifying that the directories are gone, then doing a fresh install, should work.

@ RobvanSchelven
Did you find it necessary to clean out everything including Visual Studio Express 2012?
I tried excluding a reinstallation of Visual Studio Express 2012 but that made no difference.

For Windows 7 after reinstalling:

Visual Studio Express 2012 (wdexpress_full.exe claimed I had the wrong operating system) plus Update for Microsoft Visual Studio 2012 (KB2781514) which “A flaw in visual studio may cause it to become unstable when the .NET 4.5 framework is updated.”

installed NETMF4_3(QFE1)SDK which is V4.3.1 (has GHI stated a preference for V4.3.1 rather than V4.3.0) ?

then installed NETMF and Gadgeteer Package 2014 R2 Beta-2

This overcame the error: “Cannot deploy the base assembly ‘mscorlib’, or any of his satellite assemblies, to device - USB:Gadgeteer twice. Assembly ‘mscorlib’ on the device has version 4.3.1.0, while the program is trying to deploy version 4.3.0.0”

For me it also overcame an compile error I was getting with Display T35.
Regards,
Kevin.

@ KG1 - No, i did not un and re-installed VS2010 or VS2012. Just uninstalled the netmf,ghi and gadgeteer stuff. But most important step was manualy deleting the related folders after uninstalling netmf and stuff.

After deleting everyting i only run the installer from R2014 beta 2.

@ KG1 - This and future SDKs require the 4.3.1 QFE Micro Framework. 4.3.0 will not work.

I would like to have the separate installers back (FEZConfig, USB Drivers, …) or at least the ability to choose install features in the installer.

If I want to install FEZConfig and drivers only on a non development machine I can not do this anymore!?

I also never ever need the Gadgeteer overhead, just plain NETMF.

I also don’t want to reinstall NETMF SDK every time a new SDK comes out.

I tried to extract the installer by "NETMF and Gadgeteer Package 2014 R2 Beta-2.exe /layout ", but all I get is a installer exe with a different filename.

1 Like

How many more betas will be released?

Raptor and beta2 2014 R2 is hardly usable… for now i am going back to netmf 4.2

I ported an application… using wifi, a number of threads… but its slooooow… network io, debug io. lag on interrupts.

I also ported an application from 4.2, that uses a lot of RS485 comms at 115000 baud, plus SDmicro card, T43 display, RS232, and it ran quite fast - I was pleased. However the T43 did not display correctly as there is a known problem with that display on 4.3. However, it did not have networking.
Another app I ported with RTC, EMC28, and timechecks with NIST every 8 minutes ran find for several days, but did not work at all on 4.2.
I have not seen any difference between debugging in 4.2 and 4.3. Both are not perfect.
Perhaps the WiFi is particularly buggy.

I am not sure what causes the behaviour… I have not much time and spirit to do beta testing :wink:

@ Reinhard Ostermeier - We will look into providing more install customizability, but no promises.

@ Simon from Vilnius - We don’t have a firm number of planned betas, but we do plan to keep releasing them until things become stable.

@ RobvanSchelven - Networking, and WiFi in particular, are not 100% stable yet in 4.3. It is something we are continuing to work on. We have made a number of WiFi improvements in the next beta.

Also please make sure to use https://www.ghielectronics.com/community/forum/topic?id=15400

Is the installation package of “NETMF and Gadgeteer Package 2014 R2 Beta-2 SDK” for Windows XP?

Please don’t continue to use XP. There’s no longer any support for it and it becomes a significant security risk to leave it in use.

@ Majo - Our 4.3 SDK specifically disallows any version of Windows before 7. Only 7 and 8 are supported.

Is a new beta version on the way?

Its not even a month since last beta. Take it easy.

Is the issue “Devices will lock up for three seconds when connecting to a WiFi network.”
in the improvements list?

@ David@ Emrol - It is. It will be out very soon.

@ John: Glad to hear. Can I suggest that this time you start a new thread in case there are any bugs :whistle:
If there were any way to have a single place to go to see a list if any bugs remaining, so all who are testing can avoid wasting time trying to get things to work that are still defective, then this would also be great…not that that will be needed…