Problems to update winc1500 firmware on FEZ Feather

I’m trying to update the winc1500 firmware without success.
I have no problems with the old firmware which is 19.6.1.16761, only wanted to verify that the update procedure works.

I followed this tutorial by Microchip which was was recommended by @mmmtang

and the GHI Tutorial:

-https://docs.ghielectronics.com/software/tinyclr/tutorials/wifi.html

I downloaded the latest firmware from:

-https://ww1.microchip.com/downloads/en/DeviceDoc/ATWINC1500_FW_19_7_3_02NOV2020.zip

unzipped and got the file ‘m2m_ota_3a0.bin’

I installed a fileserver program hfs.exe from https://www.rejetto.com on my PC and loaded the firmware file to the fileserver.

I made a TinyCLR application:

-https://github.com/RoSchmi/FezFeather_WiFi_firmware_Update

to start the firmware update with the command:

bool success = GHIElectronics.TinyCLR.Drivers.Microchip.Winc15x0.Winc15x0Interface.FirmwareUpdate("http://192.168.1.24:8000/m2m_ota_3a0.bin", ( 3 * 60 * 1000));  // 3 minutes

which was not successful.

I could not see that anything connec to the fileserver program.

However if I open a socket to the server in my test-app I could see, that the Winc1500 module can connect

var s = new Socket(AddressFamily.InterNetwork, SocketType.Stream, ProtocolType.Tcp);
try
{
    var ip = IPAddress.Parse("192.168.1.24");
    s.Connect(new IPEndPoint(ip, 8000));
}
catch (Exception ex)
{
       Debug.WriteLine(ex.Message);

}

With wireshark I can see that the socket connection can be established with the test code but with the FirmwareUpdate command I can see no activity at all.

What can I be doing wrong?

We haven’t test 19.7.x

As we know this will work with 19.6.x and recommended for 19.5.4.15567.

If you can go back 19.5.4 or 19.6.x too see if it work, meaning it is not happy with 19.7.x

Hi @Dat_Tran, thanks for your response.

The problem for the first seems to be that the Winc1500 module doesn’t even load the firmware from the file server.
As far as I can see from the different documents the name of the the file to download is the same for all firmware versions namely ‘m2m_ota_3a0.bin’.

-https://docs.ghielectronics.com/software/tinyclr/tutorials/wifi.html

Without downloading the file the module can hardly know which firmware it doesn’t like?

I see, will give it a try.

1 Like

Hi, we found and fixed in rc1. For sure we are same page, set your ssid to something has only 3 character then ota will work if preview4.

it is corrected in rc1. And as quick test, 19.7.x looks working.

2 Likes

Thanks @Dat_Tran ,
SUCCESS !!
I tried with three character SSID (namely: xyz) and upload and update to the latest firmware version 19.7.3.19057 worked.
Version 19.7.3.19057 is working in my application (TLS secured Get and Post requests) as well.
I updated my Tool for the fimware update, perhaps it can be helpful for others:

-https://github.com/RoSchmi/FezFeather_WiFi_firmware_Update

Btw:
Would be nice to have a new function in the ‘Winc15x0Interface’ class to switch back to the firmware version which was active before the update (afaik this version is preserved in the module).

Would be also nice to have links to the Microchip sites (ore GHI site) were older firmware versions can be downloaded (it was not easy for me to find to find the respective sites on the Microchip page)

1 Like