Problem with Spider Starter Kit - Display T35 - DP Client USB

Hi everybody,

I bought a Spider Starter Kit and I tried some tutorials without any success (like this one:

What I have done:

  • Update the firmware of the Spider board with the latest firmware
  • Connect all elements together
  • Power up the USB Client DP Module with 12V DC 1A

After that, the screen stays white (backlight on) and I cannot print anything to the display T35.

So, I tried to :

  • switch on/off the backlight and I succeeded to do it
  • read the touch coordinates and I succeeded to do it

I pinged the spider board and I succeeded to do it

I checked the resolution screen (width and height) and it was correct

I changed the IDC Cable and nothing changed …

I spoke a long time with mike (on chat) and he said to me to reset the board to see if a message appeared on the screen. I did it and no message appeared at all. I never succeeded in printing something in the screen.

Mike said to me that he suspected the board or the display T35 to be faulty.

So, this morning, I decided to call the French distributor ( which sold the starter kit to me and the support replied that I had to open a request to GHI Support directly.

So I do not know how to do because GHI support is only for products commercial use.

Thank you for your help !

GHI support is here on this forum, for commercial and for education. Your distributor should have told you this. Do not worry, we will take care of you.

Do you see anything on the display on power up? It usually shows bootup messages in green. If not, have you tried different cables? Did you double check that you connected the 3 RGB sockets correctly? Finally, do a quick look around the RGB sockets. Do you see anything suspicious, like short or bad connection?

Do you own LED7R module? This is a good one for testing.

Welcome to the community.

Thank you very much for your help, for you quick reply and my apologises for my poor english.

[quote]Do you see anything on the display on power up?[/quote] No, I see nothing printed on the screen, only the backlight and a line which goes from the top to the bottom which stops after a while.

[quote]If not, have you tried different cables?[/quote] Yes, I tried different cables.

[quote]Did you double check that you connected the 3 RGB sockets correctly?[/quote] Yes I checked my connections several times.

[quote]Do you see anything suspicious, like short or bad connection?[/quote] I checked that. No, I don’t see anything suspicious but what do you mean by short connection ?

[quote]Do you own LED7R module?[/quote] Unfortunately not. I do not have it. I only have the fez Spider starter kit content.

Thank you for your welcome message !

Have a real close look at the R G and B sockets. I have only heard of one case where there was a suspect solder pad on one of the sockets.
The other thing to check is power, is the spider connected directly to a PC USB port or to an un powered hub? If so try plugging it in directly to the USB ports on the PC itself.

edit: Re reading your post it looks like you have tried most things.

I just have an another close look to the socket. I saw nothing particular to notice neither on the spider board nor on the screen itself …

I don’t think the power is the problem because I read that in other posts. So I powered the USB DP Client with 12V DC 1A.


He is able to deploy and run a program from VS.

Using MFDeploy, he is able to ping the Spider and get the device capabilities info. The device capabilities show that the LCD has the proper width and height.

Do you have a voltmeter or something that can test continuity?

Hello Mike !

Yes. I checked a lot of things with Mike yesterday.

Yes I have a voltmeter. I will test the continuity between solders and pins.

Look around on the bottom of the board, where the EMX module is attached to the Spider. If you see a bunch of gold where the other places are silver, that may be the problem. Otherwise, test continuity between adjacent pins. Start with the pins labled with a T on the EMX module. They will be on the same side as sockets 12-14.

Maybe also look at the pads around EMX module. Of course you can just send it back for a new one if you like but it maybe easier for you if you can make it work :slight_smile:

Let us know how we can help.

No resistance between T1, T2, T3, T4, T5, T6 and T7 included. I think that I have a faulty board no ?

This is a good thing. You do not want resistance between each of those connections. Finish the rest from T7 to T20.

Really ? I should not have resistance between T1 and T2, between T1 and T3, between T1 and T4, and so on ?

No you shouldn’t. I really doubt there is more than one bad connection on the board. These are tested after manufacturing so they should be fine but there is always a chance of one bad connection.

You need to measure from the pin down to the PCB, to EMX module. It should be near zero.

Sorry to interrupt you guys. But I think the issue is simpler than that.

I suspect that there is something wrong with the .NET Gadgeteer project. Maybe it is not enabling the LCD interface as it should be when you add the T35 Display in the designer.

Do this simple test:
Use FEZ Spider Updater application to update the firmware. Do you see some boot up messages on the display after you are done updating? note: don’t forget to put back the configuration switches back to the default state when you are done.

Joe, the boot messages do not appear.

[quote]Joe, the boot messages do not appear.
I know Mike. But we change the LCD configuration to headless system before we ship FEZ Spider. So The boot up messages will not show up if Gadgeteer app did not enable it back.
Updated the firmware will make sure the config sector is set to the default.

He did update the firmware several times, and he did try to write to the screen in a Gadgeteer application using the designer.

Excuse me guys. I was away. Yes, Mike is right. I did update the firmware with the updater (not manually) and no message appeared. I never succeeded in printing something to the screen.

Is it possible to know which version of the firmware is on the board and to compare it with the version needed ?