Main Site Documentation

New GHI installers package for hydra/gadgeteer users


#1

We are glad to have completed the GHI OSH SDK. This is still a beta release but it is complete. It even includes RLPLite! The following is GHI package installer. In includes everything even GHI’s non-OSH SDK. It also includes the new Gadgeteer SDK

http://www.ghielectronics.com/downloads/NETMF/Beta/GHI%20NETMF%20v4.1%20and%20.NET%20Gadgeteer%20Package.zip

Release notes are found inside the zip file above http://tinyclr.com/release-notes/

Built with:
Microsoft .NET Micro Framework v4.1
GHI Electronics NETMF SDK v1.0.17
GHI Electronics OSH NETMF SDK v1.0.1
Microsoft Gadgeteer Core v2.41.410

As always, refer to this page for details http://wiki.tinyclr.com/index.php?title=FEZ_Hydra_Developer
Note that this SDK includes TinyBooter so you can now use MFDeploy to load the firmware. All explained here http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra

Want to help?

  1. Add SD drivers. I think Atmel already provide them and we already include FAT in the build.
  2. Add SSL and test it.
  3. Test I2C and fix if there is a problem.
  4. Run libmpeg2 lib to RLPLite http://tinyclr.com/forum/21/5069/
  5. Add whatever you see fits! Native Game engine?

Have fun!

(PS: if you used the OSH SDK from 2 days ago, please uninstall it before installing this package. We deleted the old post to eliminate confusion.)


#2

awwwww:

Known Issues

• WifiRS21 module driver is still in development.

…I guess I have to be juuuuuust a bit more patient…


#3

I am sorry Jimmy. It is the last minute bug.


#4

Not having much success :frowning: I did the following…

  1. Uninstalled the last OSH SDK.
  2. Updated Hydra firmware using jumper method. This took much longer than expected. I didn’t time it but I would guess 6-7 minutes. It did appear to be successful though according to the log.
  3. Started a new Gadgeteer project. Woo! hoo! My USB modules appear in the Toolbox again! :slight_smile:
  4. F5 - deploy. No go. :frowning:
Device not found or cannot be opened - USB:Gadgeteer========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

Tried resetting & unplugging board.

Ideas?


#5

You forgot the firmware last time :slight_smile:

What do you get when you ping from mfdeploy? Did you select the hydra device when deploying from vs?


#6

Ping works fine. I selected Hydra from VS.


#7

Look at error message you posted again please :slight_smile:

This device name is Hydra not gadgeteer. So back to my question, did you select Hydra_Hydra fro the USB device menu on VS? :wink:


#8

Yep. I don’t know where that’s coming from… >:(


#9

Select serial them select USB then try again please.


#10

We will change the name to what gadgeteer template expects. For now, you need to change the settings back and forth to update the project to not use “gadgeteer” but use “hydra”


#11

Now all it will do when I try to deploy is get to the stage “Preparing to deploy assemblies to the device.” and spin… 15 min now and still not deployed. I’ve restarted VS several times. Only thing left is to restart the computer. I guess I’ll do that and try again in the morning…


#12

@ Gus - no worries; I gleaned as much from another post.

So far, the results are promising.
Didn’t you say that the flipped colors on the DaisyLink LED module was fixed in this release?
…Or am I misremembering …?


#13

@ Jimmy I think they will not be really fixed until a new firmware is available for the LED module. Until then, you have to call the Flip…() functions.


#14

I’m still dead in the water. I can’t get VS to deploy to Hydra since installing this update. It still just spins its wheels while trying to deploy. I’m getting the same result whether I’m deploying a native project or a Gadgeteer project. So, I think there’s either something wrong with VS as a result of the SDK update or there’s a problem with the firmware update. Is no one else having this problem or am I just lucky?


#15

Any ideas? I’ll be home soon and would like to make some progress. Otherwise, I guess my next steps are to uninstall/reinstall everything and re-apply the firmware and hope something gets fixed.


#16

I am not sure why this is happening to you. Has anyone else try this new SDK with hydra? It is workin fine here.

Do this, go to MFDeploy and change “USB name” to “Gadgeteer”. Then you will see “FEZHydra_Gadgeteer” on MFDeploy. Ping it and you will see TinyCLR back. Now, make new gadgeteer project and load it.


#17

Aside from module glitches Hydra’s working just fine for me.


#18

What glitches? so we can fix them :wink:


#19

Reading from joystick completely haults everything.

And man do I ever want to rewite that displaymodule base class. I know it’s an MS thing but how do they put in 2 interfacing WPF and Sans and not even have line methods…ok rant mode off; I’ll just code an alernative.

In the mean time; email module code changes to normal GHI email or what?


#20

How?