Main Site Documentation

My Spider Gadgeteer is not stable


#1

Recently, I got a problem.
I took my Gadgeteers to very far place to do the field test, but the Spider based Gadgeteer application suddenly reboot Irregular.
After I re plug the power even the USB or external power, the Gadgetee system reboot again and again.
I don;t change anything, the application works well in the office, but suddenly it happened.
I can’t fix it in that moment,my colleagues and boss suspect the stability for the Gadgeteer.

The other thing is the USB driver.
The USB driver is also unstable, I always need plugs in/out again and again then the PC finally recognize the spider, always waste my time.

That I was facing recently.


#2

If you use RLP or RLPLite or Register class you should be very careful with the addresses.

Also you may recheck the pins that you use. If you use pin which is used by the USB you will got the same issue.

I got the same problems on my discovery board when I used wrong pin or tried to use RLPLite.


#3

I do not use RLP or RLPLite in my application.
My application is not very complex.


#4

Yes display connected, before reboots, the display show white screen then reboots.
The most important things is, sometime happened sometimes not.


#5

Thank you, I do note use glide.
Today afternoon I test simple code, xbee receive the data sent by the other xbee, and debug.output the data. In first few seconds, works fine, then Suddenly stop print and reboot.
And when I re deploy the code,sometimes it works well.
Very strange and the Error "An error has occurred. Please check your hardware "
shows many times, I need plug USB in/ out many time.
I plug the USB Hundred times, I most lost my patient.
Get angry.


#6

I believe thats a hardware problem.
Maybe near by the USB connector on the pcb.
Or USB cable, or USB connector at PC or …
Next idea : Is something getting to hot on your pcbs ?


#7

Hi, I had this problem with my Spider and it was caused by not enough power, screen went white and it repeatedly rebooted. I.e. I plugged it into a powered Hub and problem went away.


#8

I use a power Hub and sometimes it happened. I will test it again or change to other Spider board to check. Thank you guys.


#9

@ Tzu Hsuan -

As jasuk70 said… I’ll bet a cup of Irish Whisky it is a power problem.

I have a Spider with a T35 display (IT WANT ELECTRONS!).

I have had my spider for quite awhile and the problem got worse as it aged. Not sure why but now I must have a Aux. power supply connected to use it. I have tried a different USB Client DP and it makes no difference.

My opinion only…


#10

+1 to power. When you’re in the field, what power source are you using, and through what power module? Have you measured current draw and voltage on that supply over time to see what it’s condition is?


#11

I guess the problem is the power too.
I use a Power Bank to power my system via USB(2A output) in the field test.
There are Xbee, GPRS, Ethernet J11D, USB Client DP Module, SD card, T35 display inside the box.

I re-deploy the same application and just test it today using different power(USB from PC,Power Bank, 110V to 12V AC/DC Adapter ).
All works fine. not reboot.
So It is unpredictable.

PS: My Power Bank can show the current consumption from my system. ( 400mA)


#12

I sometimes have the same problem, using a spider with ethernet j11d, sd, usb host, and extender with rfid board. For me, it looks like its j11d related. When i unplug the ethernet cable it boots normal. I’m using a external 1amp 12v power source.

Replacing the setup with a new set of boards (ethernet, sd, usb, extender, spider) did solve the problem for now.

I need to get into the problem tomorrow… any progress will be post here.

edit: using the latest sdk 4.2.10.1


#13

I did some additional testing and it seems related to the ethernet_j11d module. On my customers site they brings down the electricity during closing hours (its a museum). When they power up every morning it seems that the spiders ethernet_j11d module get some bad packets and causes the spider to reboot and sometimes results in a white screen. Bringing the power down and disconnect the j11d module from the spider and connect power again brings up the spider again. Reconnecting the j11d module, reboot and ethernet is working again.

I think the failure is not due to power limitation but more a lockup of the ethernet module. Anyone has a clue on this?


#14

i have notice this problem as well using
spider, GPS, J11D, USB Client DP, SD card, T35 display

when the bord get power after 1 or 2 day’s it’s reboot and don’t start
white screen as well

some times: it’s help to disconnect/connet the eth. cabel
some times: waiting a few reeboots, disconect power for some seconds
and the reconnect the power

maybe one element need to warm up ?
I’m not sure if its the USB Client DP or the J11D


#15

In this particular case, it is a drytek dsl modem with switched 10/100 ethernet ports


#16

Ha, it is nice to see that I am not the only one with this problem.
Now I am losing the confidence for using Gadgeteer in my final project.
Maybe I should consider the pure NETMF main board.


#17

I mean like using System on Module


#18

But in fact, Gadgeteer is more simpler for me. I like Gadgeteer.


#19

I don’t think it is gadgeteer related but something with the network stack.


#20

i updated my spider to 4.2.10 and renew my code to dhcp
don’t see the problem for a few day’s
what version you are useing…