Main Site Documentation

Laptop dont recognize fez spider


#1

Hi. Iejected fez spider during firmware updating by mistake and now laptop dont recognize fez.what should i do?
thank you.


#2

@ andre.m - it’s in normal mode now.


#3

@ andre.m - before fezconfig recognize my fez but i tried to update firware and ejected fez during updating by mistake


#4

@ andre.m - thats what i see. and wheh i try upload in loader mode its like second picture.


#5

Restart the firmware installation with the boot loader than the CLR.


#6

In loader mode you must see the FEZ Device as COM Port. Please expand "Baglanti noctalari (COM ve LPT) in the Device Manager


#7

@ Mike - but it couldn’t.like picture


#8

@ RoSchmi - it’s not there.i can update firmware now and pc recognize fez.but during in tiny booter updete its give error about “another device is connected,make sure that only one device is connected” and i just use fez spider and usb client sp module,there is no one more…before i used your bluetooth code and i attached it in number 9 socket.May it be about that?


#9

May be that it has something to do with hidden Com ports on your PC. If you use Bluetooth and use virtual Serial ports often new com ports are generated which stay there in the Background and interfere.
Here is a link how such unused com ports can be deleted.

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/how-do-i-delete-the-unused-com-ports-in-windows-7/4bb72733-1be0-4168-9ba5-68dcb72d31d9

Because of permanent issues with Bluetooth and the com ports I used the 32feet.net library on the PC and no virtual com ports

If you have another PC you could try to update the Spider on the other PC.


#10

@ RoSchmi - thank you very much.i have display screen on fez when fez powered screen blinks one time then turn off. is that broke down? during debug its gave that message

Found debugger!

Create TS.

Loading start at a0e00000, end a0e1383c

Assembly: mscorlib (4.2.0.0) Assembly: Microsoft.SPOT.Native (4.2.0.0) Assembly: Microsoft.SPOT.Security.PKCS11 (4.2
.0.0) Assembly: System.Security (4.2.0.0) Loading Deployment Assemblies.

Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Microsoft.SPOT.Security.PKCS11 (4.2.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)

Assembly: System.Security (4.2.0.0) needs assembly ‘Microsoft.SPOT.Security.PKCS11’ (4.2.0.0)

Error: a3000000

Waiting for debug commands…

The program ‘[2] Micro Framework application: Managed’ has exited with code 0 (0x0).


#11

As I interpret your post, you could now update the firmware, right? What turned out to be the reason for your issues?

I think, now you have a Version mismatch.
First I would try to set up an new application with only the power module and only program.started method. Does this work.
Then I would set up a new application an include code step by step. Keep in mind the you may not include the Bluetooth module with the designer when you use my Driver.


#12

@ RoSchmi - yes.but i creat new project i write code step by step. but normally the screen should keep turn on itself during fez powered but its blinked one time then turn off.just i fed up struggling with that lots proplems,we solved one ocuure another one :’(


#13

One day it will work, Keep on running.
The screen needs much power, you should use a powered USB Hub. If you don’t need the display in an application leave it away. Sometimes it helps to change or reconnect the Gadgeteer cable between Mainboard and power module.


#14

@ RoSchmi - i should keep try a lot.thank you very much for your interest again.


#15

this A30000000 error is often a mismatch in firmware. Can you show us the FezConfig check for update test now?

Then, go back to basics, create a new project that blinks LEDs. Make sure you can deploy that and that LEDs blink correctly.

Then, create a new project and move over any code you want into that project - in particular don’t use an older project that may have been set up with a different SDK version (you can remove all references and re-add them, but that’s easy to get wrong and get back into this scenario, so best to make small positive steps first)


#16

@ Brett - hi.i loaded picture here that what fez config says during checking firmware. and also i created basic new poject but it said “there were deployment errors.Continue?” and when i clicked yes it said check your hardware.thats basic program which i wrote and tried debug:

public partial class Program
{

    void ProgramStarted()
    {
        Debug.Print("Program Started");

        button.ButtonPressed += new Button.ButtonEventHandler(button_ButtonPressed);
    }

    void button_ButtonPressed(Button sender, Button.ButtonState state)
    {
        multicolorLed.TurnWhite(); 
    }

}

}


#17

As @ RoSchmi said, you did disconnect the LCD right? In your app, we just need button, multicolour LED, and USB client modules, right?

The last check I can suggest is the target device. Right click your project in the explorer pane on the right, select properties, then .Net Microframework tab and make sure your device is selected. I suggest you change it to Serial, then back to USB, to have the as-connected name populated, and try deploying again.


#18

@ Brett - i just use fez led and button.and i did it but same error was there


#19

so, then the only thing left to try is changing USB port/cable or changing to an alternate PC. Can you confirm what laptop model you have and if it’s using USB3 ports? That’s seen as a common concern, but not sure there’s an easy way past it.


#20

@ Brett - my laptop model is Fujitsu.i’m wondering because i successfully use that fez before,i made pulse oximeter with bluetooth module and i could send data to laptop over the tera term,just 2-3 weeks ago i could debug.but why that problem come up now. what do you think,may be my fez has bats in the belfry? is there probability that it is break down?