Main Site Documentation

Installing Visual Studio 2010 and SDKs.. A few questions and reactions


#1

I have had a few interesting hours installing VS 2010 and the MS and GHI SDKS. Almost everyting is working now…

To start trying the beta, I needed to install VS 2010 on a Windows XP SP3 machine

First I uninstalled VS2008 and then installed VS 2010 Premium edition, followed by the MS sdk and then the GHI SDK.

When I then copied over the replacement files from the GHI SDK to the MS SDK and MS Build areas.

I then tried to create a new MF project and got an error message. The message addressed a problem with a VS extension.

I had installed the VS Power Extension before the SDKs. So, I removed it, which did not help with the problem.

I have WMware workstation on my machine, and it adds an extension to VS for debugging. I disabled VMWare debugging and the problem went away. Interesting to know.

There might be issues with VS extensions and MF projects.

I then was able to build a simple project and deploy it to a Domino. Yes, I had upgraded the firmware on the Domino after loading the GHI SDK.

The only remaining issue is with the MS MF help files. From the readme file, it seems that the MF help content is alutomatically merged into the help library the first time the library is opened.

That did not seem to work for me. The MF documentation does not appear in the content page that comes up with the VS help. Anyone got this working?

The other issue I have, which is not really a MF issue, is the format /usefulnessof the VS 2010 help library. I think it is very poor relative to the prior versions.

The index appears to be gone, and the search function is almost useless.

I was able to find the MF 4.1 help file online, which are in the same format as the VS 2010 help files. I wanted to find out the DLL for “Debug.Print”. I did a search and got back 9,640,000 entries. Not like the old help files?

I finally had to do a search for “debug.print micro framework 4.1” to get the search results down to seven entries.

Have others experienced a similar reaction to the new help system, or is there something wrong in my installation? I am going to install on another machine tonight to see if I get different results.


#2

You look to have everything correct.
Maybe new visual studio has problems with some plugins or vice versa…
I think the merged help files are not supported. You have to use online help.


#3

I have had some small problems with the help too. I do not remember what I excactly did, and it was with the vs2010 beta, what I do remember is that I set some property from local help to online help (or vice versa).

1 thing I have to admit too, is that the MS help is sometimes pretty confusing, mostly I use google for problems/errors.


#4

I am having issue deploying to the Domino currently. Crashes Visual studio 2010 ultimate. If i replace the Debug dll VS wont let any .net MF stuff load. Still working on the issue but its aggravating.


#5

I reported the problem with the replacement files a few days ago. They work for some folks though. I have also found that even if I have the replacement file in MSbuild I have to uncheck ‘Copy Local’ for the GHI assemblies to get it to build.


#6

Jeff, any chance you can try it on a different PC? We are about ready for the public release but we want to make sure you are all set first.

Can we talk over the phone to discuss this?

Same for bstag, we want to work with you so let us know how we can help.


#7

I forgot to mention that with the replacement files I get lots of warnings about the ghi assemblies. The program loads and runs fine.

If I set local copy to false the warnings go away.


#8

OK so i figured out some things.

  1. I had to create a new Solution and add the old project.

That resolved the it wont deploy issue.

  1. I can not start VS 2010 Ultimate with the replacement DLL it tells me it cant load the .net MF.
    I have a work around which works but will be a pain in the arse.

If i start VS 2010 with the normally installed dll then change it out to the supplied DLL after the solution is loaded

i can debug.

I would guess this is due the DLL not being signed properly or something along those lines.
I am gonna start tracking this issue down and see what i can do about it.

For the Record my Dev machine is a Windows 7 64 bit install I am using VS 2010 ultimate edition.


#9

[quote]OK so i figured out some things.

  1. I had to create a new Solution and add the old project.

That resolved the it wont deploy issue.[/quote]

Please do not use any old projects or old solutions when you have problems or do not period. When you use old files and you run into problems then you wouldn’t know the source of the problem…old project or new system?!


#10

Gus, I have VS2010 loaded on another PC (XP SP3) that I used VS2008 and netmf on. I just added the netmf 4.1 SDK and GHI 4.1 beta SDK and have the same problem.

On the PC that I had problems with I even when through and uninstalled every last bit of VS2010 and installed it again. I still had the same problems though.

I’ll install C# Express on a different PC tomorrow and see how that works. BTW, the I’m using VS2010 Pro downloaded from my MSDNAA account. I’ve never had the Pro educational SKU act any differently that a commercial SKU of pro though.


#11
224 2010/07/30 03:54:16.304 Error VisualStudio CreateInstance failed for package [Microsoft .NET Micro Framework SDK] {20E16990-907D-49F0-B270-62D077697E61}
80131515 Could not load file or assembly 'file:///C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.1\Tools\Microsoft.SPOT.Debugger.CorDebug.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)

That is the log entry of the error loading DLL from the VS 2010 logs.


#12

bstag and Jeff, please do this

uninstall NETMF4.1
uninstall GHI SDK
install VC# express 2010
install NETMF 4.1
install GHI SDK.

do you have any problems now? We want to know the error is related to non express versions (although we already tried that here and Microsoft did too!)


#13

Ok can do sometime tomorrow. Interesting thing is i can debug with the Microsoft dll now.


#14

I have had those assembly errors too in the past. With this new SDK, I just copied the two files to their respective folders and created a new project.

VS2010 still gave an error on the GHI assemblies, but setting their property to local copy - false fixed that.

I do not have VS2010 express, I have ultimate. For now, everything runs very smooth, compared to the previous beta. ;D

If you need me to do some testing, please let me know :wink:


#15

[quote]bstag and Jeff, please do this

uninstall NETMF4.1
uninstall GHI SDK
install VC# express 2010
install NETMF 4.1
install GHI SDK.

do you have any problems now? We want to know the error is related to non express versions (although we already tried that here and Microsoft did too!)[/quote]

Well, after doing that, and copying the two files to their proper places, VS2010 Pro will create and load a netmf project. I still have to set all the GHI assemblies to Copy Local = False to I get the path related errors.


#16

Are you using the same project to test? Maybe VS saves some settings for the project and fails to load it with a different dll.

Try this.
During the steps below, do NOT open or use VS.
uninstall NETMF v4.1 SDK
Make sure the folder is gone from C:"Program Files\Microsoft .NET Micro Framework"
install SDK again.
Copy the dlls.
restart your computer.

Now, try to make a brand new Console Project and hit F5, does it work?


#17

Mike, that is basically what I did except for the reboot. I can create a new console project and it will compile. When I add a GHI assembly I have to set its properties to not copy local. I can try you steps exactly later today (at present I’m in the middle of something where I cannot reboot.)


#18

I meant try this for the professional visual studio were it couldn’t load the Micro Framework project. If you make a new project, maybe it will load correctly.


#19

Before I installed C# express:

If I copied over both files I could not create/open a project in VS2010 Pro.

After I installed C# express:

If I copy over both files I can create/open a project in VS2010 Pro (and C# Express).
I still have to set cach GHI reference added to ‘Not copy local’ or I get the invalid path errors.


#20

Ok, so first problem (not loading), it disappeared?! I wonder how it worked.

For second one (local copy), did you copy the device.targets to the correct folder and overwrote the old file? You should not get errors, but you will see few harmless warnings. Is this what you are taking about?