Hydra and Nano Spider USB Issues


The Nano Spider works correctly, although does not support the modules we need and is too small for our needs.

After installing drivers for the Nano Spider from here

Meridian WIN 32 USB Driver Install


When the display is attached it states, when powered on or reset…

Build Date:

Feb 23 2012

Starting Appliance at 0x0008400000

How do I get into Boot Loader mode… I’ve followed the following, and shorting pins 8 and 10 made no difference, cannot write a Program, to access because cannot access USB device…

tried to find the erase boot.bin to erase flash but it’s missing from this site for the SD card (and module I have!)


I’ll get this tomorrow…

Can you show us the device properties (USB VID and PID) to confirm ?


Can I clarify - you have a Sytech Nano as well as a GHI Fez Spider and a GHI Fez Hydra? Or do you just have a Sytech Nano and a Fez Hydra?

ok, with your nano connected, what device shows up ? On the driver properties page, what details can you see ? (screen shots will be fine).

I don’t have a screen to put on the hydra I have but I will step thru the bootloader update process to make sure I get all the intricacies… Can you confirm how you’re connecting pin 8 + 10 ? Do you have an Extender module or similar so you don’t have to rely on getting into the tiny Gadgeteer socket ? I honestly think that you’re not going in to bootloader mode - it only relies on having standard OS drivers available as it just shows up as a COM port when it goes into loader mode…

Sorry, for wrong terms…

I have a GHI Fez Hydra and Sytech Nano.

I’ll connect tomorrow, and upload a screenshot, I believe it shows up as a Meridien device, but I’ll screenshot tomorrow to confirm correctly.

I shorted pins 8 and 10, on socket 3 or socket 4.

I do have an extender module, I could try with this.

definitely use an extender, you can’t be sure you have sufficient contact with the pins when doing the multiple things you need to - connect power or reset while holding the pin connection for a few seconds.

I actually shorted pins 8 and 10 using a jumper.

anyway I’ll try again tomorrow.

When the USB Fez Hydra is plugged in there are no VID or PIDs displayed under Hardware Ids, just USB\Unknown…

See attached screenshot:-

I also upload screenshots of the Nano plugged in which is working.

okay, wired up the extender, pin 8 to pin 10 (ground).

Observations…after 5 seconds

0.Power up for 5 seconds before remove extender

  1. Display attached to Fez Hydra although turned on did not display anything.
  2. PC still displayed USB device is not functioning and Unknown device

After 5 seconds

  1. removed extender
  2. reset Hydra, display shows Fez Hydra sign on as normal…
  3. PC still displayed USB device is not functioning and Unknown device

No difference…

I could try SD Boot?

when the Atmel processor boots in loader mode, it just comes up as a serial port - you should clearly see it under “Ports (COM & LPT)” in device manager if it’s working. When I look at the device details tab I can see the hardware ID USB\VID_03EB&PID_6124&REV_0110.

OK, I have one more suggestion (before saying your Hydra isn’t recoverable unless GHI can make suggestions).

Instead of removing the extender module, just remove that jumper wire - in fact I left mine connected in the tests I’ve just been doing longer than 10 seconds with no effect on the driver (still comes up as a GPS Camera Detect device and stays that way. Connect everything including your USB cable, have device manager open and the PORTS section expanded, then hit the reset button on the hydra

Edit: as for trying the SD card option, sure, why not. Personally I had many fewer successes and no obvious signs that it did or did not work properly :frowning:

Edit 2: Did I already ask where you are located ? Know anyone with a GHI board ?


Thanks as you can see from the picture, the link is soldered!

So cannot easily remove the link…

I’ve left it there for 10 seconds, and nothing appears under Ports…just Unknown Device.

as usual.

I would try the SD card, but the link on this site to the Erase boot.bin is broken!

What is odd, is when 8 and 10 are shorted, the display does not boot…and displays nothing, as usual…

which makes me believe there is some life on the Fez Hydra…

see attached image…

Just found the edit button, I’m based in Yorkshire, UK I don’t know anyone with a GHI board, we have Arduino and other GHI boards (non Fez), and I was going to purchase a kit, until someone gave me this lot…to play with…

this is the broken link


No I didn’t really see that from the picture, but I can guess that now :slight_smile:

I agree, there’s something there. I don’t have (and have never had) a T35/T43 display for my kits, so can’t tell you what comes up on a regular boot into netmf - that personally isn’t a message I would have expected, but perhaps GHI or someone else with a Hydra + display can comment ?

Can you do me a favour and swap the short and long cables between your red module and extender and see if there’s any change (I know, clutching at straws).

This board is intriguing - you not knowing the history of it, I am wondering if someone has done a Linux install on it and that’s rendered it dodgy somehow - but I still would have expected it to boot in bootloader mode and expose that serial port.

swapped cables - still the same. :’(

I’d be going back to whoever gave you the board / whoever had it in their possession last and see what they did to it :slight_smile:

I assume the Sytech module is marked as a D module right ?

I really can’t think of anything else to try !! I’d suggest you go over the board and just make sure no pins are bent and touching, there are no obvious solder bridges or dodgy looking parts.

Questions for someone at GHI if they can…

  • Hydra with netmf and a display, booting, is the image from a few posts ago likely to be normal?
  • can someone resurrect the SD card file to allow the bootloader update and get it on the website?


Thanks for your help.

I’ll ask, the person who gave it me, however, I think this is/was “loan kit”, that’s been given out to many students in the past…

and the kit, that was given to me, many of the sensors have gone missing, and very coincidental, most of the high value ones e.g. GPS, WiFi, Bluetooth…

thanks for your help

From the looks of the screenshot, it is 4.1 firmware. We are trying to think of something that will help einsteinagogo but I do think that the processor may be not functioning properly. It looks like everything that he is doing is correct. It should be going into SAM-BA mode. The only thing really left to try is to get a GHI DP module to see if somehow that is the issue, but that is probably just a long shot and may be a waste.

@ einsteinagogo - Just to clarify, the Hydra never worked for you, correct?


Thanks for the reply.

Correct, the Hydra has never worked for me (the Nano has!).

I’ll try and get my hands on a DP, however the cost of a DP on it’s own, is expensive, when I can get a Hydra Kit with the DP, for not much more!

A SP is only about 6 euros, I’ll check what I have around here, and may take an option to get a SP or DP!

or brand new kit…


PS and all because I wanted to build a robot!

Gadgeteer USB Client DP Module - Purchased and Ordered…

we will wait and see what happens…I’ll post…


@ einsteinagogo - [quote]tried to find the erase boot.bin to erase flash but it’s missing from this site for the SD card (and module I have!)


I’ll get this tomorrow…[/quote]

the link is: https://www.ghielectronics.com/downloads/bin/FEZ_Hydra_EraseFlash.zip

interesting development, just turned it on…and no longer get the display info, as previous screenshot, and this is before trying the boot.bin file erase…

and when I connect the SD card, and turn on, and I get no Unknown USB on the PC!