Main Site Documentation

Hydra and Nano Spider USB Issues


#1

I’m sort of familiar with .NET, Visual Studio and C#, and I also though desktop PCs and USB issues, but this is really giving me the round around.

I’ve been given a large kit of .NET Gadgeteer modules, I’ve no idea of history, versions, firmware, whether working…

and I’m having major issues getting a connection to a PC, so far I’ve tried Windows 8.1 and a docking stating for USB, which is powered, and the device was reported as unknown, and I could not ping the device using FEZConfig.

So I decided I would build a purpose built clean Dev station from Windows 7, plus all the updates, and I get the same issue with this PC.

Unknown or a USB device has failed to operate error message.

I’ve read this could be power, I’ve also got a T35 display attached, and the Fez Hydra does boot, and display on the device, version, date of build, and I believe

Waiting…

Any clues, as to a way forward to get this up and running?


#2

welcome to the forum !

First thing I would do is just connect the Hydra without display. That will reduce the power consumption and if that’s your issue, should help.

You may need to go to manual firmware update - head to the “Support” link above, then documents, then find the Hydra firmware update process. This is probably what you’ll need to do to get things started, the tinybooter update https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra

Not knowing the history of that device usually means you will need to erase everything because if for example the Ethernet firmware was loaded, you’ll find the device won’t start successfully unless the Ethernet module is connected; a manual erase and reload will allow you to get past that and apply the non-Ethernet firmware.

You should also check out the https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting guide as there are other things that might be a challenge - in particular it might be worth telling us if you’re using virtualisation or bare-metal for your dev box, and whether you have USB3 or USB2 ports. I’d also do the “simple” thing and change the miniUSB cable…


#3

Brett

Thanks for your welcome and fast response.

I’ve only just connected the display, to give me some more diagnostics, just in case the device was dead.

So without the displays, the same issue.

Andy


#4

Although I usually operate in the virtual world extensively!

Knowing how poor USB virtualisation is, this is definitely physical. So big tick in the box for bare metal with a Windoze OS!

Laptop1 - USB3 and USB2 - no difference.

Laptop2 - new dev environment, is USB2 only.

I have tried different USB mini cables, same issue.

My power module is different, and I’ve not really seen it, rather than have a power socket, it has two screw terminals, and Mini USB.

I’ll have a look at the firmware link…


#5

Okay, tried a few more cables, and still the device states

USB Device Not Recognized.

and in Device Manager appears as Unknown.

Tried erasing the firmware by jumping pins 8 and 10, not sure this did anything.

on the screen, the device reports:-

FEZ_Hydra
Build Date:

Feb 23 2012
14:04:51

Starting Appliance at 0x0008400000

Before it stated Waiting, not sure why this has changed, I’m not sure what has changed.

Still the same

USB Device Not Recognized.

As I have a SD card, I was going to use the SD card, BOOT.BIN erase procedure, but the file cannot be found on this website…

http://www.ghielectronics.com/downloads/NETMF/Beta/EraseHydraFlash.zip

the above file cannot be found, do you know where I can get this…I’ve been around the website in circles looking…?


#6

@ einsteinagogo - can you provide a pic of your Hydra setup?


#7

photo coming up, tried all day…still Unknown device.

Rebooted Laptop Several Times, I went down to the Lab, to get a beefy regulated supply, 7 v olt, lots of current (with current limiter)

just in case it was power, changed cable, still no joy.

not sure if Firmware erase has worked…

here’s the setup with SD card read attached and nothing else, other than T35 display.

Connected to laptop (physical) and Bench supply - 7v.

Thanks


#8

Which version of the SDK do you have installed on your PC?


#9

Visual Studio 2010:

NETMF SDK 4.2 (RTM QFE2)

NETMF and Gadgeteer Package 2014 R1


#10

OK, so is there any reason you’re only using VS2010 ? VS2012 Express is equally free :slight_smile: Not that I think there’s any direct relationship, but the 4.3 SDK is working for many others.

If you correctly get the manual boot to work, you will simply see a serial port become visible instead of the netmf driver attempting to load. Often it will be detected as a “GPS Camera”. Depending on what hardware you have at your disposal, the simpler ways I know to do this are to use an Extender module or a G-Plug that is inserted into the right socket, and connect a jumper wire there. If you just try to connect a wire on the pins inside the Gadgeteer socket you’re not likely to be able to get that working reliably.

Out of interest, what USB module is that ?


#11

It’s a SyTech Designs Gadgeteer USB Device and +5V, +3V3 Power Supply.


#12

Brett/Sprigo

Thanks for your replies.

No reason why I’m using VS2010, and I understand the 4.2 and 4.3 relationship, I started out with VS2013, which is not compatible, so I only had VS2010 to hand…

but as far as I could see this is a driver issue, not got to writing code yet, and the drivers are supplied in the GHI NETMF and Gadgeteer Package 2014 R1 pack…

and it’s a driver issue I’m having…

So springo, wll spotted yes it is a

SyTech Designs Gadgeteer USB Device and +5V, +3V3 Power Supply

It does not look like the SP or DP - do we think this is the wrong Power Supply for the device ?


#13

@ einsteinagogo - To better troubleshoot your problem, we request you to upgrade to Visual Studio 2012 found here: http://www.microsoft.com/en-us/download/details.aspx?id=34673 and download the latest SDK found here: https://www.ghielectronics.com/support/netmf under step 3.

If the drivers are corrupted, you will need to update them and using VS 2012 is required as Microsoft does not support earlier Visual Studio versions with their latest builds of NetMF.

You should completely uninstall all GHI files before installing this new SDK to ensure a clean upgrade of drivers.


#14

looks like the website, was just re-written!

Okay, uninstalling…

the PSU Board is not the cause?


#15

okay, rather than uninstall, all the software and VS2010, and re-install, I decided to do a complete factory reset of the OS on the Laptop. (Windows 7)

and re-install from defaults…

So we will see what VS2012 and the new Released SDK on 31 July 2014 (yesterday) is any better.

Andy


#16

as you can imagine this is going to take a day or so, with 157 Windows 7 updates at least…


#17

Okay, so many hours later, have a fully updated Windows 7 bare metal physical laptop again.

It has Visual Studio Ultimate 2012 and NETMF and Gadgeteer Package 2014 R2 (NEW) installed.

and…

when connecting the Hydra and USB power supply, I still get an Unknown device in device manager.

So the question is, is this the correct USB power supply for the Fez Hydra ?

this USB supply, as spotted by a previous Experts, is a

SyTech Designs Gadgeteer USB Device and +5V, +3V3 Power Supply

It does not look like the SP or DP - do we think this is the wrong Power Supply for the device ?

Should I purchase a SP or DP power supply for the Fez Hydra ?

I cannot find one anywhere with the bits of kits that IU have received.


#18

The SyTech power module should be fine.

Please confirm what device gets loaded when you boot into loader mode - screen shot from Device Manager. I honestly think you need to manually load the firmware, as the previous owner/user may have loaded Linux on this.


#19

Brett

Okay, thanks for confirmation about the Systech power module.

As far as I can see, no device gets loaded in device manager. Other than it states Unknown.

Does attaching a display to the board help us in anyway?

See attached, I do have an SD card module for flash.


#20

the display may give you extra information, but it may also not - give it a try and if needed video it.

Are you sure that you are booting into bootloader mode at that point ? Can you show us the device properties (USB VID and PID) to confirm ? Do you have any other Fez devices that might prove the PC works ?