Getting ready for Endpoint

Ok, I have been away from Visual Studio for a while…

I want to get my environment ready for Endpoint.

I updated Visual Studio 2022 to the latest version. I saw this was required for .NET 8.

I installed the GHI VS extension for the Endpoint debugger, which I assume includes the project templates? I could not find any endpoint templates when creating a new project. Does a device need to be connected to create a project? Maybe .NET 8 must be installed for templates to show?

I don’t think I have .NET 8 installed. I tried to install with VS installer, but could not find it as an install option. If I create a console project, .NET 8 is not an option. Do I install .NET 8 SDK separately?

If anyone has gotten their Endpoint environment ready, could you please post how you did it?

FEZ Endpoint?

No Visual Studio here for now, sticking to VS Code.

I installed the .NET 8 SDK from [x64 Installer]( Download .NET 8.0 (Linux, macOS, and Windows) (

**Chose as appropriate for your CPU + OS

I opened up my VS Code hit Ctrl + Shift + P to get to “Endpoint: Create .NET Project”. A project using the template blinky project was created.

Ctrl + Shift + P

Select an existing folder

Type in your application name

Starter (template) project created

Nuget Packages restored

Debug fails (don’t have an Endpoint device yet)

1 Like

Thank you!

It is late here in New Jersey. I will try VS Code tomorrow on a ARM Mac.

I commented out the hardware dependent lines to run the executable on Windows for fun :grinning:



There is template for VSC but no need template for Visual Studio.

For VS, create a project then menu → Debug → Option → EndpointDebugger, check the checkbox to deploy to the device instead of running on PC.

@Raj @Dat

I was able to be Visual Studio 2022 running on Windows 11. I am ready.

Thanks for the assistance.


Receive my Endpoint today ! :heart_eyes: I love packaging !

But when I want to check checkboxe: :cry:

.net 8 runtime are installed.

Close the project, go to folder of your project, find .vs folder and delete it, reopen your project again.

we will add this to github issue.

Sadly, it doesn’t work.

I close solution, delete .vs folder, reopen it… and same message.

Make sure you can connect to the device, and have .NET 8.0.100 installed on the device.

Trivial question, but do you have .NET 8 SDK installed ?

Endpoint Config Tool see board

I can use ssh to access it.

I mean on Tool Config, do you see this:


Can you please try a new project

Sorry, I was unclear:

Seems everything look good. Try make new project, make sure Console App (C#).

I try recreate a project and nothing new (same error):

But I think it was related to ssh connection from VS 2022. I try to change password of Endpoint (from config tool). Edit VS Endpoint debugger. When I change password, I’ve a message that tell me VS is connecting:
But nothing after that.

I see “Hello from Endpoint”, where does it come from?

There is no trivial question when trying to help ! :grinning:
But that’s not the case .NET 8 SDK is already installed.

1 Like

That’s just the program which is executed localy (on pc not endpoint)

Do you have any other Window - English to try?