G80 - Visible but not usable?

I’m trying to figure out what’s going on with this G80 (seems I have a new issue very time :-(). It’s a new hardware unit, and it shows up in Device Manager as G80, but TinyCLR Config and Visual Studio can’t seem to communicate with it… USB cable has worked well with previous hardware units so I don’t think it is the cable…


image

You should use NETMF with G80 for starter. However if you want to try TinyCLR 1.0 (unsupported and not recommended) it should work. Not sure why VS is not seeing it!

Well I figured it out. I saw a bit of smoke release. Then I noticed what I had set the board on to do a little reflow work without melting my ESD mat… an old solder stencil. Unfortunately I had not taken it off before powering it up. Whoops… trash time.

Built another control board, new G80TH, same problem. Windows recognizes the USB device as G80 based on VID and PID, but I can’t connect to the device via Bootloader or Debug tabs.

Also of interest is holding LDR0 low while resetting has no effect - Windows still sees it as the same G80 device, no serial port, etc.

You only need power and USB connector.

Start from zero please, connect power and 3.3v. what do you see on device manager?

Power and USB =

image
image

Good and now please uninstall everything you have netmf and TinyCLR. Including USB drivers and vs extensions and SDK.

When done install netmf only.

If you still can’t see it then try uninstalling visual studio.

Or easier, try a different PC to just verify.

I have two PCs and both exhibit the same, one desktop and one Surface Pro. However both have VS 2017 and TinyCLR installed as I use both (one at the desk and one on the bench for the product). I’ll uninstall all and retry all with netmf to start with.

1 Like

FEZ Config can connect and seems happy:

Reinstalled TinyCLR Config (1.0.0-rtw) and it sees nothing.
Go back to FEZ Config and it sees the G80 OK still.

That is expected and is correct. You should not use TinyCLR config. User netmf for everything with G80

By the way, if you want to use TinyCLR, I suggest your submit for SITCore samples The All-New GHI Electronics 2020

@rackley
Try to delete the NETMF interface driver version 4.3 and install it from version 4.1. I had a similar problem connecting to the G120 in Win10 and VS2019 (VS2017).

2 Likes

I put in for samples already… However I’m confused by your statement that TinyCLR Config shouldn’t be used for G80s. This is the only chip I have used and I have only ever used TinyCLR and TinyCLR Config from the early beta days and it has always worked. Was something changed that broke this compatibility? The G80 TinyCLR 1.0 firmware is still listed on the Downloads page…

PCBs for SITCore already on the way:
image

2 Likes

Sorry about the confusion. Let me clarify:

  • Use any NETMF product (including G80) with NETMF only -> not recommended for new designs. limited support.
  • Use any NETMF product (including G80) with TinyCLR 1.0 -> Not recommended and not supported. You are on your own. It should work so I am not sure why you are having problems.
  • Use any SITCore product with TinyCLR 2.0 -> highly recommended and fully supported.

Yes it is because we are awesome and we keep everything for you but the page also says “These downloads are provided with no support and are not recommended for commercial designs.”

“Use any NETMF product (including G80) with TinyCLR 1.0 -> Not recommended and not supported. You are on your own. It should work so I am not sure why you are having problems.”

Understood. Was it supported at some point in the past or did I just gloss over that during development?

It was with TinyCLR 1.0 but we are now dedicating ask out resources to TinyCLR 2.0