Main Site Documentation

G400S problems update samba bootloader


#1

Hello guys,
I am facing troubles with G400S - with flashing new bootloader.
it seems to me that dataflash does not work. But I need confirmation, than i will try to change it on module.
first 30 pcs was assebled and work properly almost 2 years. Now factory assembled for us second series of our device. and when i would like to flash new samba bootloader, so the module does not answer at flashing …
But if i am trying get answer from DDR - so it works…
with older serie it works properly.
( it’s on our board, vcc corect, connected only with USB, windows can see the port, i can communicate via samba v2.12 )

(sam-ba_2.12) 1 % GENERIC::Init $RAM::appletAddr $RAM::appletMailboxAddr $RAM::appletFileName [list $::target(comType) $::target(traceLevel) $BOARD::extRamVdd 1 16 $BOARD::extDDRamModel]
-I- Loading applet applet-extram-sam9g15.bin at address 0x300000
-I- Memory Size : 0x8000000 bytes
-I- Buffer address : 0x300B90
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
(sam-ba_2.12) 1 % DATAFLASH::Init 0
-I- DATAFLASH::Init 0 (trace level : 4)
-I- Loading applet applet-dataflash-sam9g15.bin at address 0x20000000
-E- Script error: Error Initializing DataFlash Applet (Can’t detect known device)

Some idea without changing dataflash please ? ( adesto 1536 45DB321E on working devices ) adesto 1818 on current which does not work.

Thanks
jindrich


#2

Please see this http://docs.ghielectronics.com/software/tinyclr/loaders/sam-ba-bootloader.html


#3

Hi Gus,
thanks for fast response. Of course i could see user guide.
in log file above you can see, that i am able to connect but answer to “execute” data flash enable is with error.
answer to command “execute” ddr ram is with succes.

if the older module ( correct one) is connected i can get succes to dataflash enable and i can download bin file…

if i am not able to communicate with dataflash ( in newer module) so there is no chance save the bootloader :slight_smile: .

any idea ?
thnx
BR
Jindrich


#4

Try to install samba v2.18. v2.12 doesn’t work well on Win10, or try with different pc.


#5

Hi Dat,
Thanks. I tried. still the same response. ddram execute valid answer. execute enable dataflash
( error initiali… ) / win7 prof. usb2 port. samba 2.18.

if i am tring older module with the same sw and hw platform so it still works properly via all steps…

Jindrich


#6

Is it just one that is failing or do you have a number from the new batch that fail?


#7

Hi John,
We just tryied 4 pcs from new serie. and all of them has the same issue.
J.


#8

Any way you can try this on a different PC?


#9

Hy Gus,
We tryied it. my colegue notebook with win10. Me personally notebook win7 prof / and second standard PC with win7 prof. All 3 stations with the same result. Answer to execute DDR ok, answer to initialize dataflash with error message.
J.


#10

What does it say in your device manager for the connected device? Remember you need to short out a pin (I cant remember which)… so that it changes to a Bossa device (or something like that)


#11

of course , i am in bossa com port mode… in other case samba doest not communicate with module.


#12

Did you?

  • Run the application in Admin mode,
  • If the port is higher than 32, change it to under 32.

#13

Yes, I am in admin mode. com port 5 . on other PC 19.


#14

is it a custom board or FEZ Raptor? any connection on the spi port0 pins (miso, mosi, clock and PA14?)


#15

it’s custom board. send me please contact email . i can send you schematic.


#16

support@ghielec…

They will forward your email to right person.


#17

So our schematic was under revision of Gus Issa. I got advice to switch off all peripherals connected to SPI ( we have on our board buffer atd eth phy), all has to be inactive, because SPI shares bus with dataflash on G400.
When the bus is clear so samba’s and tinyboot’s update work correctly regarding user guide.
Thanks a lot
Jindrich