Main Site Documentation

G400S 1.8V and 1.0V supply issues


#1

I have a design that uses the LTC3406 switching regulator for both the 1.8V and 1.0V supplies for the G400S module but I am getting an issue with them where 1 or both thermal overload and the output fails. The thermal imaging camera shows them as hot at around 60°C and I then have to replace them.

They are using the standard parts that are recommended in the datasheet. GHI use similar parts on the G400D module. The current drawn by the CPU on these is way less than the 600mA they can produce at far less than 100mA.

Could it be that there is a delay required on the 1.8V and 1.0V supplies? On the G400D module pins 1 and 4 are not connected indicating that pin 1 (RUN input) is somehow connected to a delay circuit? There is no reference to this in the G400S datasheet for this requirement and the processor datasheet indicates some kind of sequencing but the timings are very small.


#2

hmmm, I went looking for info on the power requirements for the G400D and didnt find much about, only that it used 3.3 and ‘other’ supplies needed (like you mention).
Any went hunting of for specs on the AT91SAM9X35 to see if could get details of the power requirements for the 1.0v and 1.8v rails.
After a bit of a hunt I found a table that suggests the VDDCORE might be as high as 200mA.

Here’s what I found

http://ww1.microchip.com/downloads/en/AppNotes/Atmel-11299-32-bit-ARM-Embedded-Microprocessor-Powering-Atmel-eMPUs-with-ActivePMU-PMICs_Application-Note.pdf

Any help?

Regards

Paul


#3

Thanks Paul but even at 200mA this is well within the 600mA that the regulator can provide. I think this is related to the input capacitance. My design has a shared 10uF cap but I think I will add 2 local 4.7uF caps to the device and see if this makes it more stable. This design worked before on another design but different processor but reading the LTC3406 datasheet again the lack of the caps could be causing the problem.


#4

ahh sorry I had it in my head it was 60mA
Yep true!

hmmm, gee to get that hot and go into thermal shutdown, seems they are getting pretty stressed!.
Sounds like a load problem… but let us know how the caps go…

Did you also see the MicroChip power schematic (using their power chips I believe), might be interesting to look over too see if any clues on their reference design…


#5

FEZ raptor used G400S. You can use that as a reference to compare what we have.


#6

Here it is http://docs.ghielectronics.com/hardware/legacy/gadgeteer/fez_raptor.html


#7

Can you clarify this statement? Are you referring to the regulators on the G400D? If so, there are no delay circuits involved with these regulators. Pin 1 “RUN” is pulled up to 3.3V. As for pin 4, that pin is indeed connected to 3.3V power.

Also, is this the only prototype that you have tried to power? Is it possible that one or both regulators on the one prototype are bad?


#8

Yes, this is the only design with the G400S. Previous designs used the G400D.

If I measure between pin PIN 1 and PIN 4 on the G400D I have, there is not a direct and I read 656 ohms with my meter. Tracing the circuit from PIN 1 (ENABLE) I find that both regulators are connected and also to MN4 which appears to be a low drop out regulator which also has its enable connected and this goes to an RC timing network made up of R16 and C31. Is there a reason you delay the regulator enable on the G400D but on the Fez raptor, there is no delay on the 2 regulators.


#9

Do you mean to say that this is the only physical board that you tested? Was another built that are giving you the same results?

As I said above, it is being pulled up so there will be resistance between pin 1 and pin 4 where pin 1 is directly connected to 3.3V.

These two components are not connected to those enable pins. These are connected to a pin that is labeled VBG (ball U17) on the processor which, according to the datasheet, is the Bias Voltage Reference for USB. This same circuit is also found on the G400S. The trace must have gotten lost under the silk.


#10

I have had this issue on 3 boards but suspect this is due to the lack of capacitor on the input. I am waiting for some X7R caps to arrive and solder them in and retest. I’ll report back when I have it done.

Yeah, when I do a meter check it doesn’t connect. It looks like it does but after closer inspection, the track disappears under the resistor. Sorry for the confusion.


#11

What capacitance values do you have? Have you looked at the schematic sheet that Gus provided?


#12

I have 10uF ceramic on the input but shared between the 2 devices. I am currently reworking to give each IC its own 4.7uF cap and fit this close to the device and waiting for some to arrive for testing the current board.


#13

Just a quick update. Adding a 2.2uF X7R cap to each input pin as close as possible has made the design stable now. Working with the board all day and no more hiccups with the power supplies. I’ll be sure to use this for all future work.


#14

You owe @Aron_Phillips a beer :slight_smile:


#15

Does he accept virtual beers? :wink:


#16

:beer: Yes