G120 does no more respond over USB

I updated the G120 Firmware with FEZConfig Version that indicated successful update.
However, the device does no more respond over USB.
After that I have tried Manual Update several times with help of teraterm and the device responds over serial connection, is erasing flash and transfers (XModem) new G120 bootloader for v4.2 SDK. Now the problem seems to be that G120 does not restart and stop responding with teraterm like said in the instructions.
As a result the device is stuck in serial mode (COMxx) and reponds only to commands issued from Teraterm.
The FEZ config shows serial port COMxx when I connect the USB, but the device does not respond to Ping there. Using a Power supply does not help either.
Any instructions how to get my G120 working over USB as usual?
BR, Seppo

Can you show us images of your device manager when you’re in the mode you are? That might help identify what did or did not deploy and what drivers are in play.

Yes, see the attached screenshots from Tereterm and FEZConfig.
I’m able to connect with Teraterm in serial mode and check version, erase flash and trasfer bootloader like shown in the images. However that does not change my G120 to USB mode like expected.
The other two images are taken from FEZconfig where it does not show G120 in USB mode. Instead it shows that serial port COM10 is available.
It is strange that the device does not resport to Ping when I select serial mode like shown in the image.
I wonder if the device has some problem with serial port baudrate?
BR, Seppo

show us device manager !

Can you also confirm that you did NOT have teraterm open and holding the serial port open when you tried fezconfig?

Yes, I can confirm that I have closed the teraterm application, disconnected/reconnected and reset the G120 device before opening FEZConfig.
I understand FEZconfig is the primary “device manager” for G120 modules???
It does not appear either in VS when USB is selected.
It seems that also other have similar G120 firmware prolems like

Now I see you ment the device manager for the Windows operating System.
It shows up the GHI Boot Loader Interface (COM10) driver.

I have the same problem here.
What can I do?

This was a weird case.
I managed to get my G120 back to USB debug mode in another PC at home where I made a clean installation for the NETMF 4.2 SDK.
After that also the firmware update succeeded without any problems.
For some reason the bootloader manual installation with teraterm failed in my workstation.

snip. Matt5 removed his posts :slight_smile:

I have been facing similar problem with G120 Wifi board. I uninstall the driver then connect board to PC then, on device manager it shows following image 1.

then I updated driver software from C:\Program Files\GHI Electronics\GHI USB Drivers
and driver installed as a GHI bootloader interface. (image 2).

Then, I try to follow the procedure from following link

But, I cannot update firmware in FEZ config as COM port, I don’t know how could I make G120 work as USB communication. I did use tera term to update firmware and I uploaded loader.ghi file. I used LDR1 and LDR0 button and reset the module, but couldn’t come back as USB.
Even I cannot ping while connecting as COM port (image3)

Any help would be great…

Arkshay, did the update with Teraterm really work?

From the documentation:

I noticed in svesteri’s screen shot that there was a “BL” after the upload, so it actually failed, even though the message says that the transfer finished successfully.

I have had to upload 3 or 4 times to get it to succeed.

Please show what Device Manager says in both the “bootloader” scenario and “normal boot” scenario. It seems you may have those two modes confused, as the first image shows the “G120” device (normal boot mode) and then the driver update shows the bootloader mode.

Also note, when in bootloader mode, doing a PING in Fez Config to a COM port isn’t something I would expect to be reliable if it works at all… That is best used to confirm tinyclr is running in normal mode.

@ stevepx, I do see the BL after the loading loader.ghi file through teraterm ( image2). I have tried more than 5 times as you said, but seems like it doesn’t work.

@ Brett, I have attached screenshot of the device manager, problem is that it is always stay in that Bootloader Interface mode, how could I change the mode that it can work through USB and update the firmware of it ? Device doesn’t appear on visual studio as well ( image1)

Are you using terra term from our website? Not all versions work for some reason. Or use fez config.

I tried the version as mention on your website, still isn’t working ( image1)

what device do you have ? Is it a Cobra2 Wifi ?

Yes it is cobra 2 WiFi. So, what could be reason for it not coming as USB interface ?

I would suggest you redo the bootloader update, then reset the device. Then, use Fez Config to check the device for upgrades, you may need to reset it again after that (and I’d suggest restarting Fez Config too). If that all worked, just go into Fez Config and try the firmware update. If that works, you should then be able to see the G120 device not the bootloader COM port.

That isn’t work, but I got another board that does work, so something wrong with that board. I got another problem, when I deploy my code to the board it gives me following error:

Found debugger!

Create TS.

Loading start at a0e68e2c, end a0e982c0

Assembly: mscorlib ( Assembly: Microsoft.SPOT.Native ( Assembly: Microsoft.SPOT.Security.PKCS11 (4.3
.1.0) Assembly: System.Security ( Assembly: Microsoft.SPOT.Hardware (
Assembly: Microsoft.SPOT.Graphics ( Assembly: Microsoft.SPOT.TinyCore (
Assembly: Microsoft.SPOT.IO ( Assembly: System.IO ( Assembly: Microsoft.SPOT.Hardware.Usb (
Assembly: Microsoft.SPOT.Hardware.SerialPort ( Assembly: Microsoft.SPOT.Touch (
Assembly: Microsoft.SPOT.Ink ( Assembly: Microsoft.SPOT.Hardware.PWM (
Loading Deployment Assemblies.

Attaching deployed file.

Assembly: Microsoft.SPOT.Net ( Attaching deployed file.

Assembly: GHI.Hardware ( Attaching deployed file.

Assembly: mfnet.smallbiz.common ( Attaching deployed file.

Assembly: System.Http ( Attaching deployed file.

Assembly: GHI.Glide ( Attaching deployed file.

Assembly: Microsoft.SPOT.Time ( Attaching deployed file.

Assembly: System ( Attaching deployed file.

Assembly: System.Xml ( Attaching deployed file.

Assembly: Toolbox.NETMF.Core ( Attaching deployed file.

Assembly: System.Net.Security ( Attaching deployed file.

Assembly: GHI.SQLite ( Attaching deployed file.

Assembly: GHI.Usb ( Attaching deployed file.

Assembly: powercloud ( Attaching deployed file.

Assembly: GHI.Pins ( Attaching deployed file.

Assembly: Microsoft.SPOT.Hardware.OneWire ( Attaching deployed file.

Assembly: Microsoft.SPOT.Net.Security ( Attaching deployed file.

Assembly: GHI.Networking ( Resolving.

GC: 1msec 745428 bytes used, 6594240 bytes available

Type 0F (STRING ): 24 bytes

Type 15 (FREEBLOCK ): 6594240 bytes

Type 17 (ASSEMBLY ): 45948 bytes

Type 1E (BINARY_BLOB_HEAD ): 699384 bytes

Type 34 (APPDOMAIN_HEAD ): 72 bytes

GC: performing heap compaction…

The debugging target runtime is loading the application assemblies and starting execution.

‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\mscorlib.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Native.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Security.PKCS11.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.Security.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Graphics.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.TinyCore.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.IO.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.Usb.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.SerialPort.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Touch.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Ink.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.PWM.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Net.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.Hardware.dll’
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\data\tfs\zigbox\mfnet.smallbiz.common\bin\Debug\le\mfnet.smallbiz.common.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Net.Security.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.Net.Security.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.Http.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\System.Xml.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.Glide.dll’
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Time.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\data\tfs\zigbox\Release (4.2)\le\Toolbox.NETMF.Core.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.SQLite.dll’
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.Usb.dll’
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\Microsoft .NET Micro Framework\v4.3\Assemblies\le\Microsoft.SPOT.Hardware.OneWire.dll’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.Networking.dll’
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\data\tfs\zigbox\intelliBin\bin\Debug\le\powercloud.exe’, Symbols loaded.
‘Microsoft.SPOT.Debugger.CorDebug.12.dll’ (Managed): Loaded ‘C:\Program Files\GHI Electronics\GHI NETMF v4.3 SDK\Libraries\le\GHI.Pins.dll’
#### Exception GHI.Networking.WiFiRS9110+HardwareTimeoutException - 0x00000000 (2) ####
#### Message:
#### GHI.Networking.WiFiRS9110::WaitOn [IP: 0012] ####
#### GHI.Networking.WiFiRS9110::UpdateInternalMacAddress [IP: 0025] ####
#### powercloud.Program::.cctor [IP: 00d0] ####

This upgrading message is then keep going, How could I solve this issue ?

@ Akshay - I believe this was fixed in latest pre-release. check the announcement.