Main Site Documentation

G120 can't update tinybooter


#1

I have a G120 module on a custom board and earlier today the G120 module lost all the application and seemingly too, the firmware and would only boot as a serial port device.

I am using Tera Term to reprogramme Tinybooter but I get a FileTransfer Finished Successfully and the BL Is shown in the output window. The online docs indicate that this is an error.

No matter how many times I try to update Tinybooter it will not work.

This was the same file I used the other day to update the same module.

What else can I check?


#2

The same steps work on another device?


#3

Yes. The other 2 boards programmed with the same setup. They are both updated and working.


#4

@ Dave McLaughlin
I had almost the same issue as you. Before replacing the G120 module I decided to try and replace only the serial flash. For some odd reason after replacing the serial flash I was able to update the same module. If you have another G120 that you can take the serial flash from I think you should give it a try, much easier than replacing the module.
The SOIC-8 package is pretty simple to replace with a descent soldering iron.

Good Luck.


#5

Into which memory does the bootloader reside?

I am wondering if the load spike I had today may have taken out the memory IC on the board. I found small design fault where the LCD casing may short out the supply which is now fixed. :frowning:

I see that there is a serial flash device on the board that could potentially be replace if this was the one at fault.

Is there any commands I can issue at the bootloader to check anything?


#6

Just what I asked and you where posting before I finished. I’ll order up a replacement on Monday as I have found a supplier who has the same part number. At least I think it is. :slight_smile:


#7

@ Dave McLaughlin

I asked the same question a while back regarding the memory organization.
Unfortunately, @ GHI didn’t reply :frowning:
Please post your results.

S.B.D


#8

@ Dave - I also have 2 or 3 G120 modules on custom boards that are exhibiting the exact same symptoms – namely “BL” always showing up immediately after transferring the bootloader file. So you’re definitely not alone. The other boards in the same batch are fine and update normally. So there’s definitely something different about some of them. I might give the serial flash replacement a try.


#9

I think R command is used to run but in your case will probably just send BL back?


#10

@ Gus - When I get “BL” after uploading the new TinyBooter file and I subsequently type “R” I get “Bad firmware” reported back.


#11

Can we borrow this unit to do some testing?


#12

@ Gus - Sure. Where should I ship it to?


#13

To me at our address on the contact page please


#14

Hi Gus, I just tried the R and got back Bad Firmware and then BL


#15

I replaced the SPI FLASH device with the same type. Still won’t accept the firmware so suspect something else is faulty.

I have a spare G120 so just need the time to remove the faulty one from the board! :frowning:


#16

When I issue the B command, get back


921600?

What does that mean?

EDIT: I just found that it is the baudrate. :slight_smile:


#17

Hello, I have the same problem with G120HDR. I tried to update the firmware with TerraTerm i’t looked finished but didn’t worked. After the R command it answered Bad firmware for B 921600? . Has any solution for this problem?


#18

Unless we can get an answer from GHI on which device is likely trashed, there is not much hope for this to get working again.

I changed the serial FLASH memory device and still nothing works.


#19

Why not using FezConfig instead of Teraterm.

FezConfig. Menu Advanced->Loader (Tinybooter) Update->G120


#20

@ RobvanSchelven

Just tried that and it can update the Tinybooter but then fails with a window saying that:

The USB drive may not have installed correctly. Re-installing the USB driver may solve this issue.

Opening a terminal to it shows Bad Firmware.

I’d be willing to send this to GHI if it would be worth them checking out why this is not working and which device has failed?