G120 can't update tinybooter

I guess its a question for GHI

We would happily look it is if you feel this would help you. However, if the unit is not faulty then you will have to cover the shipping cost.

I have exactly the same problem with a FEZ Cobra 2:

  • tried with FEZ Config of 4.2 R3
  • tried with Teraterm of 4.2 R3
  • tried with G120Update.exe and firmware of 4.2R3
  • tried with 4.2 R2
  • tried with 42. R1

All of the above processes have had the same result: Bad Firmware, and the Cobra 2 contine to remain in the bootloader state.

Cristiano, can you step us through the manual process with TeraTerm and tell us what fails when? Also make sure you copy out the terminal output and paste it in here.

Hi Gus, I would like to as I think it would be good to know what is wrong. The G120 is fitted to a custom board and I will send it with a power cable. The USB is a standard Type B.

I’ll send it to the GHI address with your name on it. Any RMA needed?

Not worried about the costs. I’ll easily cover this. I’ll be ordering more anyway in the new year so I can get it back with the order shipment :slight_smile:

I have followed the istruction at https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families

  • connect the Cobra 2 to the PC, and in Devices and printer of windows I can see “GHI Boot Loader Interface (COM5)”
  • launch the TerraTerm as Administrator
  • select Serial and COM5 in the “Tera Term: New Connection” window, tha Ok button
  • press the “b” on the PC’s keyboard, so “BL” appear in the Tera Term VT window
  • press “V” => “1.01” “BL”
  • press “E”, “Y” => erase the memory correctly
  • press “X” => CCCC…
  • select File > Transfer > XMODEM > Send… and choose the file C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G120\Firmware\TinyBooter\G120_TinyBooter.GHI
  • select “1K” and than press the Open button
  • File tranfer Finished Successfully
  • press “R” => Bad firmware
  • the Cobra continue to be in the Boot Lader state

That’s all, any idea or suggestion?

Brett, for reference, that is exactly the same issue I am getting.

The other 2 custom boards with the G120 are fine.

All looks good to me. I can’t explain nor assist further, sorry. I think GHI will need to ponder next steps

What if the firmware file you have is corrupted, just a guess.

Also is anything connected to the SPI bus?

Hi Gus,

The firmware updates the other two G120 modules without any issues so there is no fault with the file itself.

Nothing else tied to the SPI on this board. On one of the other boards I have the WiFi module but the board that won’t programme is free on the SPI lines.

Nothing is connected, just only the usb cable to cennect to the PC. It is a Cobra II Net.
I have tried with and without an external power supply, same result.

I have tried with 3 version of NETMF and Gadgeteer Package (R1, R2 and R3) on 2 different PC (windows 7 and Windows 8.1).

Today I have received a new Cobra II Net and the update procedure by FezConfig went successfully.

Same PC (windows 8.1), nothing connect only the usb cable to the PC, same firmware of the NETMF and Gadgeteer Package 2013 R3.

What can I do with the cobra II that does not want to update?

I’m waiting for a respone from GHI, because I dont know what to do. :frowning:

Thanks to all for your time.

Today morning i tried again to update the firmware. When i powered up the board and connected to the PC it has worked again. Since friday i didn’t do anything. I don’t know what happened but it’s fine again.