Main Site Documentation

Fifth Preview of TinyCLR OS Core Features and Porting


#21

@ Bauland - you do not need to build anything but if you built your own firmware then GREAT. We want everyone to be able to do that, but this is optional.


#22

oh wow! This will only make us work harder. Thank you for helping us test TiynCLR OS :slight_smile:


#23

@ Gus - Sorry to say that but where can we found already built firmware without build TinyCLR-Ports ?


#24

Did you follow these steps? http://docs.ghielectronics.com/tinyclr/intro.html


#25

Thanks Gus, I was so excited that I’ve missed the line you point me !!! :wall: :wall: :wall:
Although, now I know how to build firmware :smiley:


#26

#27

@ Bauland - great! I wish everyone understand the value of their gadgeteer hardware and how it is still useful today… Maybe I should go back and make some videos about gadgeteer :wink:


#28

Here is the driver for those having issues https://www.ghielectronics.com/downloads/TinyCLR/GHI_TinyCLR_Interface.zip

We are still investigating this.


#29

@ Gus - You’re welcome.-


#30

I’m trying to get TinyCLR OS loaded on my Quail but can’t figure out how. I tried the Quail Firmware.0.5.0.hex but that error’d out and then tried the the two FEZ bootloaders but that went nowhere. Could you please post instructions?


#31

Have you seen this? http://docs.ghielectronics.com/tinyclr/boards/quail.html


#32

So does this mean we can use TinyCLR on commercial products now?


#33

I do not understand what can fail on your side. However, here is how I do it :

  • Using DFU File manager, create a .DFU from the Quail Firmware.0.5.0.hex file
  • Put the Quail in DFU mode (Press both Reset and Boot buttons, Release Reset, then release Boot)
  • Using DFU Tester, erase the flash
  • Once done, click on the “Download” button and select the DFU file you have generated just before
  • Once done, click the “Leave DFU mode” button
  • Reset the Quail

It should now appear as “Quail” in your Windows peripherals (in the USB section)


#34

If you are happy with a pre beta software :slight_smile: no it is not production ready yet.


#35

My bad. I’ve been using NETMF for 10 years and have used DFU Tester and DFU Demo a hundred times but never DFU File Manager. Didn’t even know it existed until I looked in the Start Menu. Guess I should read the original instructions a little harder :-[


#36

I get a whole bunch of “error: target CPU does not support ARM mode”

C:\TinyCLR\TinyCLR-Ports-master>build FEZ build release normal c:\GCC5_4_2016q3
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_Startup.gcc.s
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_AD.cpp
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_AD.cpp:1:0: error: target CPU does not support ARM mode
// Copyright Microsoft Corporation
^
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_DA.cpp
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_DA.cpp:1:0: error: target CPU does not support ARM mode
// Copyright Microsoft Corporation
^
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_Flash.cpp
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_Flash.cpp:1:0: error: target CPU does not support ARM mode
// Copyright Microsoft Corporation
^
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_GPIO.cpp
C:\TinyCLR\TinyCLR-Ports-master\Targets\STM32F4\STM32F4_GPIO.cpp:1:0: error: target CPU does not support ARM mode
// Copyright Microsoft Corporation


#37

Which port? What steps?


#38

@ Designer- c:\GCC5_4_2016q3 may be incorrect version.
In notes, it is version 6 - 2017 q2.


#39

@ Bauland -

Try to use gcc 6.3.1 or latest one.

If still want to use 5.4 and fix that error, add “-mthumb” right after -mcpu=%MCpu% in build.bat.

and correct the library


SET "GccLibrary=%GccDirectory%\arm-none-eabi\lib\....."


#40

@ Dat - thank you … will attempt this later in the day.