Main Site Documentation

Fifth Preview of TinyCLR OS Core Features and Porting


#41

@ Designer - day is saying, follow the instructions :slight_smile:


#42

@ Gus

I have reasons :slight_smile: and Dat’s response might help me get going with GCC5.4 !


#43

Followed instructions and generated three files

FEZ Firmware (three files)

  • HEX,
  • BIN and
  • GLB

but i’m not showing where is STM32 DFU bootloader or i’m missing something !!!

thanx,
VALONI


#44

Which board will you upadte ?


#45

@ Bauland -

I’m using Nucleo STM32F411RET6 and this board tested with

downloaded files
FEZ.Bootloader.2.0.3.dfu (uploaded in DFU mode) and
FEZ Firmware.0.5.0.glb

which i uploaded with TERA TERM after help from this forum with instructions i received

and tested blink code which worked well

regards.
VALONI


#46

@ valon.hoti@ gmail.com - Glad to see it’s working


#47

i tried it on my old cerb 40 and its working !! the only problem faced after firmware update fez cerberus appeared in the device manager but not picking up the driver from 2016 ghi framework , then i tried the driver mentioned this thread by gus worked. ( https://www.ghielectronics.com/downloads/TinyCLR/GHI_TinyCLR_Interface.zip )


#48

@ valon.hoti@ gmail.com - how did you set the Nucleo STM32F411RET6 board to DFU mode?


#49

@ RoSchmi -

Steps

1.Connect pin boot0 with vdd (jumper) on nucleo
2.cutted usb cable on mid (i have no usb prototype board but cheap usb cable of 0.50 euro with 2 DuPont wires F-F did job) and black wire connected to gnd nucleo
Green wire to pa12 , white to pa11(some usb cable have oposite colors so maybe you need to use green wire to connect at pa11 and white at pa12 instead),red wire to nucleo 5v

see picture on this link : https://mobilewill.us/stm32-nucleo-and-dfu-usb-bootloading/

Put usb cable on pc and voila you will see now you are on dfu mode (STM Device In DFU MODE like pictures i attached)

3.use dfu tools from stm website to upload into nucleo (fez bootloader)

4.after upload remove jumper (boot0 vdd)

5.after start you will see fez (if you have problem with drivers you need to install drivers from the link provided by Gus above)


#50

@ valon.hoti@ gmail.com - Thanks for the information. Got my first blinky working on STM32F411RE. As I have the Clone Waveshare XNUCLEO F411RE Board, which already has additional USB and USB to UART connectors, getting DFU mode turned out to be even easier. After setting the boot0 to VDD jumper everything could be done via the additional USB connector.
Btw: Cerbuino Bee worked as well.


#51

@ RoSchmi - Nice to see that working


#52

@ RoSchmi - I like that xnucleo board. This is the first time I hear about it.


#53

FYI : https://www.mikroe.com/tinyclr-os-supports-quail/


#54

@ Bec a Fuel - exciting :slight_smile: by the way, I have buggy running TinyCLR already.