Main Site Documentation

FEZ Spider won't connect


#1

Hi everyone,

New here but would really like to get into this!
I’ve tried everything in this post and all to no avail: http://www.tinyclr.com/forum/21/4626/

Anyone have any other help?

Basically when I plug in the Spider I get a message saying Windows does not recognise the device.

Thanks in advanced!
Gavin


#2

Did you install the GHI installer before you plugged in your FEZ?

See the 3 installers here http://tinyclr.com/support/

And this http://tinyclr.com/forum/21/4268/

Welcome to the community.


#3

windows nt? windows 2000? windows xp? windows vista? windows 7?

you have to give us a little information to assist you.


#4

Hum, I am pretty sure I installed the drivers first.
Although I was very eager to set it up and may have plugged it in first!

If I did, what can I do to remedy this?

Also, yes sorry I should have given more information:

Windows 7 32-bit.
On Administrator account.
FEZ Spider Display tells me Version: 4.1.7.0.

I have tried many different USB sockets.
I have a 19v DC power going into it also.

If you need anything else, just ask :slight_smile:
Thanks!


#5

Ok the fix is easy, open “device manager” and direct windows to load these drivers

C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_NETMF_Interface


#6

I tired it just there and now my device manager looks like this:

(see attached)

So as you can see the GHI driver is loaded.
However sadly it still only shows as “Unknown Device” :frowning:

I tried in both Loader and Default mode.


#7
  1. reset your PC
  2. use reliable power source, read this for details http://wiki.tinyclr.com/index.php?title=Gadgeteer

#8

Restarted it just there.
Also I have a 19V DC power adapter feeding it as well as USB.

Still not working :frowning:

Thanks so far for the help, any other ideas? :slight_smile:


#9

Not sure if this will help or not, but I found that if I uninstall the Unknown Device driver, then click “Scan for Hardware changes” in the Device manager.

It quickly flickers like this: (see attached image)
Before returning to the same as the picture above.


#10

That device maybe something else not your FEZ. Disconnect your FEZ and show my what the device manager shows please.


#11

It definitely is.
It only pops up when it is in:
(see attached)


#12

This is very strange! Can you try a different PC please?


#13

I don’t have access to any other machines currently. I will tomorrow.

I just did a system restore to before I installed any of the things needed. Going to try again now.
Wish me luck! :smiley:

[italic]EDIT:[/italic] Nope, still not working :frowning: Could it be possible that the Spider Kit is malfunctioning?


#14

Try to update the fimrware using FEZ Spider updater.


#15

[quote]It quickly flickers like this: (see attached image)
Before returning to the same as the picture above.[/quote]
That bit - the flicker - is normal. It’s the step between when Windows knows “something” is there and when it knows what’s really there and to do with it…

After the initial firmware update, did you reset the switches on the Spider?


#16

I can’t. When I try to do so it gives me the error message:

Cannot connect to the device! Follow steps 1 to 2.

See above, I can’t even get by the initial firmware update.
Also, I have tried loading it in default and loader mode. Neither are picked up on the computer.

At this stage, I have done 2 system restores and even tried going through safe mode with driver signature verification disabled!
Nothing has worked…

I guess the problem must be something on the hardware side. I’ll try it with a different USB cable tomorrow. Can’t find a spare one here at the moment.

Anyone have any other ideas worth trying?

Thanks again guys! :slight_smile:


#17

Set your spider in loader mode (config switches) then plug it in USB. What do you see in device manager?


#18

If I try in loader mode you get the same thing.

I also tried it on another PC and got the same result. I did everything by the book.

Guess it must be the board. I followed the tutorial EXACTLY as stated. Oh well, I presume GHI has a returns policy.

Thanks anyway!


#19

This is not even possible as the loader doesn’t even use the “.NET debug” drivers!

Windows should load totally different drivers and the device will end up showing a new COM port on device manager.


#20

That’s odd.
I recorded a video of me with it in loader mode and showing the error.

Could you check it out just to make sure it is all okay?

I’ll post it in about 30 mins when I get home. (need the adapter for my phone - btw quality is good don’t worry :P)

Thanks