FEZ Spider Failure Loop

I have been using the FEZ Spider successully for months. Now when I plug in the USB adapter it boots fine, then after about 10 seconds it goes intio a loop on the T35 Display showing the normal GHI initialization screen, then the screen flashes, and the initiatlization screen, shows, etc. A continuious loop. I have tried restarting it multiple times. Can anyone give me any suggestions as to what might be the problem? Your help is appreciated.
Thank You,

is it getting HOT? touch the NXP chip with the back of your finger…?
i would also re flash the firmware just to make sure nothing is corrupt…

and try using a Power Adapter and see if the rebooting persists, just to rule out Power issues.

good luck…

Sounds like too little power. Use a DP module with external power. Do you have other modules attached? Try disconnecting them and see if you get different results.

While USB specifications say ports should provide 500mA, we rarely see a port that can actually provide 500mA. We always recommend the use of powered hubs or a power pack instead of relying on the USB power. Use a powered hub from a known brand, not a cheap hub. If your device has the option of using a power pack (for example the USB Client DP Module) then you can use a power pack instead. 9V 1A is typically recommended but check the bottom of the circuit board for printed voltage range. All power connectors on GHI products are 2.1mm with positive on the inside and negative on the outer ring.

Not using a powered hub or power pack can cause:
[ul]Unexplained behavior
Device does not function
Device functions intermittently
Device functions but network fails
Device functions but SD card fails
Device functions but firmware update fails[/ul]
(Generated by QuickReply)

I have a FEZ Spider with the USB Client DP module with both the USB and external power adapter. Would a 12V DC Power Adapter Supply 2.1mm 1A, CCTV work. Here is a link on Amazon for one http://www.amazon.com/Power-Adapter-Supply-2-1mm-CCTV/dp/B00452YFZU/ref=pd_sbs_op_3.

It looks too small for 1A but 1A is enough.

I just got back to my desk. I unplugged some of the devices (Wifi and the SD card) as you suggested. The sysem now boots and appears to be working correctly Thus, it is pointing toward the power source. So I will order a external power adapter. For now, keeping my fingers crossed, and am assuming this to be the problem. Thank you all for your input and suggestions.

or you could use the apple power supplies the USB one for IPhone(5V 1A) or IPad (5v 2A) these work best i think… and you can even use them with your SP power module.

I went to Radio Shack and purchased a 12VDC, 2.5A power adapter for my FEX Spider USB DP. Unfortunately, the problem continues. I have noticed that when I unplug the Wifi RS21 and SD Card reader the problem stops, with or without the power adapter. Is there any chance the Spider is not getting power from the adapter? When I unplug just the USB, the Spider powers down even though the power adapter is plugged in. Is there any way to know if the adapter is working?
Thanks, Bob

The problem isn’t the power source. The problem is that the DP module can only supply a maximum of 800mA. You’ll have to find a different way to power some of your devices or wait until Gus makes us a better power module. :frowning:

Does the LED on DP module turn off at all?

Okay I unplugged just the Wifi module and everything is fine. Connecting ONLY the Wifi module and the T-35 Display, not a big load, that as soon as the Wifi onboard green light comes on the T-35 display shows the Spider having to continously reboot. This configuration worked fine for about a month, and now it doesnt. Is there any chance the problem is the Wifi module itself?

You can update posts, no need to delete if you want. See my previous reply please.

@ Gus -
The USB DP led light is always red, the FEZ Spider mainboard led is always red (no flicker), and the Wifi led turns green. I still dont know how I can tell if the power adapter is working.

If led on DP module is not blinking then DP module is not being overloaded. The problem is in power source.

Try it with no USB cable. Does it reset?

@ Gus -
The USB Client DP module has both the USB and Power Adapter plugged into it. When I pull out the USB cable everything powers down. I assumed the Power Cable would keep everything powered on?

Looks like your power pack is dead.

Are you sure your power supply has a positive center? Check it with a meter.

@ Gus -
I found a power adapter that came with my netduino. I tried the netduion power adapter with the USB Client DP. Seemed to work fine. I pulled out the USB and the Spider maintained power. I then plugged in the Wifi module and powered it up using just the power adapter. The same problem occured e.g. the spider kept rebooting.

Any chance the problem might lie with the Wifi module? This whole configuration worked fine for over a month, it just started today.