FEZ Spider Deployment Issue


When trying to Deploy my Code to the Fez Spider to take a reading, display reading, save said readings to sdCard and email them i get a issue saying “An error has occurred. Please Check hardware”. I have everything updated, boards firmware is up to date , loaders up to date. I tried changing out the different parts and same issue. Im working with Visual Studio 2013 Community, with Microsoft .net Micro Framework 4.3 (QFE2), Microsoft .net Gadgeteer Core and GHI Electronics NETMF SDK 2015 R1 Pre Release 3.

Is there any solutions?
I have also Pinged it and get “Pinging … TinyBoot”

I deployed similar codes to a previous FEZ spider board that worked. But unfortunately that board got the BSoD.

When you ping you should see tinyclr. FEZ config will take care of this.

You can check the troubleshooting guide for details if you like.

@ Gus - Hello and thanks, I got it to say Pinging… TinyCLR , But im still get “An error has occurred: please check your hardware.” any idea why i am i getting this error

@ RDGallow -

Right click on the project name which is under solution project, Property -> .Net Micro Framework (on the left side), make sure transport is USB and Device is EMX_xxxx. If they are, refresh them (click on transport box and select USB again).

1 Like

@ Dat - thanks , i did that ,but still same error keep coming up

@ RDGallow -

Reset the board, close VS, reopen VS again.

1 Like

@ Dat - Still the same error

@ RDGallow -
Re-flashing your board is the best way now.
From FezConfig -> Advanced -> Loader -> EMX, follow those steps.

After that, friendly name can be changed to EXM_Gadgeteer, so remember to refresh the name in transport box.
And try some different USB port.

@ Dat - Thanks, Did all of that again and still getting same error

@ RDGallow -

Disconnect the board, power off completely,

Reconnect again, ping it. Tell us what you get, TinyBooter or TinyCLR? please!

@ Dat - Sometimes when I ping it, I get tinyCLR and sometimes I get tinybooter but this time it’s saying tinybooter after it gave us tinyCLR

Not sometime, when reset the board, if ping it, you get TinyBooter. After 20-30 seconds, ping it, you will get TinyClr. I think so.
So your problem is there. When you deployed the application, the board is in TinyBooter instead of TinyCLR.
Disconnect power again, reconnect them, ping it. if that is in TinyBooter, use MFDeploy -> Debug -> Plugin -> Reboot CLR.
Or use FEZ Config -> Advance -> Reboot TinyCLR.

Make sure that when ping, you always get TinyCLR all time after reset the board before deploying an application.

Hi everyone. Just keeping an eye on this discussion. rdGallow and I are on the same team. We really need to get this working asap.

@ Dat - After Doing the FEZ config> Advance > Reboot TinyCLR. and i ping it, its still saying pinging… tinyBooter

The firmware is corrupted somehow.
Use FEZ Config, click on Update firmware and follow those steps.

When updating, remove all modules.

Sorry because I am asking you to do some basic steps that you may have done already, but the only way to deploy an application to device is, device must be in TinyCLR mode.

Try a simple application

static void main()
Debug.Print("Hello world");

@ Dat - its OK, i am new to the GHI products. the device isn’t connecting to the PC anymore, Ive tried various ports , and various PC and still still in fez Config its saying Status: No device.

@ andre.m - via usb client EDP that came in the FEZ Spider Starter Kit

@ RDGallow - give us a call and ask for me if you like. We do not do phone support normally but I am very curious myself!

The phone number is on the contact us page.

Ok Gus. We finally moved it to my computer (Dell Latitude, Core i5 with 4GB and Win7 Ent.)

After connecting the Spider and resetting it a couple of times, we eventually get this:

The “GHI NETMF Interface” comes up as a USB Device and not the “EMX” we were expecting to see.

What should we do next?