FEZ Raptor not recognized via USB

Hi all,

I have a Raptor board and i use a usb client dp module https://www.ghielectronics.com/catalog/product/280 but it does not get recognized via USB so i cant deploy anything. The power leds are turning red on both usb module and the board. Also i used different usb cables that work on my cobra II board but also no luck with that. It does not seem like the board is broken what could be the problem does anyone have any pointers

What operating system?

Are you running in a VM?

Is the latest SDKs installed on your PC and board?

Does anything show up in the Device Manager when you plug in the board?

os is windows 8.1 64bit

no vm

latest sdk are installed on the pc and the board i have no idea just got it today and i can’t see what is installed

Nothing pups up in device manager

the first check is that you have connected the modules up correctly. Make sure the cables are seated correctly in the module and on the raptor, and on the raptor the D socket is socket 8 so make sure you’ve plugged it in the correct spot. Make sure you have audio turned on so you can hear the PC device connect/disconnect noise, to confirm the PC is seeing something, anything…
Edit: and welcome ! We’ll help you sort this out :wink:

@ WimEling - Try updating the tinybooter and clr firmware. See g400 manual for instructions.

which power module are you using?

1 Like

Try disconnecting all other USB devices that are non-essential.

Check the hidden devices in device manager

Device Manager -> View -> Show hidden devices

maybe there was a problem when with the driver

Hi all,

thanks for your reactions, i have tried to only use raptor as usb and nothing happens also nothing pups up in the device manager also no sound of that someting is added to usb.

In the device manager i only see G120 as invisible hardware where the universal serial bus devices are no g400

So you have a G120 based board and it works fine ? That’s a good sign from a software / driver / SDK perspective. Double check it please, make sure you have the connect/disconnect sounds when you connect it up.

Now, back to other checks.

First, since your G120 is working, if you can use the same red power module (EDP, SP, DP etc) that would help - and confirm what socket you have it connected to the Raptor. Use the same USB cable too, since we proved that it worked. Does your red board have an LED, and if so did it come on ? If you don’t get a connect/disconnect sound, there’s something fundamental at that point about power and/or USB that we need to track down, and you should start looking for bent pins in the socket you’re using or such stuff.

Tell us what power modules you have too, as it might be worth trying other power options to eliminate if it’s a USB or a power problem

Hi Brett,

The FEZ Cobra II has no D socket so i cannot connect the the usb dp client what have is now is see a blue led burning on the raptor board still not recognition i cannot find what the blue led means

ok, so I really need more info from you to help.

So we’ve established your G120 is a Cobra2. Thanks. Did you confirm that it makes the usual connect/disconnect noise when you connect it to the PC??

What power module/s do you have? You say you have a DP, but do you have anything else as well?

The blue LED. Is that the one marked “LED” on the mainboard ? Does the one marked “PWR” light up (it’s red) ?

For the DP module. Do you have a power supply (wall wart) that you can use to power it from the barrel jack ? If so, please do a stand-alone test, not connecting a USB cable, to see if the PWR LED lights up as is expected.

Did you check the pins in the Gadgeteer socket ?

Can you confirm what socket you have the DP module connected to ?

Can you change the Gadgeteer cable between your DP module and your Raptor ? Does it make a difference ?

Can you change the USB cable you are using? Does that make a difference ?

I’m trying to give you a good set of checks; if you can reply to them individually it will make sure we’re all clear on the situation and help diagnosis.

Hi Brett,

I will try to be as clear as i can here :

  • There is a G120 Cobra 2 Wifi that works fine and makes the noise when you plug in the usb.

  • This is the power module and this is it: https://www.ghielectronics.com/catalog/product/280
    This is the only one i have since the cobra board does not need and usb module

  • Yes the blue one is marked LED this on came on when i was tinkering withe LDR1 and LDR0 buttons it hasent come on since. The Red one is always burning it is the PWR one (Aslo on the usb moduel it is burning always)

  • I have done a test with a wall power one like you asked (12v 0.5A) and it works just like with Usb one red light burning on the usb module and the PWR led burning red on the board

  • Pins on both sides are not bend look ok

  • The socket i use for the usb module is the D socket nr 8 on the board

  • I have tried several different gadgeteer cables i know that work and no different

  • I have one extra usb cable that i know that works on my cobra but does not work with the board

This is what i have right now i read somewhere i have to update the firmware and tinybooter but that is not possible with no working connection to the board. I have allready send a mail to the firm that i got the board from i think i will want a refund this is not working.


I think you are right to get that board replaced, because your board is obviously working as the power is applied to the device and it works, it is just the USB function that is faulty. The red PWR LED is the telling factor - it is lit, means USB power (or external power) is being applied, but the device doesn’t work as expected.

@ Brett - I am not sure about this one, but if I for example enable the Kinect 1.8 drivers on my machine, no connection is possible anymore to any of the boards. It just stops working. Maybe try to remove all other USB devices and try again?

The Cobra works, the Raptor doesn’t. That’s unlikely to be a driver issue IMO. The last test for me was the fact that the device’s power works, it is purely the USB functionality that doesn’t.


@ Brett - Indeed, good argument. That could really indicate an error on the board. Maybe some soldering issue.

@ WimEling - Can you try to update the loader on the board? Section 5.1 in https://www.ghielectronics.com/downloads/man/G400_User_Manual.pdf will walk you through the update. When it says to ground pin PA11, that is pin 8 on socket 3 on the FEZ Raptor (which is based on the G400 module). Once you ground the pin, you should see a COM port appear in the device manager. If one does not, then I would try to do these same steps on a second computer. If the same issue happens there, then it looks like the board is defective and we can issue an RMA.

hi john,

it seems something went wrong with the update i get this error in the logfile

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.12 on : windows
current connection is \USBserial\COM3, \USBserial\COM3 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM3
-I- argv 1 : at91sam9g15-ek
-I- argv 2 : Loader.tcl
-I- Connection : \USBserial\COM3 (target(comType) = 0)
-I- Board : at91sam9g15-ek
-I- Traces Level : 4
-I- target(handle) : 57049976
Read device Chip ID at 0xfffff240 — get 0x819a05a1
-I- Found processor : at91sam9g15 (Chip ID : 0x819a05a1)
sourcing device file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/devices/at91sam9g15.tcl
sourcing board description file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/at91sam9g15-ek/at91sam9g15-ek.tcl
-I- Loading applet applet-lowlevelinit-sam9g15.bin at address 0x300000
-I- Memory Size : 0x0 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- Loading applet applet-extram-sam9g15.bin at address 0x300000
-E- Error during external RAM initialization.
-E- External RAM access is required to run applets.
-E- Connection abort

What is wrong here ?

that update failed. You’ll have to do it again until it works - is COM3 the correct port for the “GPS Camera Detect” device that appears ?

hi brett,

yes it is the only com device and it is the one that pops up when i put in the raptor.

I have tried to do the update with 2 different computers but it does not work same error with both is it a problem with the hardware ?