Main Site Documentation

FEZ Domino hasn't yet been FreakingEasy to me


#1

Dear all,
I very new to FEZ domino.
I going over the Beginners Guide to C# and .NET Micro Framework.
An i am stuck. I have tested the devide to give debug.print to the console but then i added the reference FEZDomino_GHIElectroncs.NETMF.FEZ and then i get the following error:
An error has occured: please check your device.
Does any one knows the problem. Can anyone help me please?
This should have been Freaking Easy, right?
Regards


#2

Did you update your Domino with the latest firmware? If yes try unplugging the usb cable, then plug it back in.


#3

Hi Kerem,

Sorry to hear you haven’t had things go your way.

A few things we’ll need to hear about your setup if we may.

You did install the VS2010 C# Express package on your PC first, didn’t you?
Followed by the netmf 4.1 SDK from Microsoft next?
Followed by the GHI SDK after that?
… (yep the order is important!)

and then did you update the firmware on your device ? That is a very VERY important step, the firmware and the SDK on your PC have to be in alignment.

They’re the first things you should confirm are OK. Use MFDeploy to check you can ping the TinyCLR, and check that the Device Capabilities matches your release notes version from your GHI SDK install directory. Check out the Fez on Fire videos too for some more pointers


#4

My friend,

This tutorial document has a step-by-step to get you started with FEZ:
http://www.tinyclr.com/downloads/FEZ_Tutorial.pdf Please follow it and tell us at what step are you stuck. 8)


#5

Hello,
Thank you very much for your help.
Yes i did the all the steps as you mentioned.
Updated the firmware and everything seams OK.
But i have the same error still…


#6

I am stuck at page 36 in the tutorial
Thank you for your concern…


#7

Are you sure it is page 36 “Firmware update”?

This is not the eBook. it is another document. Please take a look at the link


#8

I am looking at this book : Beginners guide to C# and .NET Micro Framework
on page 36/173 there is this topic: 9.1. Digital Outputs


#9

Hey Kerem

Dont fret, let us see how we can get you started. Can you do the following :

1.Can you check the properties of your project and ensure the transport is USB and that USBizi is selected/visible on the Device drop down.

2.If the above does not work do paste a screen shot of Visual Studio with you Profram.cs open


#10

thank you very much Rajesh,
here are the printscreents


#11

printscreen 1


#12

printscreen 2


#13

Maybe a stupid question, but have you unplugged the FEZ from USB then plugged it in again?


#14

That sounds possible, I don not see anything else that is obvious.


#15

I will only suggest here… but I can’t see the whole line of code, nor have I looked at that page but…

Would adding the LED lite driver help this example?

Or why is the

 bool ledState = false;

line there. Can you call/set the led state prior to declaring it?

I would suggest downloading the LED light driver and sample code and try that?

I realize that it says it’s a hardware issue, but if that example doesn’t work, maybe it is a hardware/firmware issue.

http://www.fezzer.com/project/35/led/

Mike in MN


#16

Kerem

This error occurs when VS is not able to communicate with the FEZ (see screen shot)

1.Save your solution.
2.Unplug the Fez
3.Restart windows
4.Plug in the Fez
5.Open VS 2010
6.Start a new project using the FEZ Domino Application template
7.Edit project properties and select USB/USBizi
8.Run

HTH.

-Rajesh


#17

Seems like you upgraded the firmware. Did you get the latest SDK to match?

This caused me issues a few times. I had a reference to older files.

If you select (you may need to a right click and “properies”) the FEZ reference and check the properties. The last entry in that list should be:


#18

here’s a set of steps that will show where this issue might come from.

First, start with Visual Studio not running, and no Fez connected to your PC.
Start MFDeploy.
When it opens, select USB from the drop down. in the drop down next to that, NOTHING should appear - this means the PC can’t see the Fez (which is expected since it’s not connected).
Then, with the MFDeploy window open, connect your Fez’s USB cable to the PC. At this point, you should get the standard “device added” sound and the drop down next to the USB should show USBizi_USBizi. Your Domino should also have it’s red PWR_LED lit.
Click Ping. You should get “Pinging… TinyCLR” as the response.

At this point we know your PC and Fez are communicating; if they aren’t, then we need to delve into drivers, USB ports and hubs.

Now, open Visual Studio.
At the start screen, open a NEW PROJECT.
At the project type Wizard, select a Fez Domino app, and click OK.
Hit F5. The app should build and then the emulator pop up, and shortly after:

An unhandled exception of type 'System.InvalidOperationException' occurred in FEZDomino_GHIElectronics.NETMF.FEZ.dll

Additional information: FEZ Domino not detected!

(again, this is expected and OK). Click BREAK, then Shift-F5 to stop debugging.
Next, open the project’s properties and set the .Net Micro framework deployment method to USB, and since the Domino is connected you should see the device USBizi_USBizi listed.
Hit F5 again to build and deploy. This time, things should work (we all have our fingers crossed for you !)

This app will just flash the LED, so you can see it’s working. And this is a good way to step through the dependencies. If there’s an error somewhere along the line let us know!

"


#19

Coming in to this a bit late, did we establish that his drivers are installed and correctly working?


#20

Dear Brett,
Thank you very much for your kind help…
Unfortunately nothing has changed. I still get the same error.
Although, i have some strange behavior.
When the deploy is on emulator i get the following error…
error: assembly file "does not exist! load failed.
Could this provide us some clue?
Best Regards