Main Site Documentation

ENC28 Ethernet for Hydra


#1

I was so excited to see the ENC28 finally show up at my doorstep today only to have my heart crushed when I discover there are no drivers yet… I don’t see anything on CodePlex either. How soon till something will be released that I can test?


#2

dang, dude, are you one of the sensitive types? It’s called the bleeding edge for a reason. :slight_smile:


#3

@ ianlee74

Hydra is capable of Ethernet but not dynamically as of yet. You can recompile the firmware that is on Codeplex by modifying the project file of the TinyCLR. In the TinyCLR project file, you need to uncomment the socket_pal_lwip in lieu of the socket_pal_Stub. Once recompiled, the Ethernet module works on socket 3. Without it on socket 3, the board will get stuck waiting for an interrupt that will never respond. We are working on the official release of the dynamic Ethernet.


  <ItemGroup>
    <DriverLibs Include="sockets_pal_stubs.$(LIB_EXT)" />
    <RequiredProjects Include="$(SPOCLIENT)\DeviceCode\PAL\COM\Sockets\stubs\dotNetMF.proj" />
  </ItemGroup>
  <--<ItemGroup>
    <DriverLibs Include="sockets_pal_lwip.$(LIB_EXT)" />
    <RequiredProjects Include="$(SPOCLIENT)\DeviceCode\PAL\COM\Sockets_lwip\dotNetMF.proj" />
  </ItemGroup>-->


#4

Well… It was the very last of the modules to finally get here from China. I’d noticed that most of the other drivers were in the last SDK version but didn’t notice that the ENC28 was missing until last night. I have a little project I’ve been sitting on a long time waiting to be able to connect my Hydra to the net. I guess I’ll hurry up and wait a little longer :smiley:


#5

Thanks, Aron. I’ll give it a try over the weekend. This will be my first attempt at compiling TinyCLR and deploying it w/o the installer. What’s the best way to go about putting the updated code on the Hydra? Can I only compile TinyCLR.proj and deploy it or will I need to also compile other supporting projects?


#6

It depends on what compiler that you are using. We are using the RVDS compiler to give a minor speed boost to the official released firmware. If you use any other compiler you will also need to modify the scatterfile to be set for the appropriate memory locations. I believe some on the forum have already modified the GCC scatterfile. With the appropriate scatterfile, all you should need to do is change the before mentioned project file changes. Once compiled, you should be able to redeploy the firmware as described in the wiki.


#7

I only have the VS2010 compiler. How long do you think before an official release?


#8

What is the status of the ENC28 driver?
I also received my hydra with ENC28 today, but there is no ENC28 module available in VS2010?

Can the steps to build the source futher be explained. I don’t understand which project file to rebuild and which tools to use.


#9

Please check back tomorrow.


#10

New Hydra release tomorrow??!! fingers crossed


#11

Is there a status page where we can find the progress of the new releases?
So we don’t always have to ask: Is it there yet? :wink:


#12

http://www.tinyclr.com/forum/12/5968/


#13

Does somebody else played with new firmware for Hydra to get the ENC28 to work?
I’m having trouble to set up a very simple socketserver on the Hydra with a test Console app on my pc.
When I run it in emulator mode the program works, but when I deploy it to the Hydra, nothing happens. I cannot send or receive data. I also tried the sample socket client and server from NETMF sdk, but these don’t work either. Only if I put my listener to port 80 I can connect from my windows console app, but the socket.Accept() doesn’t return.

When I looked at the specs in GHI catalog I was happely surprised that there was the Hydra opensource with rich .NETMF open-source software and hardware with full TCP/IP stack. And that ethernet support is available through ENC28 module. But after reading these forums, it looks like Hydra is to unstable to built products with and that you better use the Spider board. (which is not open source)

I used to worked with Pic32 / RTOS / C, but because I’m a software developer in MS technology, I wanted to try the NETMF stack. I hope I don’t regret my choice…


#14

Did you load the Ethernet firmware version? Second, are you able to ICMP ping hydra?


#15

Yes I loaded the Ethernet Firmware and I can ping the Hydra:


Pinging 192.168.0.101 with 32 bytes of data:
Reply from 192.168.0.142: Destination host unreachable.
Reply from 192.168.0.142: Destination host unreachable.
Reply from 192.168.0.142: Destination host unreachable.
Reply from 192.168.0.142: Destination host unreachable.

Ping statistics for 192.168.0.101:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),


#16

So ping didn’t work and nothing else would. Check your ip address for example. Maybe even trace the network.


#17

Yes, as Gus says, that ping did NOT work. You got Destination Host Unreachable, meaning your network didnt think a device with that IP address was on the network. I think you need to plug in to a laptop (with an auto MDX port and fixed IP address) and capture network traffic to/from the hydra.


#18

I’ve used MFDEPLOY to setup a fixed ip
192.168.0.180
255.255.255.0
0.0.0.0

I setup my pc
192.168.0.181
255.255.255.0
0.0.0.0

I connected them directly with a cross cable.
THen ping also doesn’t work.
Can I have a faulty ENC28?


#19

Before the test I also redeployed the network firmware with the latest update tool for Hydra and used the SDCard with the boot.bin to clear everything.
I also didn’t deploy any program to it. to be sure nothing else can interfere with it.

I also tried my other laptop with the same result --> no ping


#20

Do LEDs come on on the module? Does windows detect the connection?