Main Site Documentation

Cerberus Board not recognized


#1

Hi, I have just tried to upgrade all my stuff to the MF 4.2 and I cannot seem to get my PC to recognize my cerberus board. I did a complete erase and install of the boot loader using STDFU tester, and everythign said “success” but when I reboot or reset the board it does not show up in the devices tab. I have tried a reboot, and tried uninstalling and reinstalling the USB drivers and no change. The only way it is ever recognized is when I jumper the boot pins. I am at a loss…

Thanks
Daryn


#2

Windows8?
64bit?
USB3?

Tried to use it on a window7 machine?

I think there is a similar report and trying to narrow it down.

Welcome to the community.


#3

Thanks Gus, the machine is 64 bit windows 7, not USB3. Before the upgrade I was able to program my Hydra without problem. If I plug in my Hydra it shows up in devices, but the Cerberus doesn’t.


#4

Not sure then. I am assuming you tried to reload the firmware?


#5

Yes, I tried a few times, I can get as far as erase and reload tinyboot, after that nothing.


#6

Do you have a copy of old SDK? Maybe try the old firmware just in case?


#7

I can’t find an older dfu file to load to the board. I tried going back to the drivers from the 4.1 sdk but no luck…


#8

We will contact you directly with some tests if you do not mind. Hopefully we can get this figured out.


#9

Thanks Gus


#10

Try using a Powered USB Hub and please make sure you feed it with a really good 5V source with High Amp…
I’ve learned that even using a USB hub with cheap power supply can give you grief…

here is the Power Adapter I’m using with my USB Hub, I haven’t had an issue ever since… while before using that I was constantly having issues with deploy and all kinds of weird behavior…

cheers.

if my calculations are right I think the Adapter below puts out 400 to 500 mA right?


#11

Thanks Jay Jay, I tried to use the powered USB hub (the USB clinet DP module) and it didn’r work either, my power supply is 12V - 2A…


#12

I don’t think you can power a USB Hub with a 12V Power adapter, are you sure ? to my understanding the USB Hub requires 5V only.

i’m talking about powering the USB Hub while plugged into the USB Port and not by using the Standard power jack of the DP module.


#13

@ Jay Jay, you can power a hub with an appropriate supply. A proper powered hub has internal power regulation which means you’d typically need 6.5v minimum to guarantee stable 5v out. Appropriate means whatever is within tolerance for that particular hub; I’ve seen one (admittedly massive, 10 ports or something) that came with a 15v 1a supply.


#14

@ darynk

Make sure when you update the board you follow the erase step. The board must be erased prior to the Tinybooter being updated. To perform the erase step press the “Create from Map” button then select the Erase radio button then press the “Go” button. After this follow the remaining steps as before. The Erase step is easy to overlook. The erase step tends to be the most overlooked step users face when updating the Cerb-Family of boards.


#15

@ Aron, I did do the erase step, it reported success.


#16

I can send you an older DFU file to see if that file will work. What email address would you like me to send it to?


#17

thekielys@ embarqmail.com

Thanks Aron


#18

I sent you the file. Try it out and see if it will work.


#19

I got the DFU file and here are the exact steps I have taken:

  1. Boot with the boot jumper in place
  2. Start the STDFU Tester, it shows STM Device in DFU Mode
  3. Remove Jumper
  4. Select the Protocol tab
  5. Hit Create From Map
  6. Select Erase
  7. Hit Go
    8 ) Once progress finished had Success in the message box
  8. Hit Load DFU file and selected the file you just sent
  9. Selected download
  10. Hit Go
  11. Once progress finished had Success in the message box
  12. Closed STDFU tester
  13. Hit Reset on the Cerberus – nothing showed up
  14. Unplugged the USB and plugged it back in – Nothing showed up

So, no luck in getting this thing to boot up properly. I am getting the red LED on the board showing it is getting power.


#20

@ darynk

Do you have your windows update to search for drivers? Another person on the forum was having a similar problem with Hydra’s on-chip program. Here is a link to the forum post that may be of some use: http://www.tinyclr.com/forum/topic?id=10466&page=5

His reply is on page 5 but the main question is a few post back from the reply.

See if this will work for you.