Cannot update FEZ Spider Mainboard - Help!


I’m having trouble updating the FEZ Spider Mainboard and keep getting the error: “the USB driver may not have installed correctly. Re-installing the USB driver may solve the problem”

I’ve re-installed absolutely everything, including the drivers and still get this error. Visual Studio Express also doesn’t “see” the Spider.

Furthermore, I’ve also tried using an external power and not just the USB cable.

Any ideas?

I’m running Windows XP (32bit) and installed the latest versions of all the required software.

Welcome to the forum!

Did you put Spider switches to correct position?

Thank you.

Yes I did: 1,2&3 ON and 4 Off

What is appearing in the Device Manager?

The only thing I can see related to the Spider is: GHI Boot Loader Interface (COM8)

This is correct.

When you use the updater, at what step does the problem occur?

When the error message appears, what does the Device Manager say? You might have to manually add the USB driver after the first step completes.

Thanks Mike: The error occurs during the “reboot” phase (after erasing and writing). No change occurs to the device manager even though the updater claims to “disconnect” the COM port.

Thanks Andre.Marchalek: I don’t get any errors in the device manager in either normal or loader mode. The GHI Boot Loader Interface is there during both modes.
It is a physical XP machine.

Exit the updater. Restore the dips to the normal position. Remove power from device. Wait 5 seconds, and plug it in. What happens, and what does the device manager say now?

What happens is that the GHI Boot Loader Interface (COM8) turns up again with the typical sound Window makes when you plug in a USB device.

I believe if the first phase of the updater (erase/write) worked, but then failed, and the switches are in the default position, the Boot loader interface should not be appearing.

Are you using a power hub? Try a different USB port. Reboot the PC.

I used a different USB port and rebooted - still the same problem.

Just using a standard USB 2.0 from the Dell laptop with a 12V power supply as well (I’ve tried both with and without the power supply)

I only have the boot loader interface showing up - with the switches in either the default or loader position.

Yes, November 29, 2012 for the GHI SDK and NetMF 4.2

Yes, correct.

You now need to go back into the uploader, or use the manual instructions, to complete the firmware deployment. Use the Wiki and the EMX instructions.

Having only the bootloader interface show up is good - it just means it has the bootloader on there and you can continue although may require more effort than usual

Thanks Brett

I can get as far as running TeraTerm (without any problems) and uploading TinyBooter. However I get this:[em]
File Transfer Finished Successfully
I understand that I shouldn’t be getting “BL” again. Any ideas?

No you shouldn’t get bl again.

Your file is corrupted or device has a problem.

Male sure to use terarerm from our downloads folder.

… and I would try reapplying the tinybooter too.

I like to add that this sometimes happens and a second try solves it

This step is also power critical. Use powered hub or add a power pack.