Cannot update FEZ Spider Mainboard - Help!

thanks Gus & Brett. I’ve re-installed everything, including the tinybooter and still no luck. I’m using a power pack as well. i’m out of ideas here.

If you still get BL on TeraTerm after applying TinyBooter, then your firmware file is corrupted. You will need to reinstall the SDK on your PC so that you get a non-corrupted version.

Using the power pack along the usb is not the same as using a powered usb hub, so please make sure you are using a powered usb hub and the usb plug only…

@ RbG -

while you are seeing BL in tera term, how about if you press ‘R’

Hello everyone,

Thursday 31 January 2013 I received from Mouser electronics my first Gadgeteer board: the FEZ Spider startup kit.
I have spent many hours trying to make it work, but no success. I have exactly the same problems @ RbG is having.

Never had these problems with my EMX or ChipworkX development boards.

Could it be that the mainboard or the red power module is just broken?

Hi PK, welcome to the forum.

Spider is actually an EMX module at heart - so if your EMX based device is currently operating correctly and you can’t get your Spider to work, either the switching of the MODE switches isn’t taking effect or there’s some other issue - perhaps a bent pin? Can you confirm what you see in Device Manager?

RbG and Pk

I do not want to point you off in the wrong direction so somebody out there YELL at me if I am wrong.
All I know is that it worked for me the last time I had a similar problem with my Spider.

I had the Booter installed but could not load the Firmware following the steps in the directions.

I was able to attach to my Spider with a ‘powered’ USB port and loaded the firmware using MFDeploy.

Attached are two images showing the files/location… Your file location path will be different except for the actual files
that need to be downloaded.

Brett to answer your questions and give you some extra information. Indeed, my EMX development boards works fine and in the Device Manager I see a ‘GHI NETMF Debug Interface’ under ‘Universal Serial Bus Controllers’ and I can run a MF Console Application on the EMX development board.

Now for the FEZ Spider:

When the pins are in loader mode:


then I see in the Device Manager a ‘GHI Boot Loader Interface (COM8)’ under ‘Ports (COM & LPT)’

When I run ‘C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\Firmware Update\FEZSpiderMainboardUpdater.exe’

I see in Step 1 the files it will be using for TinyBooter and Firmware files:

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\TinyBooter\TinyBooter.GHI

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Config.hex;
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Firmware.hex;
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\Firmware2.hex;

I guess these files are right ones.

Then in Step 2 I see how the switches need to be set (Loader mode). I guess I don’t have to check the ‘Update MAC Address’

Then I press the Update button

Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM8
No reponse from device

Then I see a message box ‘The USB driver may not have installed correctly.’
‘Re-installing the USB driver may solve this problem.’

In the Device Manager the 'GHI Boot Loader Interface (COM8) under Ports(COM & LPT)
is still there.

I guess I have to re-install the USB driver using:

GHI NETMF v4.2 and .NET Gadgeteer Package (11-29-2012)\Installation Files\GHI NETMF USB Drivers x64\GHI NETMF USB Drivers.msi’

I choose ‘repair GHI NETMF USB Drivers’.

Then the message box says the driver have been installed successfully.

Repeating the process with the FEZSpiderMainboardUpdater.exe still gives the same error message…

Setting the FEZ Spider in TinyBooter mode gives also shows the 'GHI Boot Loader Interface (COM8) under Ports(COM & LPT)

Setting the FEZ Spider in Default mode gives also shows the 'GHI Boot Loader Interface (COM8) under Ports(COM & LPT)

Following the manual procedure ‘Firmware Update EMX’ is only successfull for the step ‘TinyBooter Update through GHI Boot Loader’

However typing the ‘R’ in the Tera Term VT says Bad firmware

Could this be the reason it is not working?

But, I have sent via X-modem, using the 1K option:

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\EMX\Firmware\TinyBooter\TinyBooter.GHI

It said: File Transfer Finished Successfully

The step ‘EMX Firmware Update Through TinyBooter’ does not show the EMX_EMX Device when choosing USB.

I only see a GHI Boot Loader Interface(COM8), no matter what mode I choose
No bent pins
Tried a different module cable between red power module en FEZ Spider
Tried different USB cables (also one with extra assistant power)
Tried different USB ports on my laptop (Acer Aspire 8940)
Tried also 7V power to the red power module
I’m using Windows 7
Display T35 1.3 when connected showed no information, only a white screen
Tried all this on another laptop, no success


I never got that far, that MFDeploy showed me the EMX_EMX when I choose USB as the device. So ping was not working and also not the other steps.

I suppose my Acer Aspire has 8940 has a powered USB port.

If it says “bad firmware” then the firmware file is corrupted and you need to reinstall the SDK to get it “new” again. I hit this issue and I don’t think the GHI firmware updater programs checks this as a return code so they seem like it progresses but then the program flow gets out of sync with what the device is doing.

For me I just ran the individual MSI out of the “installation files” directory for the appropriate SDK (either the OSHW or the Premium) and that freshened up the firmware and I could then deploy it correctly manually.

Edit: and because you only see a GHI bootloader interface, it just means it doesn’t have a netmf firmware at all. So this reinforces the fact that the firmware file needs to be deployed correctly, but the only way to do that will be to get a new copy.

While USB specifications say ports should provide 500mA, we rarely see a port that can actually provide 500mA. We always recommend the use of powered hubs or a power pack instead of relying on the USB power. Use a powered hub from a known brand, not a cheap hub. If your device has the option of using a power pack (for example the USB Client DP Module) then you can use a power pack instead. 9V 1A is typically recommended but check the bottom of the circuit board for printed voltage range. All power connectors on GHI products are 2.1mm with positive on the inside and negative on the outer ring.

Not using a powered hub or power pack can cause:
[ul]Unexplained behavior
Device does not function
Device functions intermittently
Device functions but network fails
Device functions but SD card fails
Device functions but firmware update fails[/ul]
(Generated by QuickReply)

I am using the USB Client module (included with FEZ Spider startup kit) and I connected an adapter that provides output 12V 600mA (positive on the inside, negative on the outside). This is less than the 1A.

So I probably need to buy a 12V 1A power pack or a powered USB hub.

Any suggestions for a good brand regarding the powered USB hub?


I read this in the manual ‘If you did see the “BL” again after this process, it means that the update process failed. You might need to double check that the downloaded file is not corrupted.’

I checked this:

The EMX development board does not show the BL again, but the FEZ Spider does. Since I tried this on the same computer it means the files are not corrupted, since it works for the EMX development board.

It could be the power like Gus suggested, but that makes me wonder why the ChipworkX or EMX development boards never had these power issues.

Spider is an EMX board, so at it’s core the power usage will be “similar”. But adding displays and Gadgeteer additional pieces can all change that.

If you have applied your firmware to your EMX board from this same PC then yes I’d agree that the firmware seems to be consistent, but if you haven’t I’d still reapply the SDK to get the refreshed version.

Finally, I managed to get a working FEZ Spider mainboard.

How did I solve this problem?

Well, I just bought at Mouser Electronics a new FEZ Spider main board (EUR 94.83) and a new USB Client DP module (EUR 20.58)

The FEZ Spider main board is probably broken.

Oh, and I forgot to mention this: same laptop, same software and I didn’t bought a new power module or USB hub.

Also, the display is not showing the white screen anymore. It shows information just like the EMX development board (see photo).

Can I clarify? That’s the new Spider in that picture? And you’re using the same USB power module you were before? In that case, it’s definitely the Spider at play, but I’d try the tests again, making sure that there are no pins bent on the display or the USB connection.