About October 24th release with Ethernet and WiFi (RC3)

I am not sure where to post this so I will try here. I will do my best to keep my frustrations out of the text.

Gus posted “RTM release will be done ASAP so we would really appreciate any feedback you may have.
If you have problems with the firmware update process then please do not post here.
Keep this thread related to issues with the SDK itself, not firmware update”

So here is my feedback. I do not want to be negative but I thought it would be OK to post some of my experiences updating the Fez.Spider firmware.
Lets just say it was less than pleasent.

For general information I am using Windows 7 64bit on my PC.

Before updating my Spider was running OK on several different applications I was ‘playing’ with. I do admit that my PC and/or Spider have always been a ‘bit fussy’ about
USB issues when updating firmware or deploying applications.

As a suggestion… I sure wish that something was said about what to expect with regard to what should be ‘seen’ in the PC Device Manager. Such as there is no longer the USB Debug Interface (I forgot the actual wording) and you will ‘see’ a new serial port 'Pop up" and ‘Go Away’ during the firmware update.

I went through the setup and installed the new software using GHI NETMF v4.2 and .NET Gadgeteer Package (10-24-2012). Setup went through all the steps and installed what it needed to. Then onward to ‘flash’ the new firmware. Lets just say it erased the firmware and I was ‘Dead In The Water’ … No matter what I tried, I could not get beyond this step. I went through all the steps more than just several times and nothing beyond erasing… I also tried using the FEZSpiderMainboardUpdater.exe (found in C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK). No luck…

I then un-installed ALL of the previous GHI programs found in Control Panel Programs and Features and started over after rebooting my PC. Re-Install the new software and started over. No luck… Same thing, erase and then no further in the firmware flashing. I even tried using different USB ports to re-install everything. No Luck…

I finally got up-and-running after spending several hours getting nowhere. My main issue is I do not know what I did (if anything) that allowed it to finally flash the firmware. As a note I was always careful to make sure that I ‘reset’ the spider before trying to flash.

I ‘believe’ the main cause had something to do with the new serial port that installs when flashing? I have no idea… All I know is that it would be there and then disappear after the erase. I’m confused now, but I ‘think’ it went away and then restarted a second later wenn the firmware finall ‘flashed’. I do remember getting a windows dialog (Or I looked at the properties) and it said it was unable to start. I’m not sure now what I saw or thought I saw… Maybe it was all a dream?

Gus also pointed out:
One note on the drivers, if Windows did not detect the USB drivers automatically,
just point it to C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface

I had to do this several times. In my opinion, the firmware update dialogs should mention that when you ‘reset’ your board to wait a few seconds to see if the PC is in the process of loading a driver before continuing the flashing process.

I’ll post some screen captures just for info. Capture6 shows the serial port not starting up again to continue the flash process (I believe it should close and then restart?)

Have a GREAT day!

I think all you are describing us around one problem, windows ix not finding the driver automatically. Which we listed in the announcement as you mentioned. The updater doesn’t tell you about it because this shouldn’t be the case one we fix the driver automatic loading feature.

I just want to point out, that configuration switches need to be set to Default mode in order for Windows to install drivers successfully (once pointed out). You probably want to say it somewhere.

We will see what we can do to simplify the process.

welcome to the community.


Now, here’s another problem.

First I tried to flash the device according to the installer and got the Update failed screen.

Then I put the switches to default mode and installed drivers manually, successfully.

Now I want to update the firmware, for which I need to set the switches to Loader mode and reset the device (according to the installer), with which Windows has problems. It doesn’t use the already installed drivers (and fails to install them if I point them out). So, the device is not detected and not updatable.

What should I do?

Pointed windows to the loader drivers?

yes, as I said before, windows do not want to install drivers when switches set to Loader mode

EDIT: Ok I get it now, there are 2 types of drivers. From the users perspective, all this can get highly confusing. I know you’re trying and everything is still in development, keep up with the good work, just try making the whole package easy to use and I’m sure people will do some great stuff with Gadgeteer. Sorry if I came out too negative… :slight_smile: Cheers!

I had to state that I m not trying to point blame at anyone or anything. I love my spider… it’s great fun and you guys are always a great help!

“Now I want to update the firmware, for which I need to set the switches to Loader mode and reset the device (according to the installer), with which Windows has problems. It doesn’t use the already installed drivers (and fails to install them if I point them out). So, the device is not detected and not updatable.” Puts my post in a nut-shell.

As I remember, in the installer dialog it showed that it was closing the serial port right after erasing? The driver was loaded but can’t seem to start it again?

Just curious… Why is there a need to close the port if it is needed for the next step in the process? Sure wish I knew what changed when it finally worked so I could help murej.

@ willgeorge - So you are updated or still having problems?


Yes I am working now. I thought I said so but I’m old and forget things.

Thanks for asking…


I am new to this board and it’s my first posting. We are planning to integrate the EMX board to our new products.

We have a Problem after installing V4.2 from October, 24th. We are runing XP SP3 inside a VMware 8.0 client.
Everything runs ok before the update, but the installation from the new USB-Driver reports an error.
I’ve pointed manually to the GHI_NETMF_Interface - directory to select the driver.

The german message after the installation is “Ein Dienstinstallationsabschnitt dieser INF-Datei ist ungültig”.

The windows device manager shows “EMX” as USB-Controller but with “not installed driver”, Code 28 as info.

I’ve googled 2 days, reinstalled SP3, updated VMWare to 8.04 … now I’ve no more idea.

I hope, somebody of you can help me further
We need networking functions at our EMX board, so a “downdate” to previous versions would be not a really good solution.

Best regards

We are doing tests on windows 8 this week.


was your answer for me ? Don’t confuse WIN 8 with VMWare 8.
We are using XP with SP3 inside a Virtual Machine.
The VM is running onto a WIN7 computer.


@ Ralo - Welcome Ralo.

Is your image EN or DE?

Image ?
I’m using german windows, if this is your question.

Yes i meant VM image…
i have an x86 German VM which i can test - i will trying installing the 24th package and see what happens.

1 Like

@ justin: Thanks in advance for your efforts !

@ Ralo - Seems i havent used that image in awhile 55 windows updates :smiley: - will keep you posted

@ Justin, @ Gus,

at my XP-image I can’t find any WinUSB.sys file. Can you confirm that ?
I’ve learned, that this file is part of SP3. I have reinstalled SP3 days ago, but WINUSB is still missing.
May be this is the problem ???


@ Ralo - I think WinUSB is only windows 7 and 8…

From the Mountaineer page

Warning: WinUSB only comes preinstalled with Windows Vista, Windows 7, Windows 8. On the older Windows XP, it can be installed, but this is not trivial, has not been tested and is not supported.