Main Site Documentation

A non-beta gadgeteer SDK is up


#1

It i finally here, it was too much work but we finally made it happen.

Any volunteers to try this before we make an official announcement?
http://tinyclr.com/support/

Do not ask me what changed, see release notes please :slight_smile:
http://www.tinyclr.com/release-notes/

Yes hydra has SD drivers and file system now. This is the only beta feature…enjoy!

Edit: this was updated http://www.tinyclr.com/forum/12/5368


#2

Congratulations! Major milestone! I will try it tonight


#3

@ Gus,

Downloading as we speak…do I need to uninstall the previous version manually before install?

Thanks for all the hard work on this. :slight_smile:


#4

Downloading now. I hope it fixes my OledDisplay issue.

And to Mr. Duthie, you should present this at RockNUG in March.


#5

Woo hoo! I’ll be on it in a few hours.


#6

@ Jimmy

That would be March 14th? Looks open right now, so if you want to suggest the idea to Dean, I’m definitely open to bringing my gear up to RockNUG. Though that might mix people up since I typically present at the anniversary meeting every year. :slight_smile:


#7

@ Gus,

Downloaded and installed the package, and all seems to have gone well so far (haven’t tried any projects yet).

I was prompted to update the firmware on my Spider…do I also need to update the Hydra firmware for this release?


#8

@ Gus,

Successfully ran my Glide button/multicolor LED demo (the one I posted to http://code.tinyclr.com/project/411/glide-buttons-and-gadgeteer-demo/), using the existing references, then removed and re-added all the Gadgeteer/GHI/Glide references to make sure they were up to date.

Still works fine. Runs fine, and hits breakpoints, which is a good first test. :slight_smile:

I have to run out for a family obligation, but hopefully that feedback helps.


#9

Awesome, now all I have to do is wait for January 9th, its killing me. I have a box of modules sitting on my desk and all I’m waiting for is the Fez Spider Kit to get back in stock. Come on January 9th.


#10

Gus-

I am sure all of this is related to me never having done any microframwork stuf at all, but I still am having issues, although now they are different. My oled is acutally flasshing but when I try to run a simple display, I now get “Cannot find any entrypoint!”

I uninstalled all the GHI stuff before installing the new build and went through all five steps. There was no option to update Hydra Firmware. Perhaps i need to do that but I am finding it hard to find any information at all. It is very confusing hopping between the Wiki and the Forum.

-Dazed and Confused (Jimmy)


#11

Updated firmware on both my Cobra and Domino devices, ran all the projects i had and all worked just fine


#12

Updated: spider, mini, panda I&II, domino and rhino. Everything was smooth and easy.


#13

Jim, please start new thread with all details.


#14

And I thought I was going to bed early tonight…


#15

@ devhammer

[quote]do I also need to update the Hydra firmware for this release?
[/quote]
Yes. Without an update, The SD card will not work. It was included with latest firmware.


#16

Same manual process, right?


#17

Does the firmware must still be updated per http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra ?


#18

Yes, if you want to update the TinyBooter as well, otherwise all you would need to do is update by going into TinyBooter and update the firmware there with MFDeploy. TinyBooter should be updated as it contains the firmware version in the device capabilities and it is updated to recognize the friendly name of Gadgeteer.


#19

Updated Hydra all the way. Works great! Thanks.


#20

I just noticed a little issue in the package. We compiled all seed drivers into one installer which is in the package but the package is not installing it :wall:

I removed the package till we make this little fix. If you already have the package, you are fine. Just run the seed installer manually. It is inside “Installation Files” folder.

This will be fixed first thing in the morning.