Main Site Documentation

( You're not allowed to laugh ) A quick pointer


#1

I have a panda!! and am just trying to get the SD card up and running.

I downloaded the code from here
http://www.microframeworkprojects.com/index.php?title=USB_Client#Mass_Storage

But its for the domino. and the panda doesn’t support hosting when it tries to create the Persistant storage it whinges

[quote]Error 1 The type ‘GHIElectronics.NETMF.USBHost.USBH_Device’ is defined in an assembly that is not referenced. You must add a reference to assembly ‘GHIElectronics.NETMF.System, Version=4.1.3.0, Culture=neutral, PublicKeyToken=null’. C:\Documents and Settings\Ian\Local Settings\Application Data\Temporary Projects\FEZ Panda Application1\Program.cs 30 17 FEZ Panda Application1
[/quote]

Any help would be a boon

Cheers Ian


#2

Just add the reference.


#3

I did! I added them all as Gus recommends when this type of error is given.

I did notice however… every one else ONLY includes the USB_HOST references not the USB_CLIENT references…

Still won’t build though.

Cheers Ian


#4

I am using SD card with Panda - works fine. Here is the list of my references:


#5

It might have something todo with Microsoft.SPOT.IO. Its the only reference that you have thats not on my list.

Builds now…

Cheers Architect…

Ian


#6

If you’re still in help mode Architect!!

I’ve built the demo in the EBook but I can’t seem to make the panda into a mass storage device… it is still seen as a debug interface…

I’m sorry I’m appearing thick but USB is very very strange to me.

Cheers Ian


#7

Copy the example as is. It should throw an exception if you are still using USB debugging!
Connect MODE pin to GND, it will switch to serial debugging as described in ebook.


#8

Cheers Mike!! I have to shelve this until next Monday as I’m off for the weekend.
I suppose thats why the mode pin is on the SD connector!! I’ll only need telling once.

I’ll put a switch on there to enable or disable USB debugging.

Thanks anyway.

Cheers Ian


#9

As Mike said grounding MODE should work. Let us know how it goes. Have a nice weekend!


#10

Right!! Weekend was all right, got a bit drunk, but now I’m back at work.

I’ve now a switch on the mode input.

I’ve downloaded the code for Mass Storage again.

I’ve deployed to the panda.

If the switch is in USB debug mode all is well! However switching to serial debug and rebooting still does nothing. So its either the SD wiring or the SD card, I’m going to try an SD example that will allow me to debug so I can check my interface.

Cheers Ian

I have tried Chris’s SD card example off fezzer and it runs fine so the SD card is ok and so is my wiring… AARRGGHH!! I wonder why the Ebook example wont run?

Cheers Ian


#11

Remind me what is your setup and what example from the ebook you have issues with?


#12

I have deployed this to the Panda (Exactly, line for line )

using System;
using System.IO;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;

using GHIElectronics.NETMF.USBClient;
using GHIElectronics.NETMF.IO;
using GHIElectronics.NETMF.Hardware;

namespace USBClient_Example
{
    public class Program
    {
        public static void Main()
        {
            // Check debug interface
            if (Configuration.DebugInterface.GetCurrent() == Configuration.DebugInterface.Port.USB1)
                throw new InvalidOperationException("Current debug interface is USB. It must be changed to something else before proceeding. Refer to your platform user manual to change the debug interface.");

            // Start MS
            USBC_MassStorage ms = USBClientController.StandardDevices.StartMassStorage();

            // Assume SD card is connected
            PersistentStorage sd;
            try
            {
                sd = new PersistentStorage("SD");
            }
            catch
            {
                throw new Exception("SD card not detected");
            }
            ms.AttachLun(0, sd, " ", " ");


            // enable host access 
            ms.EnableLun(0);

            Thread.Sleep(Timeout.Infinite);
        }
    }
}

There is no " DING / DONG " from the PC when it runs, not even a notification

Cheers Ian


#13

And you grounded the mode pin right?


#14

Yep…

mode is next to the GnD pin on the SD connector at the rear of the Panda.
Must be that one as the LED is off when this is switched to GnD.
(Its the only one called MODE)

I’m going to try running it from a separate power supply, just in case!

Its Night time here and its at work so I’ll give it another go tomorrow.

Cheers Ian


#15

Ok, I will give it a try tonight.

Edit.
I have just tried it and it worked for me. Sometimes it takes few seconds before drive appears.


#16

Right… Done all I can think of.

Externally powered…
Nothing else connected…
Mode switch to serial debug…
SD card works with separate application…

My references…


#17

My connections…


#18

I must have the luck of the Irish!!! :o

A tiny spec of solder on the breadboard connected the MODE pin to the 3v3 rail so as soon as I tried serial mode, IC4 got a bit warm… well scorching actually…

Quick repair and Panda now boots to Mass Storage Mode…

Panda seems to be ok… I might replace the 3v3 reg ( unless its designed with current limiter? ) I’ll check the data sheet.

Cheers Architect for all your help. :-[


#19

No problem. I am glad you got it working!


#20

Power connector on the Panda shows 7-12V and I see your power supply saying 6V. Could it be related to your problems ?