Main Site Documentation

Yet another CLR_E_OUT_OF_RANGE error


#1

All my files are less than 64K the biggest class is 41k the whole .exe file after compile is 61k . Google do’s not help much, but one thread “http://www.dotnetsolutions.co.uk/blog/introducing-the-meta-data-processor” says that running the MetaDataProcessor in the command prompt using the same arguments that caused it to fail, will give further information to help solve the issue. So my question is what are the arguments that i need???.


#2

according to the blog post, you can:


#3

@ Jeff - If the command string appeared I would have already tried, it may well appear in v3.0 but it does not appear in v4.2. I did try using -1 or -l that appears in the link but they are not supported in v4.2


#4

Looks like I have this one solved! In my case It appears that I had too many static variables, I have changed the ones that fit a constant, and the error has gone away. I’m sort of sure that this was the issue as I now have memory issues, now I can debug. All in a days work i guess! At least I can now see where the problems are.

note: to self, can I now hit solved and get the points???


#5

No you can’t, but we can :wink:


#6

@ Architect - Where Do your superhuman skills end??? and Thankyou.


#7

All I am saying is that user can’t mark its own post as the answer. It has to be another user (Master and higher rank I think).