Main Site Documentation

XTEA in USBizi


#1

Hi,

I am having problems with the Key_TinyEncryptionAlgorithm class, where the result of an Encrypt operation is an array with all zeros (of the same length–16 bytes–as the array to encrypt). In order to do a sanity check I tried with the sample in the tutorial at http://wiki.tinyclr.com/index.php?title=Crypto_XTEA and had the same result even after replacing the funny nulls with an arrays as the initial vector.

I’m sure to be missing something, but right now I am stumped. Any help would be appreciated.

Thanks.


#2

So you did copy/paste the exact same code we have in the tutorial with no changes whatsoever and it didn’t work?!

What do you get on the output window when you run the example in tutorial?


#3

Correct. Verbatim.

Then I tried again, replacing the null values in the Encrypt and Decrypt function calls with an array of 8 bytes containing { 1,2,3,4,5,6,7,8 } just to make sure. Still no dice.

This is the result int the output window:

FEZ is so easy!

Thanks for the prompt reply.


#4

I just tried the code on the emulator and it worked fine. Can you try on the emulator instead of FEZ?


#5

Hmm. It does work in the emulator.


#6

We will test on our end and get back to you.


#7

You are right. It is not working on my board. Let us look into it.


#8

I have the same problem with my EMX module CLR 4.1.2821.0. It work in the emulator but not
when I run it in the EMX module.


#9

Have you find any solution yet for this problem?


#10

Still looking into it. There is more than one party involved in this issue so it may take a bit. You can use an older SDK which has XTEA working of XTEA is a must have for now.