Main Site Documentation

XMODEM/FEZPanel


#1

Hi, I am trying to ‘Read managed application’ from Domino using a terminal program. I am using Telnet as it has XMODEM crc support. I am able to ping the device with command B and read version command V but cannot get command G to work. It appears that Telnet is reading the device (148 packets read)when I start the XMODEM transfer but fails when writing the file. I tried GCCom with the same results. Tried TeraTerm as it is mentioned in the manual but does not support greater than 4 COM ports. Unfortunately the Domino shows up on COM17 when put into GHI bootloader mode. Also tried FEZPanel, but that app won’t find any COM ports at all, just gives error. I am using Windows 7 x64 so tried running terminal programs in XP mode, no results… Also tried using different baud rates but appears that Domino is auto-baud as it does not seem to matter what baud rate I use, at least for B and V commands. I am about out of ideas on how to proceed. Any help would be greatly appreciated.
Thanks.


#2

There are some 64 bit drivers in the download area. Are you using those?


#3

Hi, yes I am using the x64 drivers.


#4

For whatever the reason, the FEZPanel doesn’t work for me. I just get an exception. I think it has to do with that fact that I have one other locked COM port on my PC.


#5

Fez panel worked fine for me before in beta, but the version on the projects page does not work anymore and does indeed raise an exception… ???


#6

Would you mind debugging?


#7

I’m happy to help debug too !