Main Site Documentation

XBee problem


#1

Hi All,

I’m waiting for my quadcopter supplier to arrive and meanwhily try to create the remote controll / receiver working. I’m doing that using two XBee’s. The professional series should have extended range, so I got two XBee Pro S2.

I followed a nice tutorial from Ianlee (http://blog.ianlee.info/search/label/Omnicopter), but that failed. He is using the series 1 and perhaps there are more differences. I do use his c# code on the FEZ.

I also got 2x the XBee Explorer (http://www.sparkfun.com/products/9132) for the transmitter and receiver and 1x the Explorer USB to program the XBee’s with (http://www.sparkfun.com/products/8687).

I hooked up both XBee explorers to two different FEZ’s (Panda 2) and ran code to send / receive data. I can see the red transmit led blinking on the XBee Explorer. I thought that was good news, but it turns out this led also starts blinking without a mounted XBee.

No communication is possible, so I installed X-CTU. My Xbee’s are identified as XBP24-B. I can flash the Xbee with X-CTU with different function sets and read this page:

http://paparazzi.enac.fr/wiki/XBee_configuration

Indicating that I should flash one XBee with the ZIGBEE ROUTER AT and one with the ZIGBEE COORDINATOR AT. So I did that using the latest firmware, set the PAN ID to 1231 and the baud rate to 57600 as I read somewhere that this would be the maximum for dual communication.

Flashing is OK and I can still connect to the XBee’s using X-CTU… however, I still don’t get them to work.

Also tried one FEZ/XBee transmitting a HELO every second and the other XBEE on the USB explorer on the PC with X-CTU terminal, hoping for the HELO to appear. However, nothing.

I’ve allready read 100 pages on sites about this but can’t find anything new to try. Does anyone have any tips, hints, etc?


#2

Unfortunately, I don’t have any series 2 XBees to test with yet. I do remember reading that the S2’s have a yellow LED that lights when they are properly paired. Do you see it lit? Do you happen to have a second FTDI cable that you could try connecting both to your PC at the same time and see if they can talk using only XCTU? That would eliminate any possibilities of problems in your software.


#3

Hi ianlee74,

Thanks for helping me again :-). I don’t think the XBee has a yellow LED on it, or they managed to make it that small it’s impossible for me to tell.

I dont have a second USB board, but start to think that i’m forced to buy one.

Some people have difficulties when the XBee’s are to close to each other. Mine are side by side, so that could be a problem I intend to fix tonight.

I’d like to know if the XBee is actually sending something into the air. Now the board transmit light is blinking, but I’m not sure if it’s really sending any data. Don’t know how to test that unfortunatly, tried with a radio, hoping to get some noise after sending, but failed (did get a lot of noise from my DC engines though…).

Tnx again for the help!


#4

If you have a (cough) Arduino laying around somewhere, remove the chip and you have a nice FTDI board (just use wires to connect the XBee)


#5

Hi EriSan500,

Thanks for taking the time to help me out :-). “Unfortunatly” I don’t have a Arduino. If I did, changing them to FTDI boards would probably be the best purpose I could think of for them.

However, THEY NOW WORK :slight_smile:

I had to run home today and figured that while I was there I might check some steps as well. The distance did not make any difference. However, after i’ve set the “DH - Destination Address High” and “DL - Destination Address Low” to the unique serial number “SH - Serial Number High” and “SL - Serial Number Low” of the other modem it started working.

I don’t have a clue why because device high was set to 0 and device low to ffff and that should have accepted everything (at least, I thought it should).

But now it works great and I can continue with my remote control interface :slight_smile:

Thanks for the help!


#6

If you have the DL register set to 0xFFFF and DH set to 0x0000 than all you send will be a broadcast. The problem is that there is no ACK for broadcast messages. Therefor there is no retransmition. If you use unicast mode (as you did) the message will be delivered as soon as possible. Remember that if one of your XBee has End Device firmare it goes to sleep mode and might miss the broadcast.


#7

Tnx Gralin,

That could explain why it failed before (though I don’t get why it keeps failing, would expect at least one package ever to arrive).

I do have another issue now, seems like only one XBee is now the sender and the other one is in the receiver role. And I need bi directional data streams to work, so back to the configurations :-).

(want to be able to send battery status and signal strength back some day).


#8

Have you seen the wondefull wiki page created by Robert on XBee?
http://wiki.tinyclr.com/index.php?title=FEZ_Xbee


#9

Hi EriSan500,

I did, but unfortunatly there is no WIKI about the series 2 (or i’m missing that one). This tutorial is for the series 1, it has the XBEE 802.15.4 function set available. I now believe that is making XBee’s a lot easier to use.

The one I have does not contain the XBEE 802.15.4 and you have to setup routers and coordinators etc. Finally got that to work one way, but still trying to get the bi directional communication to work as well (hope I dont have to switch function sets).

Tnx for the tip though!