Main Site Documentation

Write Privileges in the Registry


#1

I’m using Windows 8,1 64-bit with Visual Studio Premium 2012

TLDL: I’m getting an error when I try to set the COM port. The error says “You must have write privileges in the registry for this device in order to modify the device’s advanced settings.” And google is failing me on how to gain this privilege in Windows 8. Help?

The full backstory…

I dusted off my Fez Hydra that I haven’t played around with for over a year. I have a new laptop so went through the process of installing the “Microframework SDK” and “NETMF and Gadgeteer Package 2014 R1”. When I the board into the USB, I got a power light on the board but I couldn’t deploy my test project. It would show this in the output:

Looking for a device on transport 'USB’
Starting device deployment…
Iteration 0
Opening port \?\usb#vid_1b9f&pid_0102#0000000001#{a5dcbf10-6530-11d2-901f-00c04fb951ed}
Attaching debugger engine…
… cannot attach debugger engine!

So I opened MFDeploy and tried pinging and got “Pinging… NoConnection”. (The device showed up as USB - Fez Hydra)

Hmm ok… So I open FezConfig guessing that I need to update the firmware before I can start communicating with the device… it has been a while. I try pinging, no luck at all. The device name is showing up under USB.

Just out of curiosity I check Devices and Printers, and also the Device Manager. The device is showing up just fine. I just can’t get any of my software to talk to it.

Out of desperation, I try to start over by loading up a new TinyBooter following the instructions here: https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra

I choose Method 2 (Ground MISO and Power-cycle/Reset) and my device gets reset. I now see the device as a COM device in Devices and Printers. Great! I start on the instrucitons for setting a COM port, but when I click “Advanced…” under Port Settings I get that dumb error I mentioned at the top of this post: “You must have write privileges in the registry for this device in order to modify the device’s advanced settings.”

Anyone know how to get around this?


#2

Welcome to the forum.

1st: You need to change to com port only if it’s number is greater than 50.
2nd you need to start the Devices and Printers window with admin rights.
Right click the icon and select “Run as administrator” (or similar)
If this is not possible start the device manager with admin rights
WIn+Q
type "Device"
Right click Device Manager
Select run as admin
Go the se serial port section
Double click the COM Port
Advanced settings


#3

Thanks Reinhard, the COM port was COM3, so I didn’t have to change it to proceed.

Here’s some notes for the rest of my install process, in case anyone else gets stuck along the way.

[line]

If you are in Windows 8, you will need to run cmd as Admin. At the very least, this is because it creates a log file in the same path which is under “Program Files” if you used the default install directory. There may be other reasons the batch file will execute only under Admin, I was getting “Access Denied” messages until I ran it as Admin.

Here’s the batch file command you’ll need to run. For example, if your com port is COM3 then you’ll need to enter the command:
C:\Program Files (x86)\GHI Electronics\GHI OSHW NETMF v4.2 SDK\FEZ Hydra\Firmware\FEZ Hydra TinyBooter Updater\UpdateFEZHydra.bat com3
(com must be lower case with no leading 0s)

You can see the COM port in use under Devices and Printers.

After it is done, as the log file says, you must press the reset button to proceed. Otherwise FezConfig will not recognize the device. After resetting, the device shows up as FEZ Hydra in Devices and Printers.

Continue with the procedure outlined here: https://www.ghielectronics.com/docs/127/firmware-tinyclr-update