Main Site Documentation

Win USB Driver install issue


#1

While I await my Cobra II, I have been preparing my windows 7 Home Premium laptop (hp). I DL and installed .NetMF 4.3 (already had VS 2012), uninstalled 4.1, deleted all old GHI inf files from Windows, and installed the NetMF and Gadgeteer Package 2014 R1. I checked the box for the new Win USB drivers, but at that step, the install failed (just that step failed). It started to install, but after the part where you get the dialog to trust drivers from GHI, the progress bar moves forward, pauses, and then rolls back. The install ends with an error indicating the process was interrupted. I tried a reboot but no change each time I attempt the install. Worried I won’t be able to use the Cobra when I get it! Thoughts? Is it looking for the actual hardware to be attached at that point? Something I forgot to uninstall first?

Thanks!

Scott


#2

Actually I. did a clean install last night without any issue. I did not have any hardware plugged in either. The win USB install raced through and did not take any time at all.

I would say that the older version of the win USB drivers did not uninstall correctly. Did you reboot between uninstalling the older version and installing the newer version?


#3

Well, here’s the thing - since I did not have any devices available to plug in to enable seeing the drivers in device mgr, I manually deleted all GHI .inf files from Windows. I did reboot, and have done so a few more times, with no luck. Any ideas on how to clean up further so I can install new drivers?

Thanks!

Scott


#4

@ petdocvmd - While the files may be gone, there is most likely entries in the registry for the driver that the installer is looking for. You may be able to overcome this when you get the Cobra II and you can plug it into your computer to manually set the driver. In the future, it is strongly recommended that you use the installer to run the uninstall process.


#5

@ James - yeah, in hindsight I realize I got ahead of myself and should have just left that step until I had hardware to plug in so I could use device mgr. I actually have my old Panda II, but USB not responding to it - poss because I have it jumpered for serial debug. Will try re plugging without that jumper tonight.

Thx,

Scott


#6

Update: I restored the deleted .inf files from the recycle bin, plugged in my old Panda II w/ serial jumper disabled and then deleted it via dvc mgr. Rebooted and tried install of updated Win USB drivers again…Success!