WiFi with WINC15x0 not scanning

I am trying to get a WINC15x0 based WiFi working but the scan hangs the module and Visual Studio 2019. The connections are working as the Winc15x0Interface.GetFirmwareVersion(); call returns the version number of the Winc15x0.

The call to Scan never returns and the touch stops working as well as the foreground task that I have handling the Modbus.

Eventually I can click around VS but when I click on pause in VS, it hangs and I have to shut it down from task manager.

To try to determine if this is a problem in the debug shims vs the firmware, could you try some ‘printf debugging’ instead of VS. That is, does it still hang if you run outside of the debugger, and use an LED or Debug.WriteLine statements around that same code?

If it doesn’t hang, then it’s somewhere in the debugger firmware or vsix. If it does hang without VS, then it’s a problem in the calling code or underlying firmware. I ask this because there are a few issues in the debugger shim and vsix and it would be good to eliminate them as a possible cause.

I found the fault. There was an error with the schematic symbol and the RESET line was the wrong GPIO name. It works fine after this until I tried to update it via firmware upgrade. Now it seems to be bricked and only sends for version but the upgrade firmware call returns true each time I run it. I’ve posted about this in another entry.