WiFi rs21 problem

@ rockybooth - You’ll want GHI.Networking.dll for the WiFiRS21. You can use GHI.Pins.dll to get a map of the pins:

using GHI.Pins;
using GHI.Networking;

using (var netif = new WiFiRS9110(FEZRaptor.SocketX.SpiModule, FEZRaptor.SocketX.Pin6, FEZRaptor.SocketX.Pin3, FEZRaptor.SocketX.Pin4)) {

Make sure to change SocketX to whichever socket you’re using.

@ John: OK, executed that program which may have worked. Now the Raptor is in a state where it is continuously rebooting, connecting, disconnecting, etc.
Tried FezConfig to try to loader update, after reseting with lrd0,1 pressed. Device shows up as GHI Bootloader Interface on COM7.but cannot seem to update.
I will try to find another Raptor…

@ John:
Tried again. No luck. Hopefully a picture is worth 1k words…

@ rockybooth - Do you see any LEDs come on on the Wi-Fi module when UpdateFirmware is called? Your first post mentioned it was connected to socket 9 but your code shows socket 11.

@ John: I am connected on socket 11. I do not see any LEDs turning on on the RS21.

Then I noticed I was using a 20cm cable. Having spend many hours tracking down spi problems in gadgeteer cables, I shortened the cable to a 10cm cable and it updated the firmware!
This same 20cm cable seems to work fine with a TempHumidSI70.

I would caution anyone using a >10cm cable with spi sensors or devices, particularly where spi reads are used. In my experience writes to a display are fine, but reads from a device with registers, for example, are vulnerable to corruption in longer Gadgeteer cables.

Long, unshielded wires are mostly a problem for fast interfaces. Also breadboards are causing problems sometimes, I noticed.