Wifi Module Change?

Hey There,

I upgraded my computer to Windows 8 (some good and some bad lol). I was making sure my projects compiled. Did GHI remove the .inferface property?

I saw the example code [GHI Electronics – Where Hardware Meets Software] did not use the interface property or use the


It is there. It starts with capital “I” _wifi.Interface. Make sure you have latest SDK.

I am sorry but it will not show up for me. Please see attached images. I tried creating a new project using the Wifi module and it resulted in the same behavior.

What is the type of your _wifi variable? How is it declared in the code?

I am also working on Wifi module, but can’t work on 4.2.
I was also trying this sample, but this sample does not works on 4.2.

@ Weston Bridgewater did you successful use the Wifi module on 4.2?

@ Weston Bridgewater -

Looks like you are using/referencing old driver for the WiFi module. See that you description field in the properties Window shows:

Driver for WiFi_RS21_41 module made by GHI Electronics for Microsoft .NET Gadgeteer

mine shows:

Driver for WiFi_RS21_42 module made by GHI Electronics for Microsoft .NET Gadgeteer

Try updating the reference or reinstalling module drivers.

That worked! Had to reinstall the GHI drivers for 4.2 although I never had any type of 4.1 SDK installed??? Weird.

@ Tzu Hsuan: Yes, I have successfully used the Wifi module in 4.2. It works perfectly using a static IP address. I currently use it to host multiple webpages and pull the latest date/time using NTP. I have had trouble in the past getting the IP address using the DHCP server and trouble when the Wifi disconnects and reconnects (when I turn my Wifi router off/on for durability tests) but I have solved that problem. I have seen your post [http://www.tinyclr.com/forum/topic?id=10058&page=3]. I am going to see if I can get the IP address to populate using this sample code and the DHCP server instead of a static IP [http://www.tinyclr.com/codeshare/entry/605].

If I am successful, I will post my code in your forum topic. Do you have any questions for me?

@ Weston Bridgewater - I have played with it a little bit more and it is actually related to the target framework of a project. You can specify in project properties if you are building 4.1 or 4.2 application. It automatically uses the related version of the driver. I think you had that settings set to 4.1

Thank you Weston.
I use the DHCP.
Debug shows the connect is connected.
but the ip always is “IP=” .
and can’t connect to the internet.
Waiting for your test.
Thank you very much.

@ Tzu - It sounds like you may be running into a problem I’m having. It seems there is a bug or two in the current SDK regarding DHCP. We may have to wait a few more weeks for the next release.


Dear Weston Bridgewater
Are you successfully used the Wifi module in 4.2 with DHCP?

@ Tzu Hsuan - So far we know for sure that Wifi works with some routers but fails with others. See this thread:


Thanks Architect:
The wifi works well with my router in 4.1 SDK but 4.2 not.
I may wait the next SDK released.