Main Site Documentation

WiFi & EMX development system V1.3


#1

Hi,

I spend more then 2 long days to get the NETMF-Wifi module (2.1) running to my attached EMX v1.3 board.

Board has been flashed to the latest CLR, Cables and power on WiFi are checked. WiFi Enable uses the settings (ports) as in the WiFi manual.

Used all combinations of WiFi Security and tried 3 different Routers. But i don’t get it to work (connected)

My Wifi board is equipped with the newer microchip MRF24WB0MA module… Could that be the case?
Is there any way to check if my WiFi module is working anyhow? or if it is detected by the EMX board?

Hope to have this problem fixed quickly because i already designed the EMZ module with WiFi module in a product. The EMX board is bought for software development.

Thanks in advance,


#2

There is an example code under WiFi class in the library documentation, did you try it?


#3

Yes, i used that code as the basis, only changed the WiFi enable code… to:

WiFi.Enable(SPI.SPI_module.SPI1, EMX.Pin.IO2, EMX.Pin.IO26);


#4

are they the latest firmware and the latest SDK you are using?

For easier troubleshooting, I recommend that you try to connected to a network with no security. and use static network settings.

Also you can see WIFI debugging information by attaching the debugger in MFDeploy. It will show you some messages like searching… authenticating… connecting …etc.


#5

Yes, latest SDK and Firmware is in use… also tried with no security. Did not try static IP. I Thought the device needs to connect first and the second step is obtaining an IP from DHCP server. I will try with fixed settings…

A question about MFDeploy… I used that to change my WiFi settings, and used it to see my debug messages, but i am not sure if i used it right in order to see the messages like “searching… authenticating… connecting”… I can see the debug messages that i generate in my code like Debug.Print(“Waiting for WiFi link!”);

Is the procedure for MFDeploy to see the messages like “searching… authenticating… connecting” to select from the menu “Plug-in” -> “Debug” -> ???


#6

The last part of this tutorial explains how to connect the debugging in MFDeploy:
http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX

If this was the way you did it and you still don;t see additional debugging messages then probably the WiFi module is not initialized. Then check the physical connection, is it as described in the user manual?


#7

I have exchanged the flat cable for another one… I set authentication to Open en encryption to None, same in router. checked WiFI of router with the wifi of my cell phone, could connect with cell phone. Forces router to assing IP to MAC of WIFi module… but still nothing :frowning:

In the MFDeploy window i have seen one or two times a message like “Init WiFi module… Done” but sometimes there is nothing like WiFi…

I am out of ideas


#8

Look here for example of what messages you should expect back. We need a copy/paste of the bootup messages so we/you can diagnose what the problem is http://www.tinyclr.com/forum/10/1075/#/3/


#9

I will contact you through Email.


#10

Thanks to mrPositive, we discovered a little bug in the new SPI driver that affects WiFi SPI clock. WiFi will not work with EMX firmware V4.1.5.1 as expected.
We are working on a bug fix and will be available in the next SDK release.

If you need to use WiFi now you need to use firmware V4.1.5.0

http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20SDK(4.1.5.0).zip